Введение

Программа ВЕКТОРИЗАТОР предназначена для векторизации растровых крупномасштабных топографических планов и создания цифровой модели местности на их основе.

В программе реализованы следующие функции:

Интеграция с программой ТРАНСФОРМ.

При наличии лицензии ТРАНСФОРМ пользователь может использовать функционал программы ТРАНСФОРМ непосредственно в программе ВЕКТОРИЗАТОР.

Импорт проектов ТРАНСФОРМ и растровых данных с различными видами привязок.

Просмотр в пользовательской системе координат картографических материалов интернет-сервисов WMS (веб-карты).

Возможность регулировки прозрачности отдельных фрагментов растровых изображений.

Поворот растровых фрагментов на произвольный угол и углы, кратные 90°.

Обрезка прямоугольным контуром.

Наложение на растровые фрагменты многоугольных контуров видимости произвольной формы.

Сшивка растровых фрагментов в единое растровое поле с учетом контуров видимости.

Редактирование растровых изображений с помощью набора инструментов.

Экспорт отредактированной растровой подложки в системы ArcView, MapInfo, PHOTOMOD и др.

Полуавтоматическая векторизация растровых крупномасштабных топографических планов, включающая:

Автоматический поиск и распознавание отметок высот на выбранном фрагменте, создание точек с отметками, равными распознанному значению высоты.

Автоматический поиск точечных тематических объектов на выбранном фрагменте по условному знаку классификатора или по образцу с растра, создание точечных объектов классификатора в найденных местах.

Интерактивное распознавание горизонталей с созданием соответствующего элемента.

Интерактивное распознавание линейных тематических объектов с созданием выбранного линейного объекта из классификатора.

Простой векторизатор (все объекты – в полилинии).

Распознавание произвольного текста в заданной области с созданием объекта Текст.

Стирание с растра распознаваемых объектов.

Создание цифровой модели рельефа по точкам и распознанным горизонталям.

Инструменты для создания и редактирования тематических объектов.

Редактор классификатора.

Инструменты для оформления плана.

Печать чертежей, оформленных в соответствии с нормативными документами; разбивка на листы, если размер чертежа превышает формат печатающего устройства.

Экспорт цифровой модели местности в форматы GDS4, DXF (с возможностью настройки схемы соответствия).

Программа ВЕКТОРИЗАТОР обеспечивает качественную векторизацию черно-белых растровых топографических планов, отсканированных с разрешением не менее 300 dpi. На точность распознавания существенное влияние оказывает и качество отрисовки элементов плана.

Оцифровка топографических планов включает в себя использование полностью автоматических (распознавание отметок, распознавание точечных тематических объектов), полуавтоматических (распознавание горизонталей и линейных тематических объектов), а также ручных инструментов (создание точек и тематических объектов, редактирование объектов).

При необходимости быстрой векторизации можно использовать инструмент Простой векторизатор, позволяющий в автоматическом режиме преобразовать черно-белый растр в набор полилиний и сохранить результат как для работы в комплексе КРЕДО, так и для передачи в сторонние приложения в форматах DXF или MIF/MID.

Для выпуска проектной документации в соответствии с действующими нормативными документами в программу встроен компоновщик чертежей. Он позволяет разместить на стандартных листах отдельные растровые фрагменты произвольной формы, оформить листы чертежей в соответствии с ГОСТом, дополнить чертеж надписями, разбить чертеж формата, превышающего формат печатающего устройства, на склеиваемые листы. Печать производится в масштабе съемки.

Подготовленный в программе ВЕКТОРИЗАТОР чертеж можно сохранить в файл, что позволяет создавать электронные архивы чертежей.

Ваши комментарии к справочной системе

© Компания "Кредо-Диалог"


Интерфейс

Программа переведена на платформу ДАТ 4, что позволило унифицировать ее интерфейс.

Интерфейс программы может быть как классическим, так и ленточным. Основа классического интерфейса – главное меню и панели инструментов главного окна. Основа ленточного интерфейса – лента команд, сгруппированных по вкладкам и группам.

Пользователь может управлять содержимым ленты. На ленту можно добавлять любые команды, содержащиеся в главном меню программы. Кроме того, на ленту могут быть добавлены некоторые команды, не содержащиеся в главном меню программы, (например, выпадающий список для выбора масштаба съёмки). (См. Настройка ленты команд).

Основные блоки классического интерфейса

Главное меню программы (Файл, Правка, Вид и т.д.)

Панели инструментов главного окна

Строка поиска, настройка рабочей области, справка

Паркуемые окна

Панели инструментов паркуемых окон

Строка состояния

Основные блоки ленточного интерфейса

Главное меню

Лента команд

Панель быстрого доступа

Строка поиска

Кнопка «Справка»

Строка состояния

Главное меню

Главное меню вызывается нажатием на большую круглую кнопку в верхней левой части окна программы (для оформлений в стиле MS Office 2007) или на заголовок вкладки Файл (для оформлений в стиле MS Office 2010 и 2013).

В главное меню программы вынесены команды, обычно содержащиеся в меню Файл. Кроме того, в меню содержится пункт для настройки разделяемых ресурсов (геодезической библиотеки) и кнопка вызова окна настроек программы.

В начало

Лента команд

На ленте команды сгруппированы по вкладкам и группам. Команды, размещённые на ленте, предназначены для вызова основного функционала программы.

Команды, специфичные для какого-либо окна, располагаются на панели управления этого окна и дублируются в меню окна. Например, для окна План это команды навигации, управления фильтрами, активизации захватов и т.д., для окон с таблицами – команды настройки представления, получения отчетов и работы со строками.

При активации команды (построение подписей и примитивов, фрагментов чертежей), выполнение которой предполагает работу с окном План, это окно активируется.

Вкладки ленты по умолчанию:

Главная

Инструменты

Оформление

Вид

Главная

На этой вкладке сгруппированы команды, позволяющие выполнить наиболее вероятную и наиболее часто используемую технологическую цепочку действий по формированию сложных растров:

загрузка растра в проект (растр, космоснимок, со сканера),

загрузка в проект высотных данных (матриц высот),

стандартные операции редактирования (вырезать, копировать, вставить, удалить),

создание точек привязки,

трансформация фрагментов,

некоторые команды для работы с фрагментами (повернуть, объединить, обрезать),

экспорт проекта или его фрагментов в форматы других программных продуктов.

Инструменты

На этой вкладке сгруппированы команды, предназначенные для работы с фрагментами:

управление отображением и блокировка (заблокировать, скрыть, отобразить всё),

объединение и обрезка

работа с областями видимости (создать по точкам привязки, сбросить, не учитывать),

изменение вертикального порядка фрагмента (выше/ниже, на передний/задний план),

ориентация фрагмента (поворот и отражение),

регулировки цвета (яркость, контраст, гамма, глубина цвета, замена цвета),

рисование (карандаш, заливка),

другие инструменты (размытие, резкость, залить дыры, убрать пятна).

Оформление

Вкладка содержит команды для вызова доступных построений подписей, размеров, примитивов, инженерно-геодезических расчётов и команду растеризации (рендеринга векторной информации на растр).

Также на этой вкладке содержатся команды для работы с фрагментами чертежей (создание, задание номенклатуры, поиск) и передачи их в чертёжную модель.

Вид

Вкладка содержит команды для управления отображением элементов интерфейса и окнами. Также на вкладке могут быть размещены элементы для настройки окна План (цвет фона графического окна, тип и цвет перекрестий координатной сетки и т.д.).

В начало

Панель быстрого доступа

Панель быстрого доступа располагается в левой части заголовка окна программы.

Пользователь может добавить на панель быстрого доступа все необходимые ему кнопки и свернуть ленту до заголовков. Таким образом, с программой будет удобно работать даже на экранах с небольшим разрешением.

В начало

Строка поиска

Строка быстрого поиска команды расположена справа в строке главного меню (классический стиль) или в строке с заголовками вкладок ленты (лента команд).

Функция быстрого поиска команды по её имени позволит пользователю найти необходимую команду, если он знает, как она может называться.

При вводе названия команды под полем появляется выпадающий список с командами, названия которых содержат введённый пользователем текст.

Выбор одного из пунктов выпадающего списка вызывает соответствующую команду.

В начало

Кнопка «Справка»

Кнопка Справка расположена справа в строке главного меню (классический стиль) или в строке с заголовками вкладок ленты (лента команд).

Нажатие на кнопку вызывает выпадающее меню с пунктами для запуска справочной системы и вызова диалога О программе.

В начало

Строка состояния

Строка состояния в нижней части окна приложения содержит информацию о рабочей области, текущей системе координат, индикатор модификации проекта, отображает координаты под курсором, имена фильтров выбора и видимости, иконку активного построения.

В начало


Настройка Интерфейса

Для настройки интерфейса предусмотрена кнопка Рабочая область с выпадающим меню. Кнопка расположена в правом верхнем углу окна приложения.

По кнопке Рабочая область вызывается меню, содержащее список конфигураций рабочих областей, пункт для вызова окна настроек конфигураций рабочих областей, команды для переключения между стилями и вариантами оформления интерфейса, вызова окна настроек ленты и панелей инструментов.

Выбор стиля и варианта оформления интерфейса

Настройка ленты команд и панелей инструментов

Перемещение и группировка окон

Настройка и сохранение конфигураций рабочих областей

Выбор стиля и варианта оформления интерфейса

Стили и оформление интерфейса переключаются "на лету".

Как к классическому, так и к ленточному стилю интерфейса может быть применено любое оформление. Исключение составляет Классическое оформление – оно может быть применено только к классическому стилю интерфейса.

Если активирован стиль интерфейса Лента команд, при выборе классического оформления стиль автоматически переключается на Меню и тулбары. При изменении стиля интерфейса с Лента команд на Меню и тулбары оформление автоматически переключается на Классическое.

В начало

Настройка ленты команд и панелей инструментов

Настройка ленты команд и панелей инструментов производится в окне настроек, которое можно вызвать из меню Рабочая область/Команды.

Окно настроек содержит несколько вкладок: Панели инструментов, Лента команд, Панель быстрого доступа. В нижней части окна располагаются кнопки для импорта, экспорта и восстановления настроек.

Для каждой конфигурации рабочей области может быть создана отдельная конфигурация команд ленты и панелей инструментов. Например, для конфигурации Компактная большая часть команд будет без подписей (только иконки).

Если активирован классический стиль интерфейса, вкладки для настройки ленты команд и панели быстрого доступа недоступны.

На вкладке Лента команд пользователю доступны следующие операции: создание, удаление, перемещение, переименование и настройка вида вкладок ленты, групп команд, групповых и отдельных команд, добавление разделителей между командами.

На вкладке Панель быстрого доступа можно редактировать содержимое панели быстрого доступа, которая размещается в левой части заголовка окна программы. Пользователю доступны следующие операции: создание, удаление, перемещение, переименование и настройка вида групповых и отдельных команд, добавление разделителей между командами.

На вкладке Панели инструментов можно настроить содержание панелей инструментов главного окна (для классического стиля интерфейса) и панелей инструментов паркуемых окон (настройка общая для всех типов интерфейса).

При активированном ленточном стиле интерфейса настройка панелей инструментов главного окна недоступна.

Для импорта и экспорта настроек предназначены кнопки Импорт и Экспорт.

В начало

Перемещение и группировка окон

С помощью мыши можно выполнить захват и перемещение окна или группы вкладок.

Областью захвата для окна или вкладки является заголовок, для группы вкладок – область заголовка, свободная от вкладок или крайняя левая область заголовка со значком [image] (для классического интерфейса). С помощью захватов и перемещений можно выполнять группировку и парковку окон, а также переводить окна в плавающее состояние.

Перемещение и парковка окна или группы вкладок производится следующим образом:

Левым щелчком в области захвата выберите окно, вкладку или группу вкладок. Если окно или группа вкладок находились в свернутом состоянии, их необходимо предварительно развернуть.

Удерживая кнопку мыши переместите окно или группу вкладок в нужную область экрана. По мере движения курсора программа автоматически предлагает место для парковки, освобождая пространство рядом с центральной областью и подсвечивая существующие окна и группы вкладок для включения в их состав паркуемого окна.

Если необходимо сформировать группу вкладок, подведите перемещаемое окно примерно в центр окна, с которым нужно сгруппировать паркуемое окно (окно подсветится).

Выбрав нужную область для парковки, отпустите клавишу мыши.

Перетаскиванием вкладок можно изменить их порядок в группе. По аналогичному сценарию производится перемещение окна в другую группу вкладок и перевод окна в плавающий режим.

В начало

Настройка и сохранение конфигураций рабочих областей

Для быстрого изменения состава, размера и расположения видимых окон и панелей инструментов предусмотрен специальный механизм управления конфигурациями рабочей области.

Для сохранения текущего размещения окон и панелей служит команда Сохранить текущую конфигурацию [image] диалога Конфигурации рабочей области (Рабочая область/Конфигурации).

После сохранения имя конфигурации включается в список конфигураций.

Активизировать ранее сохраненную конфигурацию можно командой Применить выбранную конфигурацию [image] диалога Конфигурации рабочей области.

Диалог позволяет также переименовать выбранную конфигурацию или удалить конфигурацию из списка.

Механизм управления конфигурациями рабочей области особенно полезен при работе с небольшим экраном и при частой смене прикладного характера решаемых задач, когда требуется быстрое и кардинальное изменение состава окон.

В начало


Исходные данные

В программе обрабатываются растровые изображения любой глубины цвета (черно-белые, монохромные, цветные), отсканированные непосредственно в ВЕКТОРИЗАТОР или импортированные из файлов следующих форматов:

схемы, планы, планшеты, листы топокарт, иные картматериалы в следующих форматах: BMP, GIF, TIFF (GeoTIFF), JPEG, JPEG2000, PNG, CRF, ECW, RSW;

растровые файлы BMP, GIF, TIFF, PNG, JPEG, JPEG2000, ECW с внешними файлами-спутниками привязок в форматах MapInfo (TAB), Worldfile (WLD, BPW, JGW, PGW, TFW, EWW), CREDO DOS (TIE);

растровые файлы с встроенной информацией о привязке в форматах CRF, ECW, RSW, TIFF (GeoTIFF);

матрицы высот в форматах SRTM ASCII, GeoTIFF, MTW 2000, TXT;

файлы с информацией о рациональных полиномиальных коэффициентах для космических снимков – RPC.

Также в программе можно работать со сверхвысокодетальными спутниковыми снимками, просматривая их через сервисы Google Maps и Экспресс.Космоснимки.

Загрузка и трансформация данных в режиме удаленного доступа (по протоколу WMS) реализована через сервис Экспресс.Космоснимки, который разработан и поддерживается специалистами "СКАНЭКС". Загрузка и трансформация данных сервиса Google Maps также реализована в режиме удаленного доступа (по протоколу WMS), для просмотра доступны четыре типа данных: карты, спутник, рельеф и гибрид (спутник и карта совместны).

Трансформация неподготовленных, в том числе и сканированных растров, а также ортокоррекция космоснимков доступны при наличии лицензии ТРАНСФОРМ.


Выходные данные

ВЕКТОРИЗАТОР позволяет экспортировать результаты векторизации растров:

полилинии и точки в MapInfo;

дополнительно к перечисленному - точечные, линейные, площадные объекты, горизонтали как структурные линии для восстановления поверхности в формат GDS4 для дальнейшей работы с ЦММ в продуктах CREDO III;

дополнительно к перечисленному - поверхность в виде элементов 3D-face, горизонталей, бергштрихов и подписей горизонталей, подписей отметок точек в DXF.

Также предусмотрена возможность экспорта растровых изображений из проекта в следующие форматы:

растровые файлы в формате TMD версий 3.x – 4.0;

трансформированные файлы (проект, фрагмент) без информации о привязке в форматах BMP, GIF, JPEG, TIFF (GeoTIFF), CRF, RSW;

трансформированные файлы с встроенной информацией о привязке в форматах CRF, TIFF (GeoTIFF), RSW. В формате GeoTIFF сохраняются сведения о геопространственной привязке;

трансформированные файлы с информацией о привязке в файлах-спутниках, в форматах Worldfile (c BMP – WLD, BPW; c GIF – WLD, GFW; c JPEG – WLD, JGW; c PNG – WLD, PGW; c TIFF – WLD, TFW), MapInfo (c BMP, GIF, JPEG, PNG, TIFF - TAB), CREDO DOS (c BMP - TIE);

матрицы высот в формате TXT, GeoTIFF.

Проекты программы ВЕКТОРИЗАТОР можно сохранить в файлы формата CVD.

Для выпуска проектной документации в соответствии с действующими нормативными документами в программу встроен проект Чертеж. Он позволяет отдельные растровые фрагменты произвольной формы разместить на стандартных листах, оформить листы чертежей в соответствии с ГОСТом, дополнить чертеж надписями, разбить чертеж формата, превышающего формат печатающего устройства, на склеиваемые листы. Печать производится в масштабе съемки. Подготовленный в ВЕКТОРИЗАТОР чертеж можно сохранить в файл формата DDR4, что позволяет создавать электронные архивы чертежей, а также экспортировать в файлы различных форматов (PDF, DXF, SVG).


Чертежи

На любом этапе работы растровые фрагменты можно вывести на печать. Перед тем как вывести проект на печать, необходимо скомпоновать чертеж проекта.

Создать чертеж можно двумя способами:

Непосредственно из проекта TMD при помощи команд меню Чертежи, позволяющих выбрать параметры создаваемого чертежа (формат, штампы и т.п.), а также с помощью команд меню Оформление добавить графические примитивы, тексты и т.д., и передать все видимые данные заданного фрагмента модели в проект Чертеж (чертежную модель).

При помощи команды Файл/Создать/Чертеж создается пустой проект Чертеж, после чего пользователь может вставить любой проект TMD (полностью), документ (html), добавить графические примитивы, тексты и т.д.

Формирование графических документов производится по принципу WYSIWYG, т.е. "что вижу, то получаю". Выпуск графических документов в общем случае состоит из следующих этапов:

подготовка вида информации, необходимой для вывода на печать в графическом окне проекта TMD;

создание в графическом окне проекта TMD области (фрагмента) проекта, которая должна попасть в чертеж, и переход в проект Чертеж;

редактирование графического документа;

печать чертежа и (при необходимости) экспорт.


Режимы работы программы ТРАНСФОРМ

Режимы работы программы

Программа предоставляет два режима работы:

Режим подготовки растровой подложки - основной режим работы в программе (по умолчанию).

Режим используется для создания проекта, сканирования карт и схем либо импорта исходных растровых фрагментов, редактирования растровых изображений фрагментов, создания и редактирования локальных, местных или национальных (проекции Transverse Mercator) систем координат, задания точек привязки, трансформации и привязки растра к заданной системе координат и/или склейки и привязки растра к системе координат исходного (выбранного) фрагмента, наложения контуров видимости, задания и выбора фрагментов, которые будут выводиться на чертеж.

Режим компоновки чертежа (работа в отдельном окне чертежной модели ЧМ) - переход в окно ЧМ возможен при помощи команд создания/открытия проекта чертежа (из окна подготовки растровой подложки).

Режим позволяет разместить фрагменты на чертеже, заполнить штампы, ввести пояснительные тексты, вставить подготовленную заранее ситуационную схему из файла BMP, указать направление на север.

При переходе из одного режима в другой меняются меню, панели инструментов и строка состояния в соответствии с набором операций, который может выполняться в текущем режиме.


Виды и режимы курсора

В программе в зависимости от поставленной задачи курсор может иметь следующий вид:

Вид курсора по умолчанию (вне построений)
Курсор-стрелка
Режим указания
Режим захвата точки
Режим захвата ребра, режим для создания текстовой строки на чертеже
Импорт области Веб-карты
Обрезать
Масштабировать рамкой
Масштабировать в реальном времени
Переместить (панорамировать)
Повернуть объект
Повернуть объект

В разных областях экрана курсор имеет разный вид. В области меню или панелей инструментов курсор принимает вид стрелки. В рабочей области экрана, в зависимости от выбранной операции курсор, меняет свой вид.

При работе с фрагментами используется несколько режимов построений:

Режим захвата точки используется при построении и редактировании контуров и определяет привязку к точке, попавшей в зону захвата курсора, независимо от того, совмещена захватываемая точка точно с перекрестием курсора или нет. Этот режим используется также при добавлении или редактировании опорных точек.
Режим захвата ребра предназначен для редактирования контуров видимости, фрагментов чертежа. Курсор меняет свой вид, когда попадает на ребро контура.
Режим указания используется при создании прямоугольной маски для обрезки, контуров видимости, фрагментов чертежа, построении линий, прямоугольников и многоугольников на чертеже, а также при выборе фрагментов для чертежа и удалении контуров видимости.

Захват осуществляется по левой клавише мыши. Отказ от захвата в процессе построения контура происходит по правой клавише мыши.

См. также

Интерактивное редактирование графических элементов


Настройка цветов

Параметры программы

Для комфортного восприятия пользователь может выбрать и установить цвета для:

цвета фона;

цвета выделенных элементов.

Также можно выполнить общие настройки: делать ли резервные копии, установить автосохранение, размер истории изменений, установить временную папку приложения, настроить вид отображения таблиц Фрагменты и Точки привязки.

Данные настройки выполняются в диалоге Параметры, который вызывается командой Параметры программы меню Файл.


Библиотека геодезических данных

Данные, которые являются общими для всех проектов, хранятся в так называемой геодезической библиотеке. Эти данные вводятся и редактируются в диалоге Библиотека геодезических данных.

Диалог вызывается командой Геодезическая библиотека из меню Файл и позволяет отредактировать параметры для используемых в проекте систем координат, эллипсоидов, геоидов и т.д.


Диалог Свойства проекта

Свойства проекта

Диалог вызывается командой Свойства проекта [image] меню Файл (окно плана).

В диалоге можно настроить или просмотреть свойства проекта: данные проекта, масштаб съемки, систему координат, единицы измерения, алгоритм интерполяции цвета и преобразование координат опорных точек.

Диалог Свойства проекта содержит следующие разделы:

Карточка проекта

План

Трансформ ация

Единицы измерения и точность


Карточка проекта (Свойства проекта)

Карточка проекта

Раздел Карточка проекта (диалога Свойства проекта) включает в себя следующие разделы:

Общие сведения

Раздел включает текстовые поля, которые затем будут использоваться для зарамочного оформления чертежей: ведомство, организация, объект .... и др.

Параметры

Раздел Параметры включает в себя:

Масштаб съемки – выбор из выпадающего списка. Масштаб съемки определяет степень детализации отображения элементов проекта в окне План и на чертеже (стиль и размер элементов чертежа, характер разбиения на планшеты, параметры координатной сетки).

Масштаб съемки запрашивается программой, когда выполняется операция привязки планшета по четырем углам и масштабу.

Отображать номер зоны – настройка на отображение номера зоны, значение выбирается из выпадающего списка.

Модель геоида – выбор модели геоида из библиотеки геодезических данных

Классификатор

В параметрах настраивается путь к файлу классификатора, выполняется выбор системы кодирования и полевого кодирования.

Система кодирования по умолчанию - Базовый код.

Полевое кодирование (значение) выбирается из выпадающего списка.

Системы полевого кодирования дополняются и редактируются в геодезической библиотеке.

Система координат

Система координат – задается система координат (СК), которая будет использоваться в проекте, импортом из геодезической библиотеки либо из EPSG. Значение выбирается из выпадающего списка.

Для импорта параметров систем координат из базы (реестра) хранения описаний СК (EPSG) следует знать код системы координат.


План (Свойства проекта)

План

Раздел План (диалога Свойства проекта) включает в себя следующие разделы:

Точки привязки

В разделе задаются параметры отображения в окне План точек привязки - опорных и контрольных. Из выпадающих списков выбираются значения для толщины линий, цвета и размера крестов.

Применимо только при наличии лицензии ТРАНСФОРМ.

Координатная сетка

Для координатной сетки задаются: шаг сетки, толщина, цвет линий, размер крестов в узлах.

Поверхность рельефа

Параметры. В разделе выполняются настройки параметров создания и отображения поверхности.

Модель.

Тип интерполяции. Значения: кусочно-гладкая, кусочно-линейная. Параметр управляет методом интерполяции высот точек поверхности.

Сгущать триангуляцию. При выключенном параметре (Нет) строится обычная триангуляция Делоне. При включенном параметре (Да) поверхность сгущается путем добавления в триангуляцию новых точек под условием наименьшей кривизны формируемой поверхности. Сгущение триангуляции позволяет корректно строить поверхность при неравномерном расположении точек (сгруппированные точки с большими пустыми пространствами между ними). При сгущении триангуляции возможно образование форм рельефа, не подтвержденных точками модели.

Изолинии. Настраиваются шаг изолиний, цвет, тип и толщина линии.

Утолщенные изолинии. Настраиваются шаг утолщенных изолиний, цвет и толщина линии.

Подписи изолиний. Настраивается шрифт подписей.

Бергштрихи. Настраивается длина формируемых бергштрихов.

Градиент. Настраивается прозрачность градиентной заливки.

Матрицы высот (DEM)

В этом разделе настраивается цветовая палитра для отображения матриц высот. Настройка распространяется на все загруженные и загружаемые в проект матрицы высот.

Блок настроек состоит из таблицы, в которой производится настройка цветов, и области предварительного просмотра.

Цвета для высот можно менять, добавлять строки для более детального представления высот с помощью команды контекстного меню Добавить строку, либо удалить строку с помощью команды Удалить строку.


Трансформация (Свойства проекта)

Трансформация

Применимо только при наличии лицензии ТРАНСФОРМ.

В разделе Трансформация (диалога Свойства проекта) задается алгоритм интерполяции цвета и настройка на блокировку фрагментов после трансформации. Выбор алгоритма интерполяции цвета влияет на качество изображения, получаемого при трансформации и склейке.

Метод интерполяции цвета – значение выбирается из выпадающего списка. Пункты списка: Ближайших соседей (быстрая), Билинейная (качественная).

Алгоритм ближайших соседей – применяется для растровых изображений любой глубины цвета и обеспечивает удовлетворительные результаты при операциях над цветными и монохромными (256 оттенков серого) изображениями, сами операции выполняются намного быстрее, чем при билинейном алгоритме.

Алгоритм билинейный – самый качественный из предлагаемых алгоритмов. Значительно замедляет процесс трансформации, поворота и некоторых других операций. Этот алгоритм рекомендуется использовать для получения качественных цветных и монохромных (256 оттенков серого) фрагментов. Для черно-белых 1-битных фрагментов его применять не имеет смысла.


Единицы измерения и точность (Свойства проекта)

Единицы измерения и точность

В разделе Единицы измерения и точность (диалога Свойства проекта) указываются единицы измерения для величин: угловых, линейных, температуры, давления, геодезических и высотных координат, расстояния, а также точность их представления.

Значения для единиц измерения и точность представления выбираются из выпадающих списков.


Настройка таблиц

При работе с таблицами пользователь может управлять их параметрами – видимостью и расположением колонок, выравниванием информации в ячейках таблицы и т.д.

Изменение имени таблицы, заголовков колонок, настройка видимости и ширины колонок, выравнивание заголовка и ячеек выполняется в диалоге Настройка представления таблиц, вызываемого командой Настройки из контекстного меню таблицы или кнопкой Настройки [image] локальной панели инструментов таблицы.

Находясь в таблице, можно интерактивно изменить порядок расположения столбцов и их ширину. Двойной щелчок на строке заголовка по границе между колонками устанавливает ширину по содержимому колонки.

Вид таблицы можно настроить также с помощью контекстного меню, вызываемого правым щелчком мыши в области заголовка любого из столбцов таблицы.

Содержимое таблицы можно отсортировать по выбранному столбцу.

Настройки таблиц сохраняются за проектом.


Выбор данных

Команды выбора применяются для операций копирования, удаления, экспорта, изменения свойств определенных данных проекта.

Существуют два способа выбора – непосредственно в соответствующей таблице либо в графическом окне.

В системе можно использовать как одиночный так и групповой выбор данных.

Для выбора группы элементов в графическом окне используют кнопки Выбрать рамкой [image] и Выбрать контуром [image] на локальной панели окна План. Выбирать данные можно также при помощи клавиш <Shift> и <Ctrl>. При этом для захвата доступны элементы, которые удовлетворяют условиям фильтра выбора.

При нажатой клавише <Shift> элементы добавляются в существующую группу, повторный выбор не исключает элементы из группы,
если нажата клавиша <Ctrl>, то захват работает в режиме добавления элементов в группу, а повторный выбор исключает элементы из группы,
при захвате элемента без нажатых клавиш <Shift> или <Ctrl> создается новая группа, а существующая группа расформировывается.

Выделение элементов снимается при любом щелчке в области графического или табличного окна.

Если выбраны однотипные элементы, то их общие свойства отображаются в окне Свойства, где можно их отредактировать.

Если значения какого-либо свойства отличаются для элементов группы, то в соответствующей ячейке отображаются символы <...>. При этом ячейка доступна для редактирования и в нее можно ввести любое допустимое значение данного свойства.

Выбранные элементы в таблицах выделяются фоном, а в графическом окне – специальным цветом, заданным в диалоге Параметры программы.

Снять выделение элементов можно щелчком в свободной области графического окна или таблицы.


Дополнительные столбцы в таблице Фрагменты

К дополнительным столбцам в таблице Фрагменты относятся: Вложение и Комментарий.

Столбец Комментарий служит для оперативного добавления и просмотра текстовой информации, связанной с данной строкой таблицы.

Символ "выноски" [image] в таблице показывает, что для соответствующего элемента имеется комментарий.

Для создания или изменения комментария необходимо в поле Комментарий двойным щелчком мыши открыть диалоговое окно Значение, в котором можно вводить, редактировать и удалять текст.

Столбец Вложение предназначен для прикрепления к необходимому фрагменту одного или нескольких файлов.

На наличие вложений указывает символ "скрепки" [image].

Чтобы добавить, открыть или удалить вложения, необходимо в поле Вложение двойным щелчком мыши открыть диалог Вложения.


Поиск в таблицах

В таблицах может быть выполнен поиск строк, значения полей которых удовлетворяют заданному условию (команда Найти [image] локальной панели инструментов соответствующей таблицы).

В диалоге Найти в таблице необходимо задать наименования полей , выбрать условия поиска и указать необходимое значение.

Диалог Найти в таблице может содержать два логических выражения. В верхней строке задается первое условие поиска, устанавливается переключатель в нужное положение (И, ИЛИ), затем в нижней строке задаются значения второго логического выражения.

Нижняя строка может быть пустой. Тогда поиск производится только по условию, заданному в первой строке.

В группе Условие:

Выберите наименование столбца из выпадающего списка. Поле с наименованием столбца в нижней строке может быть пустым.

Из выпадающего списка выберите логическую операцию для данного типа поля. В нижней строке это поле доступно для редактирования, если непусто наименование столбца.

Введите значение для поиска в правое поле.

Установите переключатель условия И, ИЛИ в нужное положение.

При установленном флажке В обратном направлении поиск выполняется от текущей строки вверх. В противном случае – от текущей вниз.

Флажок С учетом регистра доступен только для строковых полей. Если флажок установлен, то при сравнении строк учитывается регистр.


Фильтры видимости

Существует возможность отключать видимость отдельных элементов проекта, отображаемых в окне План и выводимых на чертеж.

Фильтр видимости предназначен для управления содержимым графического окна и при чрезмерной детальности изображения позволяет отключать видимость элементов заданного типа. Над невидимыми элементами не может быть выполнена никакая операция, включая выбор, копирование, удаление, экспорт и т.д.

Работа с фильтрами видимости осуществляется с помощью кнопки Фильтр видимости [image] на локальной панели инструментов окна План.

При нажатии на стрелку выпадает меню, содержащее:

перечень именованных фильтров видимости. При щелчке по наименованию фильтра данный фильтр становится активным;

команду Изменить текущий фильтр, которая вызывает диалог Изменить текущий фильтр, позволяющий внести изменения в фильтр видимости;

команду Настроить, вызывающую диалог Настроить, содержащий список всех именованных фильтров видимости. Диалог позволяет создавать новые фильтры видимости, а также редактировать и удалять существующие фильтры.


Фильтры выбора

Для корректного выполнения выбора нужного элемента проекта в графическом окне необходимо настроить фильтр выбора.

Для захвата доступны элементы, удовлетворяющие условиям фильтра выбора. На панели инструментов графического окна присутствует кнопка Фильтр выбора [image], вызывающая диалог Фильтр выбора. При нажатии на стрелку выпадает меню, содержащее:

перечень именованных фильтров выбора;

команду Изменить текущий фильтр, которая вызывает диалог Изменить текущий фильтр;

команду Настроить, вызывающую диалог Настроить, содержащий список всех именованных фильтров выбора. Диалог позволяет создавать новые фильтры, редактировать и удалять существующие фильтры.

Относительно выбранных в графическом окне элементов может быть выполнена групповая операция (редактирование свойств, удаление, отключение/восстановление и т.д.) или произведены интерактивные действия, такие как поворот или перемещение (для текстов и элементов чертежа).


Поиск элементов в окне План

В системе предусмотрена возможность поиска элементов в окне План. Для этого необходимо выбрать элемент (-ы) в таблице (Фрагменты или Точки привязки), а затем нажать кнопку Показать на схеме [image] на панели инструментов табличного редактора. При этом произойдет автомасштабирование графического окна, а искомые элементы выделятся.


Работа с Классификатором

Темы раздела:

Общая информация

Технология создания/редактирования ТО классификатора

Создание ТО

Параметры условного знака

Семантические свойства

Схема соответствия экспорта


Работа с тематическими объектами. Рельеф. Оформление

В этой статье:

Работа с тематическими объектами

Интерактивное создание ТО

Редактирование ТО

Создание ТО в окне Тематические объекты

Создание поверхности

Оформление чертежа в окне План

Работа с тематическими объектами

Для работы с тематическими объектами (ТО) необходимо указать путь к классификатору в меню Файл/Свойства проекта/Классификатор.

При создании и редактировании ТО соответствующая информация отображается в окнах Слои ТО и Тематические объекты. В окне Слои ТО отображена иерархическая структура слоев классификатора, связанного с данным проектом. В окне Тематические объекты отображается список объектов выбранного слоя ТО и их семантическое описание (если объекты из этого слоя ТО созданы в модели).

Для работы с тематическими объектами в окне План используются следующие команды меню Рельеф и ситуация:

Создать/редактировать ТО

ТО по линии

ТО по прямоугольнику

ТО по оружности (дуге)

ТО по существующему

В начало

Интерактивное создание ТО

Для интерактивного создания ТО используются следующие команды меню Рельеф и ситуация:

Создать/редактировать ТО. Команда предназначена для создания или редактирования тематического объекта (ТО) в окне План.

ТО по линии, ТО по окружности (дуге), ТО по прямоугольнику. При выборе команд программа предложит сначала построить линию. Затем на основе этой линии можно создать одновременно и линейный, и площадной, и точечные объект(ы).

ТО по существующему. Команда предназначена для создания точечных, линейных и площадных объектов по точкам существующих линейных и площадных объектов.

Команда Создать/редактировать ТО является универсальным способом создания ТО. Для того чтобы создать любой объект, независимо от типа (ТТО, ЛТО, ПТО), необходимо выбрать его в окне Слои ТО. В зависимости от выбранного объекта классификатора будут создаваться соответствующие объекты.

В начало

Редактирование ТО

Существующие ТО можно редактировать. Примеры редактирования:

Создание нового узла на линейном тематическом объекте (ЛТО)

Выделите ТО в окне План, кликнув по нему. Выбранный ТО изменит цвет в соответствии с настройкой для выделенных объектов.

Подведите курсор к линейному сегменту ЛТО (курсор примет вид Захват линии) и укажите положение нового узла.

Переместите созданный узел в необходимое местоположение.

Если навести курсор на узел выбранного ЛТО и вызвать контекстное меню (правой кнопкой мыши), то можно разрезать его на два объекта либо удалить выбранный узел.

Продолжение построения уже созданного ЛТО либо ПТО

Выделите уже созданный ЛТО или ПТО в окне План и вызовите команду Создать/редактировать ТО меню Рельеф и ситуация.

В графическом окне укажите следующую точку для построения ТО.

Перемещение ТО

Выбранные в окне План тематические объекты можно свободно перемещать. Курсор при этом должен быть в режиме перемещения объекта. Редактирование положения объектов производится стандартными интерактивными методами, позволяющими выполнить масштабирование, перемещение и поворот, а также изменить положение вершин границы объекта.

Тематические объекты, не опирающиеся на точки ГНСС и построений координатной геометрии, могут быть свободно перемещены в окне План. Такие объекты при выделении отображаются в рамке. При перемещении курсор должен быть в режиме перемещения объекта [image].

Удаление ТО

Для того чтобы удалить ТО, необходимо выбрать его в графическом окне и нажать клавишу <Delete>, либо удалить строку с этим объектом в окне Тематические объекты.

Редактирование ЛТО

Для редактирования линейных тематических объектов предназначены команды меню Рельеф и ситуация: Обратить ЛТО, Продолжить ЛТО, Сшить ЛТО, Разрезать ЛТО, Замкнуть ЛТО.

В начало

Создание ТО в окне Тематические объекты

Создавать ТО можно не только интерактивно в графическом окне, но и непосредственно в окне Тематические объекты.

Для этого выполните следующее:

Выберите объект в окне Слои ТО.

В окне Тематические объекты активизируйте команду Вставить строку.

Для создания, например, точечного объекта следует в столбце Точки ввести номер точки, на которой будет создан объект.

Чтобы создать объект с тем же кодом на следующей точке, следует нажать на клавиатуре клавишу <Стрелка вниз>.

Для создания линейных и площадных объектов, после выбора команды Вставить строку необходимо активизировать команду Добавить строку.

В столбце Точки введите номер точки, с которой будет начинаться объект. С помощью клавиши <Стрелка вниз> добавьте точки, по которым будет создан объект. При необходимости в таблице для линейных либо для площадных объектов можно изменить порядок следования точек (необходимо перетянуть строку с точкой в нужное место).

Аналогично можно редактировать уже созданные ТО.

В начало

Создание поверхности

На основе точек модели можно создавать цифровую модель рельефа командой Создать поверхность меню Рельеф и ситуация. В построении участвуют точки с признаком отношения к рельефу Рельефная. Рельефные ЛТО так же участвуют в построении поверхности, как и структурные линии. Построенная цифровая модель рельефа отобразится в окне План.

Настройки отображения градиентов поверхности можно изменить в команде Настройка градиента меню Рельеф и ситуация.

Параметры отображения поверхности настраиваются в диалоге Свойства проекта (в разделе План, группа Поверхность рельефа).

В начало

Оформление чертежа в окне План

Команды меню Оформление служат для дополнения графической части проекта необходимыми текстами, графическими примитивами, подписями и т.д. Все построения примитивов (линий, прямоугольников, окружностей и т.д.) выполняются интерактивно в графическом окне, при этом свойства таких примитивов (толщина, цвет и т.д.) настраиваются в окне Свойства.

Редактирование положения созданных объектов производится стандартными интерактивными методами, позволяющими выполнить масштабирование, перемещение или поворот объекта, а также изменить положение границы объекта.

Выход из построения производится клавишей <Esc> или правым кликом мыши. Для удаления объекта необходимо выделить его в графическом окне и, нажав правую кнопку мыши, выбрать команду Удалить из контекстного меню либо нажать клавишу <Delete>.

В начало


Настройки системы

Параметры настройки инсталлированной программы ВЕКТОРИЗАТОР изначально установлены по умолчанию и могут быть перенастроены пользователем на любом этапе работы с проектом.

Для организации рабочего пространства предназначены команды меню Рабочая область (См. Настройка интерфейса). Пользователь может расположить окна так, как ему удобно, перемещая и группируя их.

Для настройки предлагаемых программой цветов элементов проекта и рабочего экрана, задания общих системных настроек предназначена команда Параметры программы меню Файл. Настроенные параметры сохраняются в программе для последующих сеансов работы с проектом.

Масштаб съемки, который будет использоваться для отрисовки координатной сетки в активном проекте, задается в диалоге Свойства проекта в разделе Параметры (команда Свойства проекта меню Файл).

В разделе Трансформация диалога Свойства проекта можно выбрать алгоритм интерполяции цвета (изображений). Следует учитывать, выбор алгоритма интерполяции цвета влияет на качество изображения, получаемого при трансформации и склейке.

В разделе Единицы измерения и точность диалога Свойства проекта укажите единицы измерения и точность, которые будут использоваться для задания координат точек привязки.

В меню Вид задайте отображение панелей инструментов и окон программы.


Сканирование исходного материала

Сканирование картографического материала предназначено для получения электронной подложки.

Если на компьютере установлено несколько сканеров, с помощью команды Файл/Сканирование/Выбрать источник выберите нужный сканер.

Если в системе установлено только одно устройство, то оно выбрано всегда по умолчанию.

Для сканирования картографического материала и получения электронной подложки предназначена команда Файл/Сканирование/Сканировать.

Каждый тип сканера комплектуется своей собственной программой, которая позволяет настраивать необходимые параметры и управляет всем процессом сканирования.


Импорт данных

В программе предусмотрен импорт различных видов данных:

растровые подложки различных форматов BMP, GIF, JPEG, JPEG 2000, PNG, CRF (создается в системах CREDO III), TIFF и GeoTIFF (работа с двумя файлами - TIFF и текстовый файл), RSW (подложки Панорамы), ECW (Enhanced Compression Wavelet);

импорт точек привязки из произвольных текстовых файлов по шаблону;

импорт регулярной сетки высот DEM в различных форматах (GeoTiff, MTW 2000, ASC, TXT);

загрузка спутниковых снимков через сервисы Google Maps и Экспресс.Космоснимки;

сканирование растров непосредственно в ВЕКТОРИЗАТОР.

Команды импорта собраны в меню Файл/ Импорт.

Импорт растров различных форматов

В программе предусмотрено два варианта импорта растровых изображений: импорт растров и импорт точек привязки по шаблону.

Для импорта растровых изображений предназначена команда Растры. После активизации команды откроется диалоговое окно Импорт, в котором следует выбрать файл для импорта.

Для импорта точек привязки из текстовых файлов по шаблону предназначена утилита Импорт точек по шаблону, которая вызывается командой Точки привязки по шаблону. Работа выполняется в утилите Импорт точек по шаблону.

Импорт дополнительных точек по шаблону

При необходимости можно импортировать в модель дополнительные точки, которые можно использовать при построении цифровой модели рельефа или корректировки положения векторизуемых объектов по результатам измерений.

При наличии данных полевого кодирования вместе с точками могут быть автоматически созданы закодированные тематические объекты.

Импорт осуществляется командой Дополнительные точки по шаблону.

Импорт матриц высот

Матрицы высот (DEM) могут быть представлены в различных форматах. В связи с этим в программе реализовано две команды импорта матриц высот: Матрицы высот и Импорт матрицы по шаблону.

С помощью команды Матрицы высот можно импортировать матрицы следующих форматов:

Файлы GeoTIFF с высотными данными;

Матрицы высот в формате MTW (Panorama);

Данные SRTM (ASCII, GeoTIFF) и ASTER GDEM (GeoTIFF);

Матрицы высот в текстовых файлах.

По команде Импорт матрицы по шаблону импортируются текстовые файлы, в которых матрица высот записана в три столбца (столбцы в любом порядке) или построчно (в файле содержится только информация о привязке и высоты; одна строка файла – одна строка матрицы).

Матрицы высот импортируются в проект уже привязанными к системе координат. После импорта они автоматически блокируются.

Импортированные матрицы высот попадают в группу Матрицы высот таблицы Фрагменты и отображаются в окне План.

В окне План матрица высот отображается как растр, на котором высота визуализируется цветом пикселя. Зависимость цвета пикселя от его высоты настраивается в свойствах проекта (Файл/Свойства проекта раздел Матрицы высот (DEM)).

Для всех загруженных в проект матриц используется одна палитра. То есть, на всех растрах пиксели, расположенные на одной высоте, окрашиваются одинаково.


Спутниковые снимки и веб-карты

В программе предоставлена возможность работать со сверхвысокодетальными спутниковыми снимками и картографическими материалами через сервисы Google Maps и Экспресс.Космоснимки:

для некоммерческого использования бесплатно предоставляются снимки Google Maps в соответствии с условиями оказания услуг;

для коммерческого использования предоставляются снимки с сервиса Экспресс.Космоснимки компании "СКАНЕКС".

Общие сведения

Загрузка данных в режиме удаленного доступа (по протоколу WMS) реализована через сервис Экспресс.Космоснимки, который разработан и поддерживается специалистами "СКАНЭКС".

Загрузка данных сервиса Google Maps также реализована в режиме удаленного доступа (по протоколу WMS), для просмотра доступны четыре типа данных: карты, спутник, рельеф и гибрид (спутник и карта совместны).

Для доступа к данным Экспресс.Космоснимки необходима регистрация на сайте express.cosmosnimki.ru. Для работы со снимками через сервис Google Maps никаких дополнительных действий не требуется.

Загрузка снимка в программу

Для загрузки снимков предусмотрена команда Файл/Веб-карты/Выбрать источник. После чего открывается диалоговое окно Выбор источника веб-карт, в котором следует выбрать конкретный снимок.

При выборе данных сервиса Экспресс.Космоснимки становится доступной кнопка Выбор снимка [image], которая открывает диалог Выбор снимка со списком снимков согласно введенным ключам.

В диалоге Выбор снимка выполняется ввод полученного при регистрации API-ключа прямого доступа к сервису Экспресс.Космоснимки через кнопку Добавить ключ….

После ввода ключа становится доступным список космических снимков, которые можно загрузить в проект.

Введенный ключ сохраняется в реестре, т.е. на компьютере пользователя. Таким образом, снимок, добавленный в проект, будет подгружаться в графическое окно при открытии проекта без каких-либо дополнительных действий. Для работы со снимками на другом компьютере необходимо ввести ключ до или после открытия проекта.

После выбора снимка он отображается в окне предварительного просмотра в диалоге Выбор источника веб-карт.

В диалоге Выбор снимка можно также удалить ранее введенный ключ, получить дополнительную информацию об ИТЦ "СКАНЭКС", выполнить регистрацию на сайте http://my.kosmosnimki.ru/.

Для данных сервиса Google Maps предусмотрен поиск и позиционирование снимка по заданным координатам (в системе координат WGS 84). После ввода необходимых координат для позиционирования снимка надо нажать кнопку [image].

После выбора снимка выполняется импорт его в программу. Для этого надо нажать кнопку ОК в окне Выбор источника веб-карт.

Хранение снимков

Загрузка снимка из интернета происходит отдельными фрагментами, которые в данный момент отображаются в графическом окне приложения (часть картматериала). Заданную область картматериала (только для Google Maps) можно сохранить (импортировать) в проект и затем преобразовать в чертежную модель, т.е. можно создать чертеж с фрагментом космоснимка.

Для импорта заданной области картматерила предназначена команда Файл/ Веб-карты/Импорт в проект.


Перемещение

Перемещение фрагмента

При импорте или сканировании каждый новый фрагмент изображения размещается в рабочем окне таким образом, что его левый нижний угол имеет координату (0, 0). При импорте нескольких фрагментов каждый следующий фрагмент может частично или полностью закрывать собой предыдущий. В этом случае, а также в ряде других, следует использовать операции перемещения фрагмента.

Перед перемещением фрагмент должен быть разблокирован (команда Блокировка меню Инструменты).

Выбор фрагмента

Выбор фрагмента осуществляется левой клавишей мыши (ЛКМ).

Выбор нескольких фрагментов производится клавишами <Shift+ЛКМ>, <Ctrl+ЛКМ>.

Отменить выбор фрагмента можно <Ctrl+ЛКМ>. Выбор всех выбранных объектов отменяется кликом ЛКМ по пустому месту окна План.

Информация о выбранных фрагментах отображается в окне Свойства.

Перемещение фрагмента

Для свободного перемещения фрагмента необходимо выделить его и, нажав ЛКМ, переместить объект в нужную позицию. Указатель мыши при перетаскивании принимает форму [image].

Для заблокированных фрагментов возможность перемещения недоступна.

Разрешено одновременное перемещение нескольких выбранных фрагментов.

Вместе с фрагментами перемещаются также их точки привязки.

При перемещении информация о текущей позиции курсора отображается в строке состояния.

Перемещение фрагмента на уровень выше

Для перемещения отрисовки фрагмента на один уровень выше предназначена команда Вертикальный порядок/На уровень выше меню Инструменты.

Перемещение фрагмента на уровень ниже

Для перемещения отрисовки фрагмента на один уровень ниже предназначена команда Вертикальный порядок/На уровень ниже меню Инструменты.

Перемещение фрагмента на передний план

Для расположения отрисовки фрагмента выше всех остальных фрагментов предназначена команда Вертикальный порядок/На передний план меню Инструменты.

Перемещение фрагмента на задний план

Для расположения отрисовки фрагмента ниже всех остальных фрагментов предназначена команда Вертикальный порядок/На задний план меню Инструменты.


Управление привязками

Для изменения координат отдельного фрагмента или всего проекта (трансформация сдвигом) на величину dX, dY, например, после трансформации, в случае грубого промаха с общей оцифровкой координатной сетки либо при необходимости изменить форму представления координат, предназначены команды меню Трансформация: Создать точку привязки, Создать пару точек, Создать сетку точек, Привязка планшета, Привязка листа карты.


Поворот

Поворот фрагмента

Перед вращением фрагмент должен быть разблокирован (команда Блокировка меню Инструменты).

Поворот на произвольный угол

Интерактивный поворот выбранного фрагмента осуществляется перемещением управляющей точки выбранного фрагмента. При наведении курсора на управляющую точку изображение курсора принимает вид [image].

Захватите управляющую точку левой клавишей мыши и поверните фрагмент на нужный угол.

Несколько выбранных фрагментов объединяются в группу с одной управляющей точкой на всех. При перемещении управляющей точки осуществляется поворот всей группы.

Поворот на 180°

Для поворота выбранного фрагмента на 180 градусов предназначена команда Повернуть на 180 меню Инструменты.

Поворот на 90° по ч. с.

Для поворота выбранного фрагмента на 90 градусов по часовой стрелке предназначена команда Повернуть на 90° вправо меню Инструменты.

Поворот на 90° против ч. с.

Для поворота выбранного фрагмента на 90 градусов против часовой стрелки предназначена команда Повернуть на 90° влево меню Инструменты.


Зеркальное отображение

Зеркальное отображение фрагмента

Перед выполнением зеркального отображения фрагмент должен быть разблокирован (команда Блокировка меню Инструменты).

Отразить слева направо

Для получения зеркального отображения фрагмента относительно вертикальной оси предназначена команда Отразить слева направо меню Инструменты.

Отразить сверху вниз

Для получения зеркального отображения фрагмента относительно горизонтальной оси предназначена команда Отразить сверху вниз меню Инструменты.


Фильтры

Инверсия цвета

Инверсия цвета изображения используется для обработки растровых фрагментов, полученных в результате сканирования негативов.

Для инвертирования цветов изображения предназначена команда Инвертировать меню Инструменты

Управление яркостью и контрастом

Фильтр используется для регулировки яркости и контрастности изображения. Он может быть особенно полезным для "приглушения" яркости растровой подложки, экспортируемой в другую систему для проектирования. В этом случае неяркая растровая подложка позволит легко видеть осуществляемые построения.

Для управления яркостью и контрастом предназначена команда Яркость, контраст и гамма меню Инструменты

Залить дыры

Фильтр используется для удаления "случайных", "шумовых" черных пятен полученного на сканере изображения. В результате становятся толще светлые линии на темном фоне.

Фильтр может быть эффективен при обработке насыщенных цветных изображений.

Фильтр работает по следующему принципу:

Для 1-битных изображений – пиксель результирующего изображения будет белым, если соответствующий ему пиксель исходного изображения или один из четырех соседних пикселей был белым. В противном случае пиксель результирующего изображения будет черным.

Для монохромных изображений (256 градаций серого) и цветных изображений с индексными цветами – значение цвета каждого пикселя результирующего изображения устанавливается в наиболее светлое из значений цветов соответствующего ему пикселя исходного изображения или одного из четырех соседних пикселей.

Для полноцветных изображений – значение каждой цветовой составляющей пикселя результирующего изображения устанавливается в наиболее светлое из значений этой цветовой составляющей соответствующего ему пикселя исходного изображения или одного из четырех соседних пикселей.

Для применения фильтра предназначена команда Залить дыры меню Инструменты.

Убрать пятна

Фильтр используется для удаления "случайных" светлых пикселей, которые можно считать "шумом" и которые могут возникать, например, из-за пыли на столе сканера при сканировании исходного документа.

Фильтр может быть эффективен при обработке насыщенных цветных изображений.

Для применения фильтра предназначена команда Убрать пятна меню Инструменты. Действие этой команды обратно действию команды Залить дыры.

Сгладить

Фильтр устанавливает значение цвета каждого пикселя результирующего изображения в среднее значение цветов соответствующего пикселя исходного изображения и его ближайших соседних пикселей.

После применения фильтра создается эффект "сглаживания" цветов.

Фильтр может быть эффективен при обработке насыщенных цветных изображений.

Для применения фильтра предназначена команда Сгладить меню Инструменты.

Увеличить резкость

Фильтр создает эффект увеличения резкости и повышения контрастности изображения. Фильтр может быть применен многократно.

Фильтр может быть эффективен при обработке насыщенных цветных изображений.

Для применения фильтра предназначена команда Увеличить резкость меню Инструменты.


обрезка

Обрезка позволяет удалить из растровой подложки все элементы растра, не попадающие в контур. Помимо того, что избыточные поля вокруг обрабатываемых участков фрагментов могут создавать неудобства в процессе работы, они занимают большое дисковое пространство и значительно замедляют процесс обработки растра. Поэтому желательно обрезать избыточные участки фрагментов сразу после сканирования или импорта фрагментов.

Фрагменты, которые не должны участвовать в операции Обрезка, должны быть скрыты. Для этого воспользуйтесь командой Инструменты/Скрыть либо уберите флажки Видимость в окне Фрагменты для соответствующих растровых изображений.

Для обрезки растра предназначена команда Обрезать меню Инструменты.

Отказаться от выполненной операции можно с помощью команды Отменить меню Правка.


Преобразование цвета Фрагмента

Для преобразования цвета выделенного фрагмента в 1-битный черно-белый, монохромный (256 градаций серого) или цветной (32 бит) формат предназначены соответствующие команды Глубина цвета меню Инструменты.

Отказаться от выполненной операции можно с помощью команды Отменить меню Правка.


Изменить цвет

Для замены цвета пикселей отдельного фрагмента или всего проекта (например, черного на синий для дальнейшего использования в качестве растровой подложки при оцифровке) предназначена команда Заменить цвет меню Инструменты.

Отказаться от выполненной операции можно с помощью команды Отменить меню Правка.


Видимость

Видимость фрагментов

Для экономии времени на перерисовку экрана, повышения быстродействия при работе (что особенно актуально для сложных проектов со множеством фрагментов) существует возможность управления видимостью фрагментов.

Для отключения видимости одного или нескольких выбранных фрагментов предназначена команда Скрыть меню Инструменты. Повторный вызов команды включает видимость фрагментов.

Включить видимость одновременно всех фрагментов можно с помощью команды Отобразить все фрагменты меню Инструменты.


Блокировка

Блокировка фрагментов

Для исключения непреднамеренного искажения или редактирования фрагмента (что особенно актуально для сложных проектов со множеством фрагментов) существует возможность блокировки фрагмента.

Установить блокировку для одного или нескольких выбранных фрагментов можно с помощью команды Блокировка меню Инструменты.


Рисование точек и произвольных линий

Рисование линий

На выбранном фрагменте можно рисовать произвольные линии и области заданного цвета и толщины.

Для этого предназначены команды Карандаш меню Инструменты, Отрезок и Полилиния меню Оформление (Примитивы).

Если выбрать в качестве цвета для рисования цвет фона, можно использовать команду Карандаш для очистки небольших областей.


Рисование прямоугольника

На выбранном фрагменте можно рисовать прямоугольники линией заданного цвета и толщины.

Для этого предназначена команда Прямоугольник меню Оформление (Примитивы).


Рисование окружностей и эллипсов

Рисование окружности и эллипса

На выбранном фрагменте можно рисовать окружности и эллипсы линией заданного цвета и толщины.

Для этого предназначены команды Окружность и Эллипс меню Оформление (Примитивы).


Рисование многоугольника

На выбранном фрагменте можно рисовать произвольные регионы с заливкой заданного цвета.

Для этого предназначена команда Многоугольник меню Оформление (Примитивы).

Если выбрать в качестве цвета для рисования цвет фона, можно использовать команду для очистки небольших областей.


Заливка

Для выбранного фрагмента существует возможность заливки его областей указанным цветом.

Для этого предназначена команда Заливка меню Инструменты.

Отказаться от выполненной операции можно с помощью команды Отменить меню Правка.

Если область изображения не является непрерывной, выбранным цветом будут залиты другие области рисунка. Чтобы найти разрыв, используйте команды управления масштабом отображения растра на экране меню Вид .

С помощью команды Заливка можно менять также цвет существующих линий. Для этого необходимо установить указатель так, чтобы он касался линии, и нажать левую кнопку мыши. Если данная линия является частью фигуры, цвет всех соединенных с ней линий также изменится.


Типы точек привязки

Точки привязки задают соответствие точки растра (в системе координат растра) точке проекта (в системе координат проекта).

Опорные точки привязки могут быть абсолютными или относительными.

Абсолютные точки - это точки с известными координатами. Их необходимо задавать для трансформации растровых изображений. Такими точками могут быть кресты координатной сетки, крайние точки рамки, пункты геодезического обоснования, координированные углы зданий, просто характерные точки растра с известными координатами. Точки задаются пользователем в установленной им системе координат.

Имена абсолютных опорных точек в пределах одного фрагмента не должны повторяться.

Относительные точки – это дополнительные точки без указания координат. Их необходимо задавать для транформации или склейки растровых изображений. Обычно такие точки задаются для устранения в процессе трансформации "несводок" контуров на каждом из смежных фрагментов в области перекрытия в характерных местах изображения: на колодцах, осветительных мачтах, пересечениях линий, отдельно стоящих деревьях и т.п. либо для склейки фрагментов у которых отсутствуют абсолютные точки. Одна и та же относительная точка может присутствовать одновременно на нескольких фрагментах, как общая. В процессе трансформации или склейки соответствующие относительные опорные точки соседних фрагментов совмещаются.

Контрольные точки привязки – точки, не участвующие в расчетах параметров трансформирования, по ним оценивается величина отклонения после трансформации растра. Контрольные точки нужны для оценки качества трансформации растра.

Изменить тип можно в столбце Тип точки окна Точки привязки, выбрав необходимый из выпадающего списка.

Качество привязки каждого из фрагментов можно контролировать, периодически просматривая список опорных точек и редактируя его (таблица Точки привязки).

Сходимость опорных точек оценивается по отклонениям: по осям абсцисс (dX), ординат (dY), абсолютной величине смещения (d).

В случае, если отклонение на точке значительное (обычно величина отклонения не должна превышать значения 0.3 мм в единицах плана), то рекомендуется в этом случае отредактировать ее или удалить.

Осуществлять интерактивную привязку точек надо как можно точнее. Для этого желательно увеличить фрагмент изображения, пользуясь колесиком мыши либо кнопками масштабирования. Для ускорения указания положения создаваемых точек привязки используется функция распознавания пересечений линий на растрах (крестов координатной сетки, пересечений линий координатной сетки). На время указания точки привязки можно отключить распознавание пересечений, нажав клавишу <F3>.

При автоматических расчётах учитываются границы области видимости растрового фрагмента – за пределами области видимости точки привязки не генерируются.

См. также

Задание точек привязки

Задание сетки точек привязки

Редактирование точек привязки

Удаление точек привязки


Задание точек привязки

Трансформация растрового изображения осуществляется по задаваемым опорным точкам привязки: абсолютным и относительным. Относительны опорные точки используются для склейки растровых изображений.

Число задаваемых опорных точек зависит от качества отсканированного изображения. Если метрическое качество растра неудовлетворительное, рекомендуется использовать максимально возможное количество точек, например, привязывать все узлы координатной сетки. Число задаваемых опорных точек может достигать 400.

Минимальное количество опорных точек для трансформации – две.

В программе ВЕКТОРИЗАТОР предусмотрено несколько методов создания опорных точек:

создание одиночной опорной точки;

создание пары опорных точек (относительных точек);

автоматическое создание сетки абсолютных точек привязки;

автоматическое создание сетки абсолютных точек привязки на листе карт;

автоматическое создание сетки абсолютных точек привязки на планшете;

указание положения на растровом фрагменте точек привязки, импортированных из текстового файла.

Создание одиночной опорной точки

Этот способ предназначен для создания точек привязки (абсолютных и относительных) в характерных местах изображения, расположенных нерегулярно (пункты геодезического обоснования, колодцы, иные точки растра).

Задание одиночных опорных точек производится с помощью команды Создать точку привязки в меню Трансформация.

Создание пары точек привязки

Этот способ предназначен для создания относительных точек привязки попарно, т.е. первая точка создается на одном растре, а вторая – на втором с именем первой точки.

Для создания пары точек предназначена команда Трансформация/Создать пару точек.

После объединения фрагментов в единое растровое поле нумерация относительных опорных точек меняется, так как на одном фрагменте не может быть опорных точек с одинаковыми именами (команда Инструменты/Объединить выбранные фрагменты).

Привязка листа карты

В программе есть возможность привязать лист карты стандартной разграфки по его углам и номенклатуре, используя команду Трансформация/Привязка листа карты.

Для работы команды можно предварительно задать в свойствах проекта систему координат (команда Файл/ Свойства проекта раздел Система координат).

Привязка планшета

С помощью команды Трансформация/Привязка планшета выполняется привязка планшета по его углам и масштабу.

Указание на фрагменте существующих опорных точек

Этот способ предназначен для указания положения заранее проимпортированных точек привязки, в случае необходимости использования произвольных опорных точек с заранее известными координатами.

В результате импорта точек привязки в проект добавляются точки привязки, не относящиеся к конкретному фрагменту. В таблице Точки привязки они находятся в группе Непривязанные. Для того, чтобы указать положение этих точек на растровых фрагментах, необходимо вызвать команду Нанести точку привязки меню Трансформация, при этом точки наносятся в следующем порядке: выбирается точка в таблице Точки привязки, указывается ее положение на необходимом растровом фрагменте. Координаты точки вводить при этом не нужно, они были прочитаны из текстового файла и уже присутствуют в таблице. Все действия сопровождаются подсказками в левом верхнем углу окна План. После указания точек на растрах, они группируются по соответствующим фрагментам, таким образом по мере указания импортированных точек они из группы Непривязанные попадают в группы по фрагментам, как и обычные точки привязки.

См. также

Типы точек привязки

Задание сетки точек привязки

Редактирование точек привязки

Удаление точек привязки


Задание сетки точек привязки

Если метрическое качество растра неудовлетворительное или требуется качественная обработка отсканированного материала (планшетов), рекомендуется использовать максимально возможное количество точек, например, привязывать все узлы координатной сетки. Автоматизировать процесс создания точек привязки по сетке, позволяет команда Создать сетку точек.

Данная возможность позволяет создать абсолютные точки привязки с заданным пользователем шагом сетки (кратным шагу сетки на растре) на растровых изображениях.

Для автоматического создания сетки точек привязки необходимо, чтобы в проекте были созданы как минимум две абсолютные точки.

После вызова команды открывается окно для ввода значения шага.

Программа автоматически рассчитывает предполагаемые местоположения крестов координатной сетки, ищет в этих областях растра пересечения линий и создаёт опорные точки в этих местах или, если пересечения линий координатной сетки не найдены, то рядом.

См. также

Типы точек привязки

Задание точек привязки

Редактирование точек привязки

Удаление точек привязки


Управление привязками

Функция управления привязками необходима для изменения координат отдельного фрагмента или всего проекта (трансформация сдвигом) на величину dN, dE в случае грубого промаха с общей оцифровкой координатной сетки либо при необходимости изменить форму представления координат.

Одновременно с преобразованием координат фрагментов происходит пересчет координат точек привязки фрагментов.

Вызов функции производится выбором команды Трансформация/Управление привязками в главном меню программы.

Пункт меню и кнопка на панели инструментов доступны только тогда, когда в проекте есть хотя бы один растровый фрагмент.

Доступность функции не зависит от блокировки фрагментов.


Редактирование точек привязки

Редактировать точки привязки (изменить координаты точек, изменить тип точки) можно в таблице [image] Точки привязки.

В таблице можно отредактировать Имя точки, значения:

N, E – прямоугольные координаты точки привязки;

В, L – геодезические координаты точки привязки. Значения отображаются только в том случае, если в проекте задана система координат. Если система координат не задана, поля остаются пустыми и недоступными для редактирования;

Тип – значение выбирается из выпадающего списка (Опорная или Контрольная).

Значения

dN – отклонение точки привязки от ожидаемого положения по оси абсцисс;

dE – отклонение точки привязки от ожидаемого положения по оси ординат;

dS – общее отклонение точки привязки от ожидаемого положения.

автоматически пересчитываются при изменении значений в предыдущих столбцах таблицы.

См. также

Типы точек привязки

Задание точек привязки

Удаление точек привязки


Удаление точек привязки

Заданные точки привязки можно удалить. Удаление точек осуществляется в таблице [image] Точки привязки или интерактивно в окне План.

Выделите точку или группу точек в таблице Точки привязки или в окне План, используя клавиши <Shift> или <Ctrl>.

Нажмите клавишу <Del> или кнопку [image] на панели инструментов окна Точки привязки. Последует запрос на удаление точек.

См. также

Типы точек привязки

Задание точек привязки

Редактирование точек привязки


Трансформация (процесс)

Выполняется только при наличии лицензии ТРАНСФОРМ.

Трансформация - это преобразование растрового изображения с целью устранения искажений, вызванных складками исходного бумажного носителя, замятием при сканировании, ошибками самого сканера. В результате трансформации растр также привязывается в систему координат проекта (получает геопривязку).

Трансформация растровых изображений осуществляется по задаваемым опорным точкам. Трансформируются только те фрагменты, которые не заблокированы и для которых задано не менее двух абсолютных точек привязки. В трансформации участвуют и относительные точки привязки. Относительные опорные точки привязки, расположенные только на одном фрагменте, не учитываются.

Запуск трансформации выполняется одним из методов, сгруппированных в меню Трансформация:

Метод кусочно-линейной трансформации позволяет получать качественные изображения, в определенной степени исправляя такие дефекты, как складки бумаги, участки с неравномерным масштабом и другие. Одновременно обеспечивается привязка обрабатываемых растровых фрагментов к используемой системе координат.

Аффинная трансформация позволяет получить качественные результаты для растров, искаженных или вытянутых в одном из направлений. В направлении каждой из координатных осей рассчитывается и потом применяется свой масштабный коэффициент.

После трансформации рассчитываются значения уклонений по осям абсцисс (dN), ординат (dE), абсолютной величине смещения (dS) точек привязки от их ожидаемого положения.

Трансформировать весь проект или один из фрагментов можно несколько раз, используя предыдущие привязки, изменяя и дополняя их. Можно указывать другой вид интерполяции цвета (ближайших соседей либо билинейная) в свойствах проекта (Файл/Свойства проекта раздел Трансформация).

После трансформации фрагмент автоматически блокируется.

Отключить блокировку фрагментов можно в свойствах проекта (Файл/Свойства проекта раздел Трансформация).


Ортокоррекция одиночного космоснимка

Выполняется только при наличии лицензии ТРАНСФОРМ.

Космические снимки в сыром виде представляют собой изображение земной поверхности, которое получено с борта космического аппарата под углом наклона к точке надира, достигающим 40 градусов.

Ортотрансформирование (ортокоррекция) снимка – это математически строгое преобразование исходного снимка в ортогональную проекцию и устранение искажений, вызванных рельефом, условиями съемки и типом камеры.

Ортокоррекция космоснимка активизируется командой Ортокоррекция космоснимка меню Трансформация. Перед ортокоррекцией необходимо обеспечить выполнение ряда условий (см. ниже).

Условия для выполнения ортокоррекции

Для выполнения ортокоррекции космического снимка необходимы:

Космический снимок в одном из форматов поставки (обычно GeoTIFF).

Данные коэффициентов RPC (rational polynomial coefficients) к снимку.

Информация о рельефе в виде матрицы высот (DEM – Digital Elevation Model). Стандартный шаг сетки применяемый для ортокоррекции космических снимков – 20-50 м.

Модель геоида. Данные модели геоида применяются к матрице высот непосредственно перед ортокоррекцией, если в настройках свойств проекта в разделе Параметры выбрана модель геоида.

Перед тем как выполнять ортокоррекцию в проекте необходимо подготовить следующие материалы:

загрузить в проект космоснимок в той системе координат, в которой он поставляется;

сформировать матрицу высот, полностью покрывающую нужный снимок (матрица высот должна быть в той же системе координат, что и снимок).

Для импорта космоснимка в его поставочной системе координат нужно перед импортом в настройках системы координат проекта (Свойства проекта) выбрать значение Не задана. После импорта файла GeoTiff космоснимка система координат будет прочитана из заголовка файла.


Векторизация (процесс)

Векторизация - это преобразование изображения и растрового представления в векторное. В случае работы с информацией о местности можно говорить о преобразовании растровых картографических материалов в векторную цифровую модель местности.

Команды преобразования находятся в меню Векторизация.

В этой статье:

Подготовка к векторизации

Простая векторизация

Создание цифровой модели местности

Подготовка к векторизации

Векторизация растровых топографических планов осуществляется по фрагментам и возможна только для черно-белых фрагментов (глубина цвета 1 бит).

Следовательно, перед векторизацией цветные фрагменты необходимо преобразовать в однобитные (см. Глубина цвета меню Инструменты), при этом следует тщательно подобрать порог преобразования для сохранения максимального количества деталей в черно-белом изображении. Для корректной работы процесса векторизации важно отсутствие разрывов в линиях и текстах (см. рисунки).

Вид исходных фрагментов:

На рисунке: фрагмент некорректен для векторизации (разрывы в линиях, тонкий текст, теряются точки).

На рисунке: фрагмент корректен для векторизации (слегка жирный текст без дыр, четко прорисованные линии).

В программе ВЕКТОРИЗАТОР возможно:

выполнение простой векторизации;

создание элементов цифровой модели местности по растровым топографическим планам.

Описание процессов см. ниже.

В начало

Простая векторизация

При использовании простой векторизации из растрового изображения извлекается набор полилиний, формирующих изображение (команда Векторизация меню Векторизация). Этот способ подходит для быстрого получения векторного изображения на основе растра, при этом результатом будет являться набор 2D-полилиний. Надписи на растровом фрагменте можно распознать и создать на их основе текстовые элементы (Распознавание текста меню Векторизация).

Полученные полилинии и тексты можно экспортировать во внешние форматы для дальнейшей работы.

В начало

Создание цифровой модели местности

При создании цифровой модели местности на растровом топографическом плане выполняется поиск отметок высот (Распознавание подписей высоты), горизонталей (Распознавание горизонталей), точечных (Распознавание ТТО) и линейных (Распознавание ЛТО) объектов. Команды работы с ТО находятся в меню Векторизация.

Распознавание отметок и ТТО происходит в автоматическом режиме с последующей валидацией результатов. Горизонтали и ЛТО распознаются в полуавтоматическом интерактивном режиме.

Для всех распознаваемых элементов возможно выполнить стирание распознанных объектов с растра. Стирание позволяет повысить качество автоматического распознавания по мере уменьшения числа накладывающихся друг на друга объектов.

В начало


Создание цифровой модели местности

Создание цифровой модели местности (ЦММ) включает в себя два этапа: создание плана и создание цифровой модели рельефа.

Создание плана

В формировании плана участвуют следующие тематические объекты:

ТО, полученные в результате векторизации;

ТО, созданные инструментами создания тематических объектов;

ТО, созданные в результате импорта точек с кодами объектов.

При необходимости тематические объекты могут быть изменены и отредактированы (командами меню Рельеф и ситуация):
существующий линейный объект можно дорисовать с любой из сторон, разрезать на части, сшить с другим линейным объектом. Для правильного отображения линейных объектов, для которых направление линии имеет значение, направление отрисовки может быть изменено.

Создание цифровой модели рельефа

В создании модели участвуют:

точки, имеющие высоту и признак отношения к рельефу Рельефная;

распознанные горизонтали (они участвуют в поверхности как структурные линии с постоянной высотой);

линейные тематические объекты, имеющие признак отношения к рельефу Рельефный и опирающиеся на точки с высотой. Эти ЛТО участвуют в построении поверхности в качестве структурных линий.

Цифровая модель рельефа создается командой Создать поверхность меню Рельеф и ситуация. При создании автоматически формируются горизонтали с подписями и бергштрихами, а также градиентная заливка.

Параметры построения и отображения поверхности настраиваются в диалоге Свойства проекта в разделе План, группа Поверхность рельефа.

При необходимости можно изменить градиент поверхности (команда Настройка градиента меню Рельеф и ситуация).

Видимостью элементов поверхности можно управлять через фильтры видимости.


Создание контуров видимости

Области видимости

Контуры области видимости предназначены для формирования растровых полей произвольной формы из нескольких растровых фрагментов.

На каждый растровый фрагмент можно наложить многоугольный контур видимости, обеспечив на экране и чертеже отображение только выделенного участка изображения. Контуры видимости можно сопрягать с контурами соседних фрагментов по линии совмещения. Таким образом, отдельные фрагменты "сшиваются" в единое растровое изображение.

Для управления границами области видимости фрагментов предназначены команды меню Область видимости.

Команды работы с областями видимости доступны, когда выбран только один фрагмент.
Доступность функций не зависит от блокировки фрагментов.

Редактировать контуры можно перемещением, удалением его вершин, добавлением новых вершин.

Границы области видимости могут иметь сколь угодно сложную форму, допускается самопересечение контура и пересечение им других контуров.


Сохранение проекта

Сохранение проекта и данных

Растровое изображение сохраняется в файле формата TMD. Если был создан список опорных точек и контуры видимости, то они сохраняются в том же файле.

Для сохранения растра предназначены команды Сохранить и Сохранить как меню Файл.

С помощью команд Файл/Экспорт растра можно сохранить весь проект (команда Экспорт проекта), выбранные фрагменты (команда Экспорт фрагментов) или часть проекта, выделенного контуром (команда Экспорт контура), в файлы соответствующего формата, как для использования в программных продуктах комплекса КРЕДО, так и для работы в системах ArcView и других топографических или геоинформационных системах.


Экспорт проекта

Экспорт

Программа позволяет экспортировать проект в целом, активный фрагмент, участок, заданный контуром, в файлы соответствующего формата как для использования в программных продуктах комплекса КРЕДО, так и для работы в других топографических и геоинформационных системах:

формат BMP, GIF, JPG, PNG;

формат растровой подложки CRF;

файлы TIFF, GeoTIFF;

подложки Panorama.

Команды для экспорта растра сгруппированы в меню Файл/Экспорт растра.

Также можно экспортировать матрицы высот в форматы GeoTIFF (*.tif), TXT (*.txt).

При экспорте проекта экспортируются в единый файл все видимые фрагменты проекта с учетом контуров видимости. Участки фрагментов, не попадающие в контуры видимости, а также фрагменты с отключенной видимостью заливаются белым цветом.

При экспорте части проекта, выделенного контуром, экспортируются все видимые части и фрагменты проекта, попадающие внутрь контура с учетом контуров видимости.

При экспорте фрагмента учитывается контур видимости фрагмента. Участки фрагмента, не попадающие в контур видимости, заливаются белым цветом.


Подготовка чертежа в графическом окне

Подготовка в графическом окне

Общую информацию о создании чертежей - см. тему Чертежи.

Подготовка в графическом окне включает:

установку видимости необходимых элементов проекта с помощью команды Фильтр видимости [image] окна План;

установку необходимого масштаба документа;

дополнение проекта необходимыми графическими примитивами, текстами (меню Оформление).

Все построения примитивов (линии, прямоугольника, окружности) выполняются интерактивно в графическом окне, захватывая либо существующие точки, либо создавая новые. После завершения построений в окне Свойства уточняются, при необходимости, значения их параметров. С помощью графических элементов можно создать как линейные, так и площадные объекты, определяя необходимые параметры в окне Свойства.

При необходимости можно выполнить растеризацию примитивов – преобразовать каждый примитив в набор пикселей экрана.

Растеризация производится выбором команды Оформление/Растеризация либо нажатием на кнопку Растеризовать примитивы на растровые фрагменты [image] панели инструментов.


Подготовка проекта чертежа в проекте TMD

Область проекта, передаваемая в чертеж, ограничивается при помощи специальных контуров. Для определения положения границ фрагментов в проекте TMD используйте команды, расположенные в меню Чертежи.

Границы фрагмента чертежа могут определяться интерактивно в графическом окне в виде произвольного контура (команда Создать контур чертежа).

Если выбрана команда Создать лист чертежа, то вид чертежа определяется в соответствии с данными, заданными в шаблоне. Выбирается необходимый шаблон чертежа (по умолчанию шаблоны хранятся в папке .../ВЕКТОРИЗАТОР/Templates/Draft). При этом в диалоговом окне можно предварительно выбрать формат и ориентацию листа чертежа, после чего интерактивно указать его положение в графическом окне.

В графическом окне шаблон можно перемещать и поворачивать интерактивно. Также при необходимости можно изменить границы фрагмента, последовательно захватывая узлы и указывая их новое местоположение.

В окне Свойства можно изменять параметры листа.

После определения контуров чертежа при помощи команды Чертежи/Выпустить чертеж осуществляется переход в чертежную модель с передачей выбранного контура. При этом в графическом окне необходимо предварительно выбрать один или несколько контуров (в том числе и листов). В зависимости от выбора могут быть созданы один (если выбраны только контуры) или несколько (если выбраны листы) документов Чертеж.

В процессе передачи (вставки) фрагмента в чертеж за ним сохраняется путь к файлу TMD исходного проекта, что позволяет в случае необходимости обновить содержимое фрагмента в соответствии с текущим состоянием информации в проекте, по которому создан фрагмент. Обновление производится в документе Чертеж с помощью команды Обновить фрагменты в меню Правка, предварительно выбрав фрагмент в графическом окне. При этом должен быть открыт соответствующий проект TMD.


Работа в проекте Чертеж

В проекте Чертеж производится доработка чертежа и вывод его на печать. Предусмотрена возможность вставлять различные элементы (Правка/Вставить объект).

Для повышения информативности создаваемого документа можно рисовать примитивы, добавлять тексты и т.п. (меню Примитивы).

Все построения примитивов выполняются интерактивно в графическом окне. После завершения построений в окне Свойства при необходимости можно уточнить значения параметров построенных примитивов. Редактирование элементов осуществляется путем выбора элемента в графическом окне и редактирования его с помощью управляющих элементов.

В окне Свойства можно изменить параметры выбранного фрагмента.

При выборе шаблона листа чертежа (со штампом) в окне Свойства отображается список переменных, заданных в шаблоне.

Можно внести необходимые значения для зарамочного оформления.

Для обеспечения удобства и эффективности графических построений в чертежной модели реализованы дополнительные операции с объектами: группировка, управление вертикальным порядком, блокировка. Данные операции вызываются из меню Объект.


Экспорт чертежа

Для последующей вставки в электронные отчеты или продолжения редактирования документа чертежа предусмотрен экспорт в форматы PDF, DXF, SVG (Файл/Экспорт).

Экспорт в формат PDF производится с учетом текущей раскладки чертежа на страницы, в остальных форматах раскладка не учитывается.


Печать

Для настройки параметров печати реализованы следующие возможности:

Диалог Параметры страницы, который вызывается командой Файл/Параметры страницы. В нем можно выбрать необходимое печатающее устройство и изменить параметры.

В случае, когда фактические размеры чертежа превышают размеры бумаги выбранного принтера, можно скорректировать раскладку чертежа на страницы или параметры используемого принтера при помощи команды Файл/Раскладка на страницы. После выбора команды в графическом окне отобразится сетка страниц (границы печатаемых страниц выделяются цветом). При необходимости сетку страниц можно перенести, чтобы чертеж корректно ложился в раскладку страниц.

Окно предварительного просмотра позволяет просматривать печатаемые страницы и задавать настройки печати.

Печать документа производится при выборе команды Печать в меню Файл либо из окна предварительного просмотра.


Меню Файл

Команды меню Файл

Создать

Открыть

Недавние проекты - список последних открытых проектов

Закрыть

Сохранить

Сохранить как

Сохранить все

Сканирование

Импорт

Веб-карты

Экспорт растра

Экспорт матрицы высот

Экспорт модели

Свойства проекта

Классификатор

Геодезическая библиотека

Параметры программы

Выход


меню Файл/Создать

– Проект

Команда доступна в окне План.

Команда создает новый проект. Каждый проект создается в отдельном окне.

Чтобы создать новый проект:

Выберите команду Создать/Проект в меню Файл (кнопка Создать новый проект [image] на панели инструментов или горячие клавиши <Ctrl + N>).

Открывается окно нового проекта. По умолчанию новому проекту присваивается имя Новый проект 1, последующим вновь созданным проектам будут присваиваться имена Новый проект 2, Новый проект 3 и т.д.

– Чертеж.

Команда доступна в окне План и в окне Чертеж.

Команда создает новый чертеж. Каждый чертеж создается в отдельном окне.

Чтобы создать новый чертеж:

Выберите команду Создать/Чертеж в меню Файл (кнопка Создать новый чертеж [image] на панели инструментов или горячие клавиши <Ctrl + N>).

Открывается окно нового чертежа. По умолчанию новому чертежу присваивается имя Новый чертеж 1, последующим вновь созданным чертежам будут присваиваться имена Новый чертеж 2, Новый чертеж 3 и т.д.

– Классификатор.

Команда доступна в окне План.

Команда создает новый классификатор.

Выберите команду Создать/Классификатор в меню Файл (кнопка Создать классификатор [image] на панели инструментов или горячие клавиши <Ctrl + Shift + N>).

После выбора этой команды происходит переход в меню работы с классификатором.


Команда Открыть (меню Файл)

Открыть

Команда открывает существующий проект в формате TMD или чертеж в формате DDR или DDR4. Команда доступна в окне План и в окне Чертеж.

Чтобы открыть существующий проект или чертеж:

Выберите команду Открыть в меню Файл (кнопка Открыть [image] на панели инструментов или горячие клавиши <Ctrl + О>).

В открывшемся окне диалога из списка Тип файлов выберите требуемый формат.

Выберите файл. Его имя отобразится в поле Имя файла.

Нажмите кнопку Открыть или клавишу <Enter>.

Файл проекта открывается в окне плана, файл чертежа - в окне чертежа.

Имена проектов или чертежей, которые открывались последними, представлены в списке команды Недавние проекты меню Файл.


Команда Закрыть (меню Файл)

Закрыть

Команда закрывает текущий проект или чертеж. Команда доступна в окне План и в окне Чертеж.

Выберите команду Закрыть в меню Файл (кнопка Закрыть [image] на панели инструментов или горячие клавиши <Ctrl + О>).

При наличии несохраненных изменений в проекте или чертеже программа запросит подтверждение на сохранение перед закрытием.

Кнопка Да закрывает проект или чертеж с сохранением всех изменений, кнопка Нет закрывает проект или чертеж без сохранения изменений.

Кнопка Отмена отменяет закрытие проекта или чертежа.


Команда Сохранить (меню Файл)

Сохранить

Команда сохраняет текущий проект в окне План или чертеж в окне Чертеж.

Чтобы сохранить текущий проект или чертеж:

Выберите команду Сохранить в меню Файл (кнопка Сохранить [image] на панели инструментов или горячие клавиши <Ctrl + S>).

Для нового проекта или чертежа вызывается диалоговое меню Сохранить как.

После сохранения проекта или чертежа файл остается открытым, и с ним можно продолжать работу.


Команда Сохранить как (меню Файл)

Сохранить как

Команда сохраняет новый проект или чертеж или создает копию существующего проекта или чертежа под другим именем. Команда доступна как в режиме подготовки растровой подложки, так и в режиме компоновки чертежа.

Выберите команду Сохранить как в меню Файл (кнопка Сохранить как [image] на панели инструментов или горячие клавиши <Ctrl + Shift + S>).

В открывшемся окне диалога в поле Имя файла укажите или измените имя сохраняемого проекта или чертежа.

Нажмите кнопку Сохранить или клавишу <Enter>.

Файл проекта сохраняется с расширением TMD. Файл чертежа сохраняется с расширением DDR4.


Команда Сохранить все (меню Файл)

Сохранить все

Команда сохраняет все открытые проекты в режиме подготовки растровой подложки или чертежи - в режиме компоновки чертежа.

Для сохранения изменений:

Выберите команду Сохранить все в меню Файл (кнопка Сохранить все [image] на панели инструментов).

Для нового проекта или чертежа вызывается диалог Сохранить как.

После сохранения текущий проект или чертеж остается открытым, и с ним можно продолжать работу.


меню Файл/Сканирование

меню Сканирование

Сканировать - вызывает программу сканирования

Выбрать источник - позволяет выбрать сканер


меню Файл/Импорт

меню Импорт

Растры

Точки привязки по шаблону

Дополнительные точки по шаблону

Матрицы высот

Импорт матрицы по шаблону


меню Веб-карты

Импорт в проект

Выбрать источник


меню Файл/Экспорт растра

меню Экспорт растра

Меню находится в главном меню Файл и содержит следующие команды:

Экспорт проекта

Экспорт фрагментов

Экспорт контура


Команда Экспорт матрицы высот (меню Файл)

Экспорт матрицы высот

Команда предназначена для экспорта одного выбранного фрагмента-матрицы.

Вызовите команду (кнопка Экспортировать выбранную матрицу высот [image] на панели инструментов).

В открывшемся диалоге Сохранить матрицу высот в поле Тип файла укажите один из форматов. В поле Имя файла задайте имя экспортируемой матрицы.

По умолчанию имя экспортируемой матрицы соответствует имени фрагмента.

Экспортировать матрицу возможно в форматы GeoTIFF (*.tif), TXT (*.txt).

После экспорта файла появится окно с сообщением о завершении экс-порта.

См. также

Экспорт


меню Файл/Экспорт модели

меню Экспорт модели

Меню находится в главном меню Файл и содержит следующие команды:

Экспорт в GDS4

Экспорт в DXF

Экспорт в МIF/MID


Команда Свойства проекта (меню Файл)

Свойства проекта

Команда предназначена для редактирования параметров проекта.

Выберите команду (кнопка Свойства проекта [image] на панели инструментов).

В открывшемся диалоге Свойства проекта задайте параметры, необходимые для работы с проектом.


команда Классификатор (меню Файл)

Классификатор

Команда открывает классификатор, который используется по умолчанию в текущем проекте.

Порядок работы:

Вызовите команду (кнопка Классификатор [image] на панели инструментов).

См. также

Работа с Классификатором


Команда Параметры программы (меню Файл)

Параметры программы

Команда позволяет установить настройки цветов, отображения и выполнить общие настройки.

Чтобы выполнить настройки программы:

Вызовите команду Параметры программы из меню Файл или кнопкой [image] Параметры программы на панели инструментов.. Открывается окно диалога.

В разделе Общие настройки задаются следующие настройки:

При установленном значении Да в строке Резервные копии создаются резервные копии проектов при их сохранении.

При установленном значении Да в строке Автосохранение будет происходить автоматическое сохранение проектов через заданный период времени (строка Период автосохранения, мин.).

Период автосохранения, мин. Указывается период, через который будет происходить автоматическое сохранение.

Автосохранение производится в папку, указанную в строке Временная папка. Создается копия проекта с внесенными на момент автосохранения изменениями с расширением tmd – для файлов проекта, ddr4 – для файлов чертежей.

Размер истории документов – задается количество последних открытых проектов, которые отображаются в меню Файл/Недавние проекты.

Размер истории изменений – задается количество последних действий при редактировании данных проектов, которые отображаются в окне История.

Временная папка приложения – папка для хранения временных файлов. При этом размер свободного места на диске должен превышать размер растровых фрагментов, планируемых для обработки в проекте. По умолчанию задана системная временная папка.

Раздел План/Цвета содержит настройки цвета рабочего экрана и элементов проекта.

В разделе Представление таблиц выполняется настройка параметров таблиц (Точки привязки и Фрагменты).

Заданные параметры могут быть импортированы и экспортированы (кнопки Импорт и Экспорт в нижней части диалога). В качестве обменного формата используется XML. При экспорте и импорте можно указать разделы настроек, относительно которых производится обмен.

Кнопка Восстановить умолчания предназначена для установки настроек, заданных по умолчанию.

Для выхода из диалога с сохранением внесенных изменений нажмите кнопку ОК. Для отказа от установленных настроек нажмите кнопку Отмена.


Команда Выход (меню Файл)

Выход

Команда осуществляет выход из программы с запросом на сохранение изменений в проектах и чертежах, если оно необходимо.

Выберите команду Выход в меню Файл (кнопка Выход [image] на панели инструментов).

Для каждого открытого проекта или чертежа с несохраненными изменениями программа запросит подтверждение на сохранение перед закрытием.

Кнопка Да закрывает проект или чертеж с сохранением изменений. При нажатии кнопки Нет все изменения будут потеряны.

При нажатии кнопки Отмена выполнение команды Выход прекращается, и происходит возврат в программу ВЕКТОРИЗАТОР.


Меню Правка

Команды меню Правка

Отменить

Вернуть

Копировать

Вырезать

Вставить

Удалить


Команда Отменить (меню Правка)

Отменить

Команда отменяет последнее выполненное действие. Команда доступна как в режиме подготовки растровой подложки, так и в режиме компоновки чертежа.

Выберите команду Отменить меню Правка (кнопка Отменить [image] на панели инструментов или горячие клавиши <Ctr + Z>).

Команда позволяет отменить последовательно несколько действий. Если отменить последнее действие невозможно, команда становится недоступной.

См. также

Вернуть


Команда Вернуть (меню Правка)

Вернуть

Возвращает проект или чертеж к тому состоянию, в котором он был до применения команды Отменить меню Правка. Команда доступна как в режиме подготовки растровой подложки, так и в режиме компоновки чертежа.

Выберите команду Вернуть меню Правка (кнопка Вернуть [image] на панели инструментов или горячие клавиши <Ctr + Y>).

Команда позволяет вернуть последовательно несколько действий. Если вернуть действие невозможно, команда становится недоступной.

См. также

Отменить


Команда Копировать (меню Правка)

Копировать

Команда копирует выбранные фрагменты проекта (чертежа) в буфер обмена, не удаляя его из проекта (чертежа). Команда применяется в режиме подготовки растровой подложки к фрагментам проекта, а в режиме компоновки чертежа – к фрагментам чертежа.

Выберите фрагмент.

Выберите команду Копировать меню Правка (кнопка Копировать [image] на панели инструментов, горячие клавиши - <Ctr + С>).

Скопированный фрагмент будет сохраняться в буфере обмена до помещения туда путем вырезания или копирования другого содержимого.

При копировании фрагмента проекта в буфер обмена, помимо самого растра, помещаются опорные точки, параметры привязки и контур видимости. Это означает, что при вставке фрагмента из буфера обмена в другой проект он вставится в неизменном виде: с тем же контуром видимости, опорными точками и в те же координаты.
При попытке вставить скопированный из ВЕКТОРИЗАТОРа в буфер обмена фрагмент в другое приложение (Paint, Imaging и т.п.) будет вставлен только сам растр. Остальные атрибуты фрагмента (контур видимости, опорные точки, координаты привязки) теряются.

См. также

Вырезать


Команда Вырезать (меню Правка)

Вырезать

Команда удаляет выбранные фрагменты из текущего проекта (чертежа) и помещает его в буфер обмена. Команда применяется в режиме подготовки растровой подложки к фрагментам проекта, а в режиме компоновки чертежа – к фрагментам чертежа.

Выберите фрагменты.

Выберите команду Вырезать меню Правка (кнопка Вырезать [image] на панели инструментов, горячие клавиши - <Ctr + Х>).

Если операция применяется в режиме подготовки растровой подложки к заблокированному фрагменту, то на экране появится сообщение о том, что фрагмент заблокирован, и запрос на удаление этого фрагмента.

Вырезанный фрагмент будет сохраняться в буфере обмена до помещения туда путем вырезания или копирования другого содержимого.

При вырезании фрагмента проекта в буфер обмена, помимо самого растра, помещаются опорные точки, параметры привязки и контур видимости. Это означает, что при вставке фрагмента из буфера обмена в другой проект он вставится в неизменном виде: с тем же контуром видимости, опорными точками и в те же координаты.
При попытке вставить вырезанный из ВЕКТОРИЗАТОРа в буфер обмена фрагмент в другое приложение (Paint, Imaging и т.п.), будет вставлен только сам растр. Остальные атрибуты фрагмента (контур видимости, опорные точки, координаты привязки) теряются.

См. также

Копировать


Команда Вставить (меню Правка)

Вставить

Команда вставляет содержимое буфера обмена в проект или чертеж. Команда применяется в режиме подготовки растровой подложки для вставки фрагментов проекта, а в режиме компоновки чертежа – для вставки фрагментов чертежа.

Выберите в меню Правка команду Вставить (кнопка Вставить [image] на панели инструментов, горячие клавиши - <Ctr + V>).

Команда доступна в случае, когда буфер обмена содержит данные, причем данные соответствующего типа: в режиме подготовки растровой подложки – это фрагмент проекта либо просто растровое изображение, помещенное туда другим приложением, в режиме компоновки чертежа – это фрагмент чертежа.

См. также

Вырезать

Копировать


Команда Удалить (меню Правка)

Удалить

Команда удаляет выбранные фрагменты или объекты из текущего проекта.

Выберите фрагменты.

Выберите команду Удалить в меню Правка (кнопка Удалить [image] панели инструментов либо горячая клавиша <Del>).

Если операция применяется к заблокированному фрагменту, то на экране появится сообщение о том, что фрагмент заблокирован, и запрос на удаление этого фрагмента.

Команда удаляет фрагмент без помещения его в буфер обмена.

Вернуть удаленные фрагменты можно с помощью команды Отменить меню Правка.


Меню Вид

Команды меню Вид

Меню Вид содержит команды управления отображением окон и вкладок в группах вкладок. Выбор команды включает видимость соответствующего окна - значок для соответствующего окна находится в "нажатом" состоянии. Повторный выбор команды отключает видимость окна.

План | включает/отключает видимость окна План
Фрагменты | включает/отключает видимость окна Фрагменты
Точки привязки | включает/отключает видимость окна Точки привязки
Слои ТО | включает/отключает видимость окна Слои ТО
Тематические объекты | включает/отключает видимость окна Тематические объекты
Свойства | включает/отключает видимость окна Свойства
История | включает/отключает видимость окна История
Панели | включает/отключает видимость панелей инструментов


Меню Инструменты

Команды меню Инструменты

Объединить выбранные фрагменты

Блокировка

Скрыть

Отобразить все фрагменты

Вертикальный порядок

Поворот

Отражение

Область видимости

Обрезка

Глубина цвета

Заменить цвет

Инвертировать

Яркость, контраст и гамма

Прозрачность

Карандаш

Заливка

Залить дыры

Убрать пятна

Сгладить

Увеличить резкость


Команда Объединить выбранные фрагменты (меню Инструменты)

Объединить выбранные фрагменты

Команда объединяет несколько выбранных фрагментов в один.

В зависимости от типа фрагмента команда работает по-разному – для растров и матриц высот.

Левой клавишей мыши (ЛКМ) используя клавиши <Shift+ЛКМ>, <Ctrl+ЛКМ>, выберите фрагменты.

Выберите команду Объединить выбранные фрагменты в меню Инструменты (кнопка Объединить выбранные фрагменты [image] на панели Инструменты).

Пункт меню и кнопка на панели инструментов доступны только тогда, когда выбраны два и более фрагмента одного типа (более двух растров, более двух матриц).

Растры и матрицы высот не объединяются друг с другом.

Если на момент вызова функции в наборе фрагментов содержались и растры, и матрицы высот, сначала растры объединяются в один растр, затем матрицы высот объединяются в одну матрицу.

Объединение растров

При объединении растров:

Учитываются границы областей видимости фрагментов.

Разрешение выходного растра устанавливается по фрагменту с наибольшим разрешением.

Глубина цвета выходного растра:

при объединении растров с глубиной цвета 1 бит/пиксель – 1 бит/пиксель;

во всех остальных случаях – 32 бит/пиксель.

Форма выходного растра достраивается до прямоугольной по внешним границам набора выбранных фрагментов.

Области, на которые не попали видимые части фрагментов, заливаются прозрачным цветом.

Объединение матриц высот

При объединении матриц высот:

Учитываются границы областей видимости фрагментов.

Детализация выходной матрицы устанавливается по фрагменту с наибольшей детализацией.

При объединении матриц к матрице с наибольшей детализацией присоединяется матрица с меньшей детализацией, потом с ещё меньшей и так до матрицы с наименьшей детализацией.

Если объединяются несколько матриц с одинаковой детализацией, учитывается их вертикальный порядок. Больше значение вертикального порядка – больше приоритет.

Форма выходной матрицы достраивается до прямоугольной по внешним границам набора выбранных фрагментов.

Пустые области (на которые не попали видимые части фрагментов), заполняются отметкой
-9999 м (в матрицах SRTM в шапке указывается: NODATA_value -9999).

Имя выходного растра устанавливается как Новый фрагмент [номер_фрагмента].

После объединения опорные точки, созданные на фрагментах, сохраняются и остаются на своих местах.

См. также

Фильтры


Команда Блокировка (меню Инструменты)

Блокировка

Команда устанавливает/снимает блокировку фрагментов. Управление блокировкой фрагментов работает независимо от типа фрагмента – одинаково для растров и матриц высот.

Для заблокированного фрагмента нельзя изменить координаты растра – трансформировать, перемещать, поворачивать и т.д.

Чтобы заблокировать фрагмент:

Левой клавишей мыши (ЛКМ) выберите фрагмент или фрагменты. Несколько фрагментов можно выбрать, используя клавиши <Shift+ЛКМ>, <Ctrl+ЛКМ>.

Выберите команду Блокировка [image] в меню Инструменты. Команда также доступна из контекстного меню, вызываемого правой клавишей мыши, курсор на фрагменте.

Пункт меню и кнопка на панели инструментов доступны только тогда, когда выбран хотя бы один фрагмент.

Повторный вызов команды Блокировка снимает блокировку с выбранных фрагментов.

См. также

Блокировка фрагментов


Команда Скрыть (меню Инструменты)

Скрыть

Команда включает/отключает видимость фрагментов.

Левой клавишей мыши (ЛКМ) выберите фрагмент или фрагменты. Несколько фрагментов можно выбрать, используя клавиши <Shift+ЛКМ>, <Ctrl+ЛКМ>.

Выберите команду Скрыть [image] в меню Инструменты. Команда также доступна из контекстного меню, вызываемого правой клавишей мыши, курсор на фрагменте.

Управлять отображением фрагментов можно также:

установкой флажка в таблице Фрагменты (столбец Видимость),

для выбранных фрагментов – установкой флажка видимость в окне Свойства.

Включить видимость одновременно всех фрагментов можно с помощью команды Отобразить все фрагменты меню Инструменты.


Команда Отобразить все фрагменты (меню Инструменты)

Отобразить все фрагменты

Команда включает видимость одновременно всех фрагментов проекта.

Выберите команду Отобразить все фрагменты [image] в меню Инструменты. Команда также доступна из контекстного меню, вызываемого правой клавишей мыши.


Меню Инструменты/Вертикальный порядок

меню Вертикальный порядок

Команды меню Инструменты/Вертикальный порядок управляют порядком отрисовки фрагментов, перемещая активный фрагмент выше, ниже, на передний план, на задний план относительно всех остальных фрагментов:

– На передний план – перемещает фрагмент на передний план,

– На задний план – перемещает фрагмент на задний план,

– На уровень выше – перемещает фрагмент на один уровень выше,

– На уровень ниже – перемещает фрагмент на один уровень ниже.

Порядок работы:

Левой клавишей мыши (ЛКМ) выберите фрагмент или фрагменты. Несколько фрагментов можно выбрать, используя клавиши <Shift+ЛКМ>, <Ctrl+ЛКМ>.

Выберите нужную команду меню Вертикальный порядок.


Меню Инструменты/Поворот

меню Поворот

Команды меню Поворот поворачивают выбранный фрагмент (фрагменты) вокруг геометрического центра области видимости фрагмента или геометрического центра фрагмента, если область видимости не построена.

– Повернуть на 90° вправо – поворачивает фрагмент на 90 градусов по часовой стрелке,

– Повернуть на 90° влево – поворачивает фрагмент на 90 градусов против часовой стрелки,

– Повернуть на 180° – поворачивает фрагмент на 180 градусов.

Пункты меню и кнопки на панели инструментов доступны только тогда, когда выбран хотя бы один незаблокированный фрагмент.

Левой клавишей мыши (ЛКМ) выберите фрагмент или фрагменты. Несколько фрагментов можно выбрать, используя клавиши <Shift+ЛКМ>, <Ctrl+ЛКМ>.

Выберите нужную команду меню Поворот.

См. также

Поворот фрагмента


Меню Инструменты/Отражение

меню Отражение

Команды меню Отражение отражают выбранный фрагмент (фрагменты) относительно горизонтальной или вертикальной оси:

– Отразить сверху вниз – выполняет зеркальное отображение фрагмента относительно горизонтальной оси,

– Отразить слева направо – выполняет зеркальное отображение фрагмента относительно вертикальной оси.

Порядок работы:

Левой клавишей мыши (ЛКМ) выберите фрагмент или фрагменты. Несколько фрагментов можно выбрать, используя клавиши <Shift+ЛКМ>, <Ctrl+ЛКМ>.

Выберите нужную команду меню Отражение.

См. также

Зеркальное отображение фрагмента


меню Область видимости

Команды меню Область видимости предназначены для управления границами области видимости фрагментов.

– Построить – строит произвольный контур области видимости фрагмента.

Вызовите команду.

Пункт меню и кнопка на панели инструментов доступны только тогда, когда выбран только один фрагмент.
Доступность функции не зависит от блокировки фрагментов.

В левом верхнем углу окна План появляется область подсказок с координатами курсора.

Постройте контур последовательным указанием его вершин нажатием левой клавиши мыши. Для отмены только что построенной вершины нажмите правую клавишу мыши. Для замыкания контура подведите курсор к первой или последней указанной вершине и захватите ее.

Выход из построения без применения изменений производится нажатием клавиши <Esc>.

Замыкание строящегося контура применяет построение.

Скрыть/отобразить части фрагмента за пределами контура видимости можно с помощью команды Применять области видимости.

– Редактировать – позволяет изменить границу области видимости выбранного фрагмента.

Вызовите команду.

Пункт меню и кнопка на панели инструментов доступны только тогда, когда выбран только один фрагмент.
Доступность функции не зависит от блокировки фрагментов.

После запуска функции отображаются границы областей видимости всех фрагментов.

В левом верхнем углу окна План появляется область подсказок с координатами курсора.

Граница области видимости редактируется перетаскиванием узлов его границы, удалением или добавлением узлов.

Выход из построения с применением изменений производится правым кликом мыши или нажатием клавиши <Esc>.

После завершения работы функции границы областей видимости всех фрагментов перестают отображаться.

– По номенклатуре листа карты – устанавливает границу области видимости фрагмента по внешним границам листа карты (по координатной рамке), рассчитывая положение узлов границы на основе номенклатуры листа.

Для корректной работы функции необходимо предварительно привязать фрагмент при помощи функции Трансформация/Привязка листа карты.

Для более точного результата функцию рекомендуется использовать после кусочно-линейной трансформации фрагмента.

Пункт меню и кнопка на панели инструментов недоступны, если в проекте не установлена система координат.
Пункт меню и кнопка на панели инструментов доступны только тогда, когда выбран только один фрагмент.
Доступность функции не зависит от блокировки фрагментов.

Вызовите команду.

После вызова функции появляется окно для ввода номенклатуры листа карты. После нажатия в этом окне кнопки ОК создаётся область видимости выбранного фрагмента.

– По границе фрагмента – устанавливает границу контура видимости по границе фрагмента.

Выберите один или несколько фрагментов и вызовите команду – границы областей видимости этих фрагментов установятся по границам фрагментов.

– Применять области видимости – – флажок позволяет включить или отключить учёт границ областей видимости выбранных фрагментов при их отображении в окне План.

Выберите один или несколько фрагментов и нажмите кнопку Применять область видимости.

Фрагменты, для которых отключено применение областей видимости, отображаются полностью, но границы их областей видимости по-прежнему видны.


Команда Обрезка (меню Инструменты)

Обрезка

Команда изменяет физические размеры фрагментов, обрезая их рамкой.

Функция позволяет обрезать либо все фрагменты, которые попали под рамку, либо только выбранные фрагменты (то есть, перед запуском функции не обязательно выбирать фрагменты).

Левой клавишей мыши (ЛКМ) выберите фрагмент или фрагменты. Несколько фрагментов можно выбрать, используя клавиши <Shift+ЛКМ>, <Ctrl+ЛКМ>.

Если не выбран ни один фрагмент, обрезаются все фрагменты, попавшие под рамку.

Вызовите команду Обрезка меню Инструменты (кнопка Обрезать фрагменты прямоугольной рамкой [image] на панели инструментов).

Включается режим создания рамки: в верхнем левом углу окна План появляется панель построения, курсор принимает вид [image].

Укажите верхний левый (правый) и нижний правый (левый) угол рамки – рамка построена. Производится обрезка фрагмента.

Обрезаются только выбранные фрагменты (остальные фрагменты остаются без изменений, даже если рамка попала на них).

Отказаться от выполненной операции можно с помощью команды Отменить меню Правка.


меню Глубина цвета

Команды меню изменяют глубину цвета изображения. Изменение глубины цвета доступно только для растров.

Пункт меню и кнопка на панели инструментов доступны только тогда, когда выбран хотя бы один фрагмент. Доступность функции не зависит от блокировки фрагментов.

– Черно-белый (1 бит) – преобразует фрагмент в 1-битный черно-белый.

– Оттенки серого (8 бит) – преобразует фрагмент в 8-битный (256 градаций серого).

– Цветной (32 бит) – преобразует фрагмент в 32-битный (цветной).

Порядок работы:

Выберите один или несколько фрагментов.

Вызовите команду.

Для команды Черно-белый (1 бит):

каждый пиксель, яркость которого выше некоторого порогового значения, становится белым;

пиксели, яркость которых ниже порогового значения, становятся черными.

Для оптимального подбора порогового значения и получения результирующего изображения с максимально четкой прорисовкой деталей при минимальной "зашумленности" изображения предусмотрена возможность интерактивного подбора порогового значения.

После преобразования фрагмента открывается диалог Пороговый уровень.

Перемещая бегунок (мышью, клавишами клавиатуры ¬, ® или <PageUp> и <PageDown>), задайте пороговый уровень. Изображение будет откорректировано.

Отказаться от преобразования можно, нажав кнопку Отмена.

Для применения преобразования нажмите кнопку ОК.

Отказаться от выполненной операции можно с помощью команды Отменить меню Правка.


Команда Заменить цвет (меню Инструменты)

Заменить цвет

Функция заменяет один цвет на растре другим цветом.

Возможность замены цвета для растров с глубиной цвета 1 бит недоступна.

Для замены цвета выберите фрагмент.

Пункт меню и кнопка на панели инструментов доступны только тогда, когда выбран хотя бы один фрагмент. Доступность функции не зависит от блокировки фрагментов.

Выберите команду Заменить цвет (кнопка Заменить цвет [image] на панели Инструменты).

После запуска в области подсказок появляются два поля с выпадающими списками: одно для выбора исходного цвета, второе – для выбора результирующего цвета.

В самом верху списка расположен пункт Выбрать для вызова окна выбора цвета.

В окне Выбор цвета можно точно указать заменяемый цвет или по кнопке Указать цвет на экране запустить инструмент для указания цвета с экрана.

После выбора цвета, который требует замены, и цвета, на который требуется заменить нажмите кнопку ОК.

Отказаться от выполненной операции можно с помощью команды Отменить меню Правка.


Команда Инвертировать (меню Инструменты)

Инвертировать

Команда инвертирует цветовую гамму изображения выбранных фрагментов. Инверсия доступна только для растров.

Как правило, команда применяется для обработки изображений, полученных в результате сканирования негативов.

Пункт меню и кнопка на панели инструментов доступны только тогда, когда выбран хотя бы один фрагмент.

Чтобы инвертировать цвета фрагмента:

Выберите фрагмент.

Выберите команду Инвертировать в меню Инструменты (кнопка Инвертировать [image] панели Инструменты).

Отказаться от выполненной операции можно с помощью команды Отменить меню Правка.

См. также

Фильтры


Команда Яркость, контраст и гамма (меню Инструменты)

Яркость, Контраст и гамма

Команда изменяет яркость, контраст и гамму выбранных фрагментов.

Изменение яркости, контраста и гаммы работает только для растровых фрагментов. Если в наборе содержатся как растры, так и матрицы высот, настройка влияет только на растры.

Для настройки яркости, контраста и гаммы:

Выберите фрагмент.

Выберите команду Яркость, контраст и гамма [image] меню Инструменты. Открывается диалоговое окно с фильтрами Яркость, Контраст, Гамма.

Пункт меню и кнопка на панели инструментов доступны только тогда, когда выбран хотя бы один фрагмент.

Перемещая бегунки (мышью, клавишами клавиатуры ¬, ® или <PageUp> и <PageDown>), отрегулируйте яркость, контраст и гамму изображения.

При перемещении бегунка изменения отображаются в окне План.

Отказаться от преобразования можно, нажав кнопку Отмена.

Для применения преобразования нажмите кнопку ОК. После нажатия кнопки ОК происходит изменение растра в соответствии с установленными настройками.

См. также

Фильтры


Команда Прозрачность (меню Инструменты)

Прозрачность

Команда устанавливает прозрачность при отображении фрагментов.

Управление прозрачностью фрагментов работает независимо от типа фрагмента – одинаково для растров и матриц высот.

Вызовите команду Прозрачность меню Инструменты (кнопка Прозрачность [image] панели Инструменты).

Пункт меню и кнопка на панели инструментов доступны только тогда, когда выбран хотя бы один фрагмент.

После вызова функции появляется окно настройки прозрачности.

Перемещая бегунки, настройте прозрачность фрагментов.

При перемещении бегунка изменения отображаются в окне План.

Прозрачность выбранных фрагментов может быть установлена в окне Свойства.

Настройка прозрачности влияет только на отображение фрагментов в окне План.

Отказаться от преобразования можно, нажав кнопку Отмена.

Для применения преобразования нажмите кнопку ОК.

См. также

Фильтры


Команда Карандаш (меню Инструменты)

Карандаш

Команда предназначена для рисования на фрагменте произвольных линий и областей. Инструменты рисования доступны только для растров.

Выберите фрагмент.

Выберите команду Карандаш в меню Инструменты (кнопка Карандаш [image] на панели Инструменты).

Пункт меню и кнопка на панели инструментов доступны только тогда, когда выбран только один фрагмент.

Вызов функции Карандаш недоступен для больших растровых изображений.

В верхнем левом углу окна План появляется панель построения, в которой выбирается толщина и цвет линии.

В самом верху списка расположен пункт Выбрать для вызова окна выбора цвета.

В окне Выбор цвета можно точно указать заменяемый цвет или по кнопке Указать цвет на экране запустить инструмент для указания цвета с растра.

Укажите начало линии, нажав левую клавишу мыши, и, удерживая клавишу нажатой, нарисуйте линию.

Отказаться от выполненной операции можно с помощью команды Отменить меню Правка.


Команда Заливка (меню Инструменты)

Заливка

Команда заливает выбранным цветом замкнутые однотонные области растра. Команда доступна только для растров.

Выберите фрагмент.

Выберите команду Заливка в меню Инструменты (кнопка Заливка [image] на панели Инструменты).

Пункт меню и кнопка на панели инструментов доступны только тогда, когда выбран хотя бы один фрагмент.

В верхнем левом углу окна План появляется панель построения, в которой выбирается цвет заливки.

Щелчком левой клавиши мыши укажите область, которую требуется залить.

Выбранная область будет закрашена в соответствии с выбранным цветом.

Отказаться от выполненной операции можно с помощью команды Отменить меню Правка.


Команда Залить дыры (меню Инструменты)

Залить дыры

Команда заливает дыры на выбранном фрагменте, т.е. удаляет "случайные" светлые пиксели, возникшие на полученном в результате сканирования изображении. Команда применима только к растрам.

Выберите фрагмент.

Выберите команду Залить дыры в меню Инструменты (кнопка Залить дыры [image] на панели Инструменты).

Пункт меню и кнопка на панели инструментов доступны только тогда, когда выбран хотя бы один фрагмент.

Отказаться от выполненной операции можно с помощью команды Отменить меню Правка.

См. также

Фильтры


Команда Убрать пятна (меню Инструменты)

Убрать пятна

Команда убирает пятна на выбранном фрагменте, т.е. удаляет "случайные" темные пиксели, возникшие на полученном в результате сканирования изображении. Действие команды обратно действию команды Залить дыры.

Команда применима только к растрам.

Выберите фрагмент.

Выберите команду Убрать пятна в меню Инструменты (кнопка Убрать пятна [image] на панели Инструменты).

Пункт меню и кнопка на панели инструментов доступны только тогда, когда выбран хотя бы один фрагмент.

Отказаться от выполненной операции можно с помощью команды Отменить меню Правка.

См. также

Фильтры


Команда Сгладить (меню Инструменты)

Сгладить

Команда "сглаживает" цвета изображения выбранного фрагмента путем удаления мелких ненужных деталей. Команда применима только к растрам.

Выберите фрагмент.

Выберите команду Сгладить в меню Инструменты (кнопка Сгладить [image] на панели Инструменты).

Пункт меню и кнопка на панели инструментов доступны только тогда, когда выбран хотя бы один фрагмент.

Отказаться от выполненной операции можно с помощью команды Отменить меню Правка.

См. также

Фильтры


Команда Увеличить резкость (меню Инструменты)

Увеличить резкость

Команда настраивает резкость изображения активного фрагмента. Фильтр может быть применен многократно. Команда применима только к растрам.

Выберите фрагмент.

Выберите команду Увеличить резкость в меню Инструменты (кнопка Увеличить резкость [image] на панели Инструменты).

Пункт меню и кнопка на панели инструментов доступны только тогда, когда выбран хотя бы один фрагмент.

Отказаться от выполненной операции можно с помощью команды Отменить меню Правка.

См. также

Фильтры


Меню Рельеф и ситуация

Команды меню Рельеф и ситуация

Создать/редактировать ТО

ТО по линии

ТО по прямоугольнику

ТО по окружности (дуге)

ТО по существующему

Обратить ЛТО

Продолжить ЛТО

Сшить ЛТО

Разрезать ЛТО

Замкнуть ЛТО

Создать точку

Создать поверхность

Настройка градиента


Команда Создать/редактировать ТО (Рельеф и ситуация)

Создать/редактировать ТО

Команда включает режим создания или редактирования тематического объекта (ТО) в окне План. Вызывается после предварительного выбора объекта в окне Слои ТО.

Команда применяется для создания/редактирования ТО в графическом окне и в окне Тематические объекты.

Порядок работы:

Выберите команду Создать/редактировать ТО в меню Рельеф и ситуация (кнопка Создать/редактировать ТО [image] на панели инструментов).

Создание ТО в графическом окне

Выберите команду. В графическом окне появится окно-подсказка.

Интерактивно укажите точки создаваемого объекта. Можно захватить точки модели либо указать точку в произвольном месте - при этом в модель будет добавлена дополнительная точка.

Для завершения построения ТО повторно захватите конечную точку. В окне Тематические объекты будет отображаться созданный тематический объект. В окне План объект будет отображаться заданным условным знаком.

Чтобы увидеть все созданные тематические объекты, необходимо в окне Слои ТО выбрать общий слой Топографические объекты. Чтобы увидеть все ТТО геодезических пунктов, необходимо выбрать слой Геодезические пункты и т.д.

Создание ТО в окне Тематические объекты

Выберите объект в окне Слои ТО.

В окне Тематические объекты активизируйте команду Вставить строку.

Для создания, например, точечного объекта в столбце Точки введите номер точки, на которой будет создан объект.

Для создания объекта с тем же кодом на следующей точке следует нажать на клавиатуре клавишу Стрелка вниз.

Для создания линейных и площадных объектов после выбора команды Вставить строку активизируйте команду Добавить строку. В столбце Точки введите номер точки, с которой будет начинаться объект. С помощью клавиши Стрелка вниз добавьте точки, по которым будет создан объект.

При необходимости в таблице для линейных либо для площадных объектов можно изменить порядок следования точек (необходимо перетянуть строку с точкой в нужное место).

Редактирование ТО

Созданные тематические объекты можно редактировать интерактивно либо в таблице Тематические объекты. При редактировании ТО в окне Слои ТО объект выбирать не нужно.

Для выхода из метода создания ТО нажмите правую кнопку мыши либо клавишу <Esc>.

См. также

Работа с тематическими объектами


Команда ТО по линии (Рельеф и ситуация)

ТО по линии

Команда строит тематический объект (ТО) по линии в окне План.

Порядок работы:

Выберите команду ТО по линии в меню Рельеф и ситуация (кнопка ТО по линии [image] на панели инструментов).

Постройте ломаную линию в виде простой полилинии, сплайна либо дуги. Для этого левой клавишей мыши задайте положение начала ломаной.

Последовательно задавайте положение следующих точек ломаной. Для завершения построения выберите повторно последнюю созданную вершину.

Правым кликом мыши можно отменить построение последней вершины линии.

В окне Свойства отредактируйте параметры построенного объекта. На основе построенной линии можно создать одновременно и линейный, и площадной, и точечные объект(ы).

Выход из построения производится клавишей <Esc>.

Удалить выделенный объект можно клавишей <Delete>.

См. также

Работа с тематическими объектами


Команда ТО по прямоугольнику (Рельеф и ситуация)

ТО по прямоугольнику

Команда строит площадной тематический объект (ТО) по прямоугольнику в окне План. Одновременно по его границе создается линейный ТО.

Порядок работы:

Выберите команду ТО по прямоугольнику в меню Рельеф и ситуация (кнопка ТО по прямоугольнику [image] на панели инструментов).

Укажите три опорные точки строящегося прямоугольного ТО с помощью левой клавиши мыши: задайте положение левой верхней, правой верхней и нижней правой вершин прямоугольника.

При необходимости в окне Свойства отредактируйте параметры вставленного объекта:

размеры и положение объекта,

параметры линейного, площадного объекта.

Выход из построения производится клавишей <Esc>.

Удалить выделенный объект можно клавишей <Delete>.

См. также

Работа с тематическими объектами


Команда ТО по окружности (дуге) (Рельеф и ситуация)

ТО по окружности (дуге)

Команда строит площадной тематический объект (ТО) по дуге окружности в окне План.

ТО создается по трем точкам либо в виде окружности, либо в виде дуги, хорды, сегмента.

Порядок работы:

Выберите команду ТО по окружности (дуге) в меню Рельеф и ситуация (кнопка ТО по окружности (дуге) [image] на панели инструментов).

Левой клавишей мыши определите начальную точку дуги окружности.

В окне Свойства уточните значение параметра Тип построения. В результате построения может быть создана как линия (значение Дуга) , так и полигон (значения Окружность, Сектор и Хорда).

Далее последовательно укажите еще две точки дуги окружности.

При необходимости в окне Свойства отредактируйте линейные, площадные параметры вставленного объекта.

Выход из построения производится клавишей <Esc> или правым кликом мыши.

Удалить выделенный объект можно клавишей <Delete>.

См. также

Работа с тематическими объектами


Команда ТО по существующему (Рельеф и ситуация)

ТО по существующему

Команда позволяет создать ТО по точкам существующих объектов в окне План. Например, по точкам контура здания создать площадной объект или по точкам ЛЭП создать столбы.

Порядок работы:

Выберите команду ТО по существующему в меню Рельеф и ситуация (кнопка [image] ТО по существующему на панели инструментов).

После вызова команды (если не выбран ЛТО) появляется подсказка "Выберите ЛТО или ПТО", а также поле выбора создаваемого объекта. Возможен выбор точечных, линейных и площадных объектов.

После выбора ПТО или ЛТО в окне План будет создан ТО по точкам выбранного.

Выход из построения производится клавишей <Esc> или правым кликом мыши.

См. также

Работа с тематическими объектами


Команда Обратить ЛТО (Рельеф и ситуация)

Обратить ЛТО

Команда изменяет направление ЛТО. Имеет смысл для несимметричных линий (например, заборов или линий с буквами).

Порядок работы:

Выберите команду Обратить ЛТО в меню Рельеф и ситуация (кнопка Обратить ЛТО [image] на панели инструментов).

Если ЛТО не выбран, клик по ЛТО в окне план меняет его направление. Если ЛТО выбран, вызов команды меняет его направление. В обоих случаях команда остается активна и можно обращать другие ЛТО.

Выход из построения производится клавишей <Esc> или правым кликом мыши.

Удалить выделенный объект можно клавишей <Delete>.

См. также

Работа с тематическими объектами


Команда Продолжить ЛТО (Рельеф и ситуация)

Продолжить ЛТО

Команда позволяет дорисовать существующий ЛТО в окне план.

Порядок работы:

Выберите команду Продолжить ЛТО в меню Рельеф и ситуация (кнопка Продолжить ЛТО [image] на панели инструментов).

После вызова команды (если не выбран ЛТО) появляется подсказка "Укажите ЛТО".

После выбора ЛТО в окне плана или сразу после вызова команды, если ЛТО выбран, появляется подсказка "Укажите крайнюю точку", при этом крайние точки выбранного ЛТО меняют вид.

Укажите точку с той стороны ЛТО, с которой необходимо его дорисовать. После выбора точки включается режим создания полилинии, в области подсказки верхней части окна плана отображаются текущие координаты курсора и расстояние создаваемого сегмента полилинии.

Продолжать ЛТО можно как интерактивно, указывая положение новых точек в окне плана, так и путем ввода значения координат или угла и расстояния в соответствующих полях.

Выход из построения производится клавишей <Esc> или правым кликом мыши.

Удалить выделенный объект можно клавишей <Delete>.

См. также

Работа с тематическими объектами


Команда Сшить ЛТО (Рельеф и ситуация)

Сшить ЛТО

Команда позволяет "сшить" два ЛТО.

Порядок работы:

Выберите команду Сшить ЛТО в меню Рельеф и ситуация (кнопка Сшить ЛТО [image] на панели инструментов).

После вызова команды (если не выбран ЛТО) появляется подсказка "Укажите первый ЛТО".

После выбора ЛТО в окне плана или сразу после вызова команды, если ЛТО выбран, появляется подсказка "Укажите второй ЛТО", при этом крайние точки выбранного ЛТО меняют вид.

Если второй ЛТО имеет общую точку с выбранным, клик по нему приведет к сшивке его с первым.

Если второй ЛТО не имеет общей точки с первым, то после выбора первого ЛТО можно выбрать одну из его концевых точек и появившимся отрезком соединить его с одним из концов второго ЛТО, ЛТО при этом сошьются с вставкой звена между ними.

Если оба ЛТО представляют собой разные объекты классификатора, сшитый объект будет того же типа, что и первый ЛТО.

Выход из построения производится клавишей <Esc> или правым кликом мыши.

Удалить выделенный объект можно клавишей <Delete>.

См. также

Работа с тематическими объектами


Команда Разрезать ЛТО (Рельеф и ситуация)

Разрезать ЛТО

Команда позволяет разрезать существующий ЛТО в окне плана.

Порядок работы:

Выберите команду Разрезать ЛТО в меню Рельеф и ситуация (кнопка Разрезать ЛТО [image] на панели инструментов).

После вызова команды (если не выбран ЛТО) появляется подсказка "Укажите ЛТО".

После выбора ЛТО в окне плана или сразу после вызова команды, если ЛТО выбран, появляется подсказка "Укажите точку разреза".

После указания точки разреза произойдет разрезка ЛТО на два объекта. Может быть указана как существующая точка (узел ЛТО), так и любой участок звена ЛТО.

Выход из построения производится клавишей <Esc> или правым кликом мыши.

Удалить выделенный объект можно клавишей <Delete>.

См. также

Работа с тематическими объектами


Команда Создать точку (Рельеф и ситуация)

Создать точку

Команда позволяет добавить точку с высотой и подписью высоты в модель.

Порядок работы:

Выберите команду Создать точку в меню Рельеф и ситуация (кнопка Создать точку [image] на панели инструментов).

После вызова команды в верхней части окна план появляется окно с текущими координатами и полем для ввода высоты. Координаты также могут быть введены с клавиатуры.

Точка с введенным значением высоты будет создана в текущих координатах кликом мыши или после ввода координат с клавиатуры по нажатию ОК в окне редактирования координат.

Выход из построения производится клавишей <Esc> или правым кликом мыши.

Удалить выделенный объект можно клавишей <Delete>.

См. также

Работа с тематическими объектами


Команда Создать поверхность (Рельеф и ситуация)

Создать Поверхность

Команда создает цифровую модель рельефа на основе:

точек, имеющих высоту и признак отношения к рельефу Рельефная;

распознанных горизонталей (они участвуют в поверхности как структурные линии с постоянной высотой);

линейных тематических объектов, имеющих признак отношения к рельефу Рельефный и опирающихся на точки с высотой. Эти ЛТО участвуют в построении поверхности в качестве структурных линий.

Порядок работы:

Выберите команду Создать поверхность в меню Рельеф и ситуация (кнопка Создать поверхность [image] на панели инструментов).

Поверхность будет создана автоматически. В случае невозможности создания программа выведет сообщение.

Построенная модель рельефа отображается в окне План.

Параметры построения и отображения поверхности настраиваются в диалоге Свойства проекта в разделе План, группа Поверхность рельефа.

См. также

Создание цифровой модели местности

Работа с тематическими объектами


Команда Настройка градиента (Рельеф и ситуация)

Настройка градиента

Команда настраивает градиент построенной поверхности.

Порядок работы:

Выберите команду Настройка градиента в меню Рельеф и ситуация (кнопка Настройки градиента [image] на панели инструментов).

В открывшемся окне с помощью вертикального "ползунка" настройте градиент цветовой гаммы. Нажмите ОК.


Меню Трансформация

Команды меню Трансформация

Меню активно при наличии лицензии ТРАНСФОРМ.

Создать точку привязки

Создать пару точек

Создать сетку точек

Нанести точку привязки

Привязка планшета

Привязка листа карты

Управление привязками

Корректировка точек

Аффинная трансформация

Кусочно-линейная трансформация

Ортокоррекция космоснимка


Команда Создать точку привязки (меню Трансформация)

Создать точку привязки

Выполняется только при наличии лицензии ТРАНСФОРМ.

Команда предназначена для создания одиночных точек привязки (абсолютных и относительных).

Этот способ подходит для создания точек привязки в характерных местах изображения, расположенных нерегулярно (пункты геодезического обоснования, колодцы, иные точки растра).

Вызовите команду Создать точку привязки из меню Трансформация (кнопка Создать точку привязки [image] на панели инструментов).

В левом верхнем углу окна План появляется область подсказок с текстом: Создание точки привязки.

Левым кликом мыши по растровому фрагменту укажите точку привязки.

Точка привязки создаётся на том растровом фрагменте, над областью видимости которого находился курсор мыши.

Осуществлять интерактивную привязку точек надо как можно точнее. Для этого желательно увеличить фрагмент изображения, пользуясь колесиком мыши либо кнопками масштабирования. Для ускорения указания положения создаваемых точек привязки используется функция распознавания пересечений линий на растрах (крестов координатной сетки, пересечений линий координатной сетки). На время указания точки привязки можно отключить распознавание пересечений, нажав клавишу <F3>.

После указания местоположения точки привязки появляется окно для редактирования типа, имени и координат точки привязки.

После нажатия кнопки ОК программа ожидает указания положения следующей точки привязки.

В зависимости от типа выбранной системы координат, выбранного формата ввода и настройки представления координат (Файл/Свойства проекта) задание координат точек привязки может осуществляться как Широта/Долгота (B, L) или как плоские координаты (Х, Y), с учетом представления.

После создания на фрагменте двух точек привязки с координатами, координаты следующих создаваемых точек привязки автоматически рассчитываются с учетом предварительной привязки растра по созданным точкам. Т.е. не в СК растра, а в пользовательской СК, заданной созданными точками привязки.

Автоматически рассчитанные координаты точек привязки округляются в соответствии со значением, введённым в поле Округление координат. Значения параметра Округление координат можно выбирать из выпадающего списка или вводить вручную. Отключение режима округления координат производится выбором значения Нет в выпадающем списке.

По умолчанию при создании одиночной точки привязки значение округления = Нет .

Если в выпадающем списке выбрано Нет, точность отображения координат берётся из свойств проекта (Единицы измерения и точность).

Округление действует только на автоматически рассчитанные координаты. Координаты, введённые пользователем, не округляются.

Таким образом задается необходимое количество опорных точек. Число задаваемых точек зависит от качества растрового изображения. Если метрическое качество растра неудовлетворительное, рекомендуется использовать максимально возможное количество точек. Число задаваемых опорных точек практически неограничено. Минимальное количество опорных точек для трансформации – две.

См. также

Типы точек привязки

Задание точек привязки

Редактирование точек привязки

Удаление точек привязки


Команда Создать пару точек (меню Трансформация)

Создать пару точек

Выполняется только при наличии лицензии ТРАНСФОРМ.

Команда предназначена для создания относительных точек привязки попарно, т.е. первая точка создается на одном растре, а вторая – на втором.

Функция необходима для сшивки краёв растров.

Вызовите команду Создать пару точек из меню Трансформация (кнопка Создать пару точек [image] панели инструментов).

В левом верхнем углу окна План появляется область подсказок с текстом: Создание пары относительных точек привязки.

Левым кликом мыши по растровому фрагменту укажите первую точку пары.

Затем левым кликом мыши по другому растровому фрагменту укажите вторую точку пары.

После указания положения второй точки в указанных местах создаются две относительных точки привязки. Имя для указанных точек генерируется автоматически. Далее программа ожидает указания положения первой точки второй пары.

Для ускорения указания положения создаваемых точек привязки используется функция проецирования точек привязки на границы областей видимости фрагментов. На время указания точки привязки можно отключить проецирование, нажав клавишу <F3>.

См. также

Типы точек привязки

Задание точек привязки

Редактирование точек привязки

Удаление точек привязки


Команда Создать сетку точек (меню Трансформация)

Создать сетку точек

Выполняется только при наличии лицензии ТРАНСФОРМ.

Данная команда позволяет создать на выбранном фрагменте абсолютные точки привязки с заданным шагом сетки.

Для автоматического создания сетки точек привязки необходимо, чтобы на выбранном фрагменте были созданы как минимум две абсолютные точки.

Выберите фрагмент.

Вызовите команду Создать сетку точек из меню Трансформация (кнопка Создать сетку точек [image] панели инструментов).

Откроется окно, в котором нужно ввести значение шага.

При изменении шага N, м шаг Е, м становится равным N, м. Но изменение шага Е, м не влияет на значение N, м.

После нажатия на кнопку ОК запускается генерация точек привязки.

Если в окне для ввода шага сетки была активирована опция Проверять корректность генерации, после завершения генерации точек автоматически запустится функция Корректировка точек.

См. также

Типы точек привязки

Задание точек привязки

Редактирование точек привязки

Удаление точек привязки


Команда Нанести точку привязки (меню Трансформация)

Нанести точку привязки

Выполняется только при наличии лицензии ТРАНСФОРМ.

Команда предназначена для указания положения точек на растровых фрагментах.

Порядок работы:

Вызовите команду Нанести точку привязки из меню Трансформация (кнопка Нанести точку привязки [image] на панели инструментов).

Выберите точку в таблице Точки привязки, укажите ее положение на необходимом растровом фрагменте. Координаты точки вводить при этом не нужно, они были прочитаны из текстового файла и уже присутствуют в таблице.

Все действия сопровождаются подсказками в левом верхнем углу окна План.

После указания точек на растрах, они группируются по соответствующим фрагментам, таким образом по мере указания импортированных точек они из группы Непривязанные попадают в группы по фрагментам, как и обычные точки привязки.

См. также

Управление привязками


Команда Привязка планшета (меню Трансформация)

Привязка планшета

Выполняется только при наличии лицензии ТРАНСФОРМ.

Команда предназначена для привязки планшета по его углам, координатам левого верхнего угла и масштабу.

Вызовите команду Привязка планшета из меню Трансформация (кнопка Привязка планшета [image] панели инструментов).

В левом верхнем углу окна План появляется область подсказок. Вначале укажите левый верхний угол рамки планшета и его координаты. Затем укажите правый верхний угол, правый нижний угол и левый нижний угол рамки планшета. После указания каждого угла содержимое окна План панорамируется так, что в центре окна оказывается следующий угол планшета.

После указания левого нижнего угла рамки появляется окно для ввода масштаба съёмки, размера планшета, а также активации генерации сетки точек и проверки корректности генерации.

Если генерация точек привязки не была активирована, после нажатия кнопки ОК на фрагменте будут созданы только четыре точки привязки (в указанных углах) и произведена аффинная ВЕКТОРИЗАТОРация фрагмента.

Если генерация точек была активирована, после нажатия кнопки ОК запускается функция Создать сетку точек (шаг сетки рассчитывается автоматически по масштабу съёмки и размеру планшета).

Если проверка корректности генерации была активирована, после создания сетки точек будет запущена функция Корректировка точек.

После привязки планшета масштаб съёмки проекта устанавливается в соответствии с масштабом съёмки привязанного планшета.

См. также

Типы точек привязки

Задание точек привязки

Редактирование точек привязки

Удаление точек привязки


Команда Привязка листа карты (меню Трансформация)

Привязка листа карты

Выполняется только при наличии лицензии ТРАНСФОРМ.

Команда позволяет привязать лист карты по его углам и номенклатуре.

Для работы команды необходимо предварительно задать в свойствах проекта систему координат (команда Файл/ Свойства проекта раздел Система координат).

Вызовите команду Привязка листа карты из меню Трансформация (кнопка Привязка листа карты [image] панели инструментов).

В левом верхнем углу окна План появляется область подсказок.

Укажите положение углов карты, начиная с левого верхнего. После указания каждого угла содержимое окна План панорамируется так, что в центре окна оказывается следующий угол листа карты.

После указания левого нижнего угла рамки появляется окно для ввода номенклатуры листа карты, а также активации генерации сетки точек и проверки корректности генерации.

Если генерация точек привязки не была активирована, после нажатия кнопки ОК на фрагменте будут созданы только четыре точки привязки (в указанных углах) и произведена аффинная трансформация фрагмента.

Если генерация точек была активирована, после нажатия кнопки ОК запускается функция Создать сетку точек (шаг сетки рассчитывается автоматически номенклатуре листа карты).

Если проверка корректности генерации была активирована, после создания сетки точек будет запущена функция Корректировка точек.

После привязки листа карты масштаб съёмки проекта устанавливается в соответствии с масштабом привязанного листа карты.

См. также

Типы точек привязки

Задание точек привязки

Редактирование точек привязки

Удаление точек привязки


Команда Управление првязками (меню Трансформация)

Управление привязками

Выполняется только при наличии лицензии ТРАНСФОРМ.

Команда изменяет координаты отдельного фрагмента или всего проекта.

Пункт меню и кнопка на панели инструментов доступны только тогда, когда в проекте есть хотя бы один растровый фрагмент.

Доступность функции не зависит от блокировки фрагментов.

Порядок работы:

Вызовите команду Управление привязками из меню Трансформация (кнопка Управление привязками [image] на панели инструментов).

В появившемся окне Управление привязками введите значения смещений по осям (N, E). Флажок Сместить все фрагменты проекта указывает, какие фрагменты будут смещаться: все или только выбранные.

Значения N и E могут быть как положительными, так и отрицательными. Единицы измерения и точность представления берутся из свойств проекта (параметр плоские координаты).

По умолчанию значения смещений равны нулю.

Если на момент вызова функции не был выбран ни один фрагмент, флажок Сместить все фрагменты проекта недоступен.

После нажатия кнопки ОК выбранные (или все) фрагменты проекта смещаются на заданную величину. Значения координат точек привязки, созданных на смещаемых фрагментах, изменяются на заданную величину.

См. также

Управление привязками

Ваши комментарии к справочной системе

© Компания "Кредо-Диалог"


Команда Корректировка точек (меню Трансформация)

Корректировка точек

Выполняется только при наличии лицензии ТРАНСФОРМ.

Команда позволяет выполнить проверку расстановки опорных точек, создаваемых программно.

Корректировка точек также запускается при привязке листов карты и планшетов, создании точек по сетке, если установлен соответствующий флажок.

Вызовите команду Корректировка точек из меню Трансформация (кнопка Корректировка точек [image] панели инструментов).

Пункт меню и кнопка на панели инструментов доступны только тогда, когда выбран только один фрагмент.

После активизации команды происходит панорамирование окна План, в центре расположена точка привязки, у которой уклонение по осям абсцисс (dN) и ординат (dE) максимальное. Точка выделяется цветом, заданным в параметрах программы (Файл/Параметры программы, раздел Цвет).

В левом верхнем углу окна План появляется вспомогательное окно, в котором отображается информация о корректируемой точке (имя и значения уклонений).

Для указания нового положения необходимо:

увеличить фрагмент изображения, пользуясь колесиком мыши либо кнопками масштабирования;

щелчком левой клавиши мыши указать новое местоположение точки;

подтвердить новое положение точки нажатием клавиши <Enter>. После чего произойдет переход на следующую точку.

В случае неоднозначности (например, на фрагменте некорректно отображается пересечение линий координатной сетки) – точку привязки можно удалить (клавиша <Del>).

См. также

Типы точек привязки

Задание точек привязки

Редактирование точек привязки

Удаление точек привязки


Команда Аффинная трансформация (меню Трансформация)

Аффинная трансформация

Выполняется только при наличии лицензии ТРАНСФОРМ.

Аффинная трансформация позволяет получить качественные результаты для растров, искаженных или вытянутых в направлении одной из координатных осей. В направлении каждой из координатных осей рассчитывается и потом применяется свой масштабный коэффициент.

Трансформируются только те фрагменты, которые не заблокированы и для которых задано не менее двух абсолютных точек привязки. В трансформации участвуют и относительные точки привязки.

Относительные опорные точки привязки не учитываются.

Вызовите команду Аффинная трансформация из меню Трансформация (кнопка Аффинная трансформация [image] панели Трансформация).

После успешной трансформации рассчитываются значения уклонений по осям абсцисс (dN), ординат (dE), абсолютной величине смещения (dS) точек привязки от их ожидаемого положения.

Трансформированные фрагменты блокируются.

трансформировать весь проект или один из фрагментов можно несколько раз, используя предыдущие привязки, изменяя и дополняя их.

В результате трансформации получается качественное изображение растра, в котором учитываются деформации сканирования и случайные ошибки нанесения координатной сетки.

См. также

Трансформация


Команда Кусочно-линейная трансформация (меню Трансформация)

Кусочно-линейная Трансформация

Выполняется только при наличии лицензии ТРАНСФОРМ.

Кусочно-линейная трансформация позволяет получать качественные в метрическом отношении изображения, в определенной степени исправляя такие дефекты, как складки бумаги, участки с неравномерным масштабом и другие. Одновременно обеспечивается привязка обрабатываемых растровых фрагментов к используемой системе координат.

Трансформируются только те фрагменты, которые не заблокированы и для которых задано не менее двух абсолютных точек привязки. В трансформации участвуют и относительные точки привязки.

Относительные опорные точки привязки, расположенные только на одном фрагменте, не учитываются.

Вызовите команду Кусочно-линейная трансформация из меню Трансформация (кнопка Кусочно-линейная Трансформация [image] панели Трансформация).

Трансформированные фрагменты блокируются.

См. также

Трансформация


Команда Ортокоррекция космоснимка (меню Трансформация)

Ортокоррекция космоснимка

Выполняется только при наличии лицензии ТРАНСФОРМ.

Команда активизирует процесс ортокоррекции космоснимка. Для выполнения ортокоррекции необходимо выполнение ряда условий.

Для работы в команде берется одна из матриц, полностью покрывающая снимок.

Вызовите команду Ортокоррекция космоснимка из меню Трансформация (кнопка Ортокоррекция космоснимка [image] панели инструментов).

Если в проекте не выбран ни один растровый фрагмент или выбрано несколько объектов, пункт меню и кнопка панели инструментов недоступны.

Производится проверка наличия и корректности исходного материала. После проверки появляется окно, в котором отображаются исходные данные и информация об их корректности.

По кнопке [image] выберите файл с данными RPC.

Нажмите кнопку ОК. Запустится расчет.

После ортокоррекции полученный снимок загружается в проект, заменяя собой выбранный снимок.


Меню Векторизация

Команды меню Векторизация

Распознавание подписей высоты

Распознавание горизонталей

Распознавание ТТО

Распознавание ЛТО

Векторизация

Распознавание текста


Команда Распознавание подписей высоты (Векторизация)

Распознавание Подписей высоты

Команда позволяет найти на выбранном фрагменте отметки высот и точки, к которым они относятся, распознать значение высоты и создать точки с подписями высот в соответствующих местах.

Вызовите команду Распознавание подписей высоты из меню Векторизация (кнопка Распознавание подписей высоты [image] на панели инструментов).

В появившемся окне настройте параметры распознавания: маску для отметок, вид точек и масштаб съемки (если масштаб съемки текущего фрагмента отличается от масштаба проекта). Если размер подписей высоты или точек отличается от требований условных знаков для выбранного масштаба, необходимо снять флаг "из масштаба съемки" и ввести данные вручную. Установкой флажка можно настроить "стирание распознанных отметок". Нажмите ОК.

По завершении процесса распознавания запускается интерактив проверки результатов.

На растре выделяется текущая отметка и положение точки, а в верхней части окна плана появляется подсказка с возможными действиями, полями для редактирования информации и кнопками (см. рисунок ниже). Таким образом интерактив предлагает проверить все найденные отметки.

В случае правильного распознавания значения высоты и положения точки необходимо просто нажать <Enter>.

В случае неправильного результата (подпись горизонтали или другие цифровые надписи вместо отметки) необходимо нажать "пробел" (Space).

В случае ошибки распознавания высоты или положения точки необходимо исправить значение высоты в соответствующем поле, а также указать правильное положение точки, после чего нажать <Enter>.

При необходимости возможно завершение интерактива без проверки всех отметок:

Esc – выход без создания точек.

Создать подтвержденные - будут созданы проверенные и подтвержденные точки.

Создать все - будут созданы ранее подтвержденные и все оставшиеся точки.

Редактирование подписей производится стандартными методами интерактивного редактирования графических элементов.

Параметры шрифта одинаковы для всех подписей данного типа, созданных в проекте, и настраиваются в диалоге Параметры программы.

См. также

Векторизация (процесс)


Команда Распознавание горизонталей (Векторизация)

Распознавание горизонталей

Команда позволяет векторизовать горизонтали в интерактивном режиме на выбранном фрагменте.

Вызовите команду Распознавание горизонталей из меню Векторизация (кнопка Распознавание горизонталей [image] панели инструментов).

В верхней части окна плана появляется сообщение, которое дает возможность уточнить масштаб текущего фрагмента и начать распознавание.

После инициализации распознавания в верхней части окна плана появляется подсказка с вариантами действий и настройки. Можно настроить стирание с растра распознанных горизонталей, а также включить сглаживание распознанных векторных горизонталей.

Для запуска распознавания необходимо кликнуть мышью по растровому изображению горизонтали, которую требуется векторизовать.

Поиск горизонтали происходит в одну строну от указанного места. Если поиск находит пересечение линий, то анализируются все примыкающие линии и цветом указывается наиболее вероятное продолжение, поиск в этом случае приостанавливается.

Для продолжения поиска необходимо выбрать желаемое продолжение линии, при этом можно выбрать как и наиболее вероятное рассчитанное продолжение, так и отвергнутые варианты, выделенные красным. В случае, если продолжения не найдены или среди предложенных вариантов нет правильного, можно выбрать продолжение горизонтали на растре. Как и при выборе горизонтали в начале распознавания, соответствующий участок будет добавлен к существующей линии.

Таким же образом можно перейти к другому концу горизонтали и продолжить ее собирать с той стороны. После указания очередного продолжения при наличии неоднозначности или отсутствии вариантов, будет продолжен автоматический поиск линии.

В случае ошибочного автоматического или ручного продолжения, последние действия по сборке линии можно откатить, нажимая правую клавишу мыши необходимое число раз. Текущий распознанный участок будет отображаться синим выделением. По мере полуавтоматической сборки линии он будет увеличиваться.

По завершении распознавания необходимо нажать соответствующую кнопку в окне подсказок, после чего появится диалоговое окно, предлагающее ввести высоту распознанной горизонтали. Значение высоты необходимо для учета распознанной горизонтали при построении поверхности. В дальнейшем высоту можно исправить, выбрав нужную горизонталь и отредактировав значение в окне Свойства.

После ввода высоты программа готова к распознаванию следующей горизонтали, новая инициализация не требуется. Выйти из режима распознавания горизонталей можно нажатием клавиши <Esc> или кнопки Выход в окне подсказок.

Редактирование подписей производится стандартными методами интерактивного редактирования графических элементов.

Параметры шрифта одинаковы для всех подписей данного типа, созданных в проекте, и настраиваются в диалоге Параметры программы.

См. также

Векторизация (процесс)


Команда Распознавание ТТО (Векторизация)

Распознавание ТТО

Команда позволяет найти на выбранном фрагменте все изображения точечные объектов заданного типа и создать на их месте точечные тематические объекты (ТТО) на основе классификатора.

Существует два способа распознавания: на основе изображения условного знака из классификатора и на основе указанного образца из растра. Первый способ можно использовать тогда, когда начертание условных знаков на растре соответствует их изображению в классификаторе. Если начертание разное, нужно использовать второй способ.

Вызовите команду Распознавание ТТО из меню Векторизация (кнопка Распознавание ТТО [image] панели инструментов).

В верхней части окна план появляется подсказка, предлагающая уточнить масштаб съемки и выбрать ТТО из классификатора для распознавания.

Кнопки в окне подсказок позволяют запустить распознавание по изображению из классификатора для выбранного ТТО (Использовать изображение символа ТТО) или указать образец на растре (Выбрать образец).

Распознавание по изображению из классификатора запустит процесс сразу после нажатия кнопки. В случае выбора образца необходимо рамкой выбрать изображение ТТО на растре. При выборе образца важно взять хорошо прорисованный символ и не допустить попадания в пределы рамки выбора других линий. Для указанного изображения будет рассчитана базовая точка условного знака, которая при необходимости может быть исправлена кликом мыши. Далее запускается процесс распознавания.

По завершении распознавания запускается интерактив проверки результатов.

На растре выделяются все найденные ТТО (красным цветом), текущий объект (синим цветом), а в верхней части окна план появляется подсказка с возможными действиями, полями для редактирования информации и кнопками. Подтвержденные ТТО меняют цвет выделения на зеленый.

Найденные образцы фильтруются по допуску достоверности. Достоверность 1 означает 100% соответствие образцу. Можно выбрать одну из преднастроенных конфигураций допуска для простых, стандартных и сложных объектов, либо ввести свое значение допуска. Основной принцип выбора значения допуска: чем сложнее изображение символа (например, хвойное дерево) - тем меньше достоверность всех найденных, и чем проще изображение (окружность) – тем выше достоверность. Таким образом, если для простого ТО поставить низкий порог достоверности, будет много ложных совпадений, и наоборот, если для сложного ТО выбрать высокий порог, не будет найдено ничего.

Результат работы фильтра сразу отображается в подсказке: отображается общее количество найденных ТО и тех, что прошли допуск по достоверности. В окне плана отображаются только прошедшие допуск регионы.

В случае правильного распознавания объекта необходимо просто нажать <Enter>. В случае неправильного результата необходимо нажать <Backspase>. При необходимости можно вернуться к ранее подтвержденному объекту и изменить решение (клавиша "влево").

Таким образом интерактив предлагает проверить все найденные ТТО.

При необходимости возможно завершение интерактива без проверки всех ТТО:

<Esc> – выход без создания;

Создать подтвержденные - будут созданы проверенные и подтвержденные ТТО;

Создать все - будут созданы ранее подтвержденные и все оставшиеся ТТО.

Редактирование подписей производится стандартными методами интерактивного редактирования графических элементов.

Параметры шрифта одинаковы для всех подписей данного типа, созданных в проекте, и настраиваются в диалоге Параметры программы.

См. также

Векторизация (процесс)


Команда Распознавание ЛТО (Векторизация)

Распознавание ЛТО

Команда позволяет векторизовать линейные тематические объекты (ЛТО) в интерактивном режиме на выбранном фрагменте.

Вызовите команду Распознавание ЛТО из меню Векторизация (кнопка Распознавание ЛТО [image] панели инструментов).

В верхней части окна План появляется сообщение с возможностью уточнить масштаб текущего фрагмента, а также настроить параметры распознаваемой линии - тип линии (сплошная/ пунктирная, гладкая/ломаная), объект классификатора - и начать распознавание.

После инициализации распознавания в верхней части окна План появляется подсказка с вариантами действий, а также настройки текущего распознавания: стирать линии с растра, спрямлять (сглаживать) линии. Опция Спрямлять линии доступна только для типа линии "ломаная", при включенной опции программа автоматически убирает лишние точки на прямых участках и корректно формирует углы между линиями. Опция Сглаживать линии доступна для гладких линий, при включенной опции программа автоматически убирает лишние точки, сглаживая "зубцы" на линиях, возникшие из-за особенностей растра. В случае ошибочных автоматических действий на отдельных объектах опции могу быть отключены.

Для запуска распознавания кликните мышью по растровому изображению ЛТО, который требуется векторизовать.

Поиск ЛТО происходит в одну строну от указанного места. Если поиск находит пересечение линий, то анализируются все примыкающие линии и цветом указывается наиболее вероятное продолжение, поиск в этом случае приостанавливается.

Для продолжения поиска необходимо выбрать желаемое продолжение линии, при этом можно выбрать как и наиболее вероятное рассчитанное продолжение, так и отвергнутые варианты, выделенные красным. В случае, если продолжения не найдены или среди предложенных вариантов нет правильного, можно выбрать продолжение линии на растре, как и при выборе ЛТО в начале распознавания, соответствующий участок будет добавлен к существующей линии.

Таким же образом можно перейти к другому концу линии и продолжить ее собирать с той стороны. После указания очередного продолжения при наличии неоднозначности или отсутствии вариантов, будет продолжен автоматический поиск линии. В случае ошибочного автоматического или ручного продолжения, последние действия по сборке линии можно откатить, нажимая правую клавишу мыши необходимое число раз.

Текущий распознанный участок будет отображаться синим выделением. По мере полуавтоматической сборки линии он будет увеличиваться.

По завершении распознавания необходимо нажать соответствующую кнопку в окне подсказок.

После создания объекта программа готова к распознаванию следующего ЛТО, новая инициализация не требуется. При этом для новой линии можно изменить ее тип и объект классификатора. Выйти из режима распознавания ЛТО можно нажатием клавиши <Esc> или кнопки Выход в окне подсказок.

Редактирование подписей производится стандартными методами интерактивного редактирования графических элементов.

Параметры шрифта одинаковы для всех подписей данного типа, созданных в проекте, и настраиваются в диалоге Параметры программы.

См. также

Векторизация (процесс)


Команда Векторизация (Векторизация)

Векторизация

Команда предназначена для автоматической векторизации всего выбранного растрового фрагмента, результатом векторизации являются объекты Полилиния.

Вызовите команду Векторизация из меню Векторизация (кнопка Векторизация [image] панели инструментов).

Редактирование подписей производится стандартными методами интерактивного редактирования графических элементов.

Параметры шрифта одинаковы для всех подписей данного типа, созданных в проекте, и настраиваются в диалоге Параметры программы.

См. также

Векторизация (процесс)


Команда Распознавание текста (Векторизация)

Распознавание текста

Команда предназначена для распознавания текста в выделенной области растрового фрагмента.

Вызовите команду Распознавание текста из меню Векторизация (кнопка Распознавание текста [image] панели инструментов).

Укажите область с текстом на растре для распознавания. По результатам распознавания текста создается объект Текст.

Редактирование подписей производится стандартными методами интерактивного редактирования графических элементов.

Параметры шрифта одинаковы для всех подписей данного типа, созданных в проекте, и настраиваются в диалоге Параметры программы.

См. также

Векторизация (процесс)


Меню Оформление

Команды меню Оформление

Текст

Отрезок

Полилиния

Эллипс

Окружность

Прямоугольник

Многоугольник

Растеризация

Подпись координат пункта

Подпись высоты пункта

Подпись дирекционного угла

Подпись расстояния

Подпись угла

Узел координатной сетки


Команда Текст (меню Построения)

Текст

Команда вставляет текст в любое место окна План или Чертеж.

Вызовите команду Текст из меню Оформление (Примитивы) (кнопка Текст [image] панели Построения ).

Укажите место в графическом окне, куда необходимо вставить текст. Вставится текст Текст, который можно отредактировать. Изменить текст также можно в окне Свойства, дважды кликнув в области значения параметра текст.

Если необходимо ввести многострочный текст, в режиме редактирования текста в конце каждой строки нажмите клавишу <Enter>.

В окне Свойства отредактируйте параметры текста:

координаты X, Y – введите с клавиатуры координаты центра объекта Текст;

угол поворота текста в градусах – введите с клавиатуры;

шрифт - вызывается стандартный диалог выбора шрифта;

цвет, фон - вызывается стандартный диалог выбора цвета.

Введенный текст можно редактировать интерактивно.

Выберите текст в графическом окне. При этом у объекта Текст отображаются управляющие элементы. Редактирование положения объекта Текст производится стандартными интерактивными методами, позволяющими выполнить масштабирование, перемещение и поворот.

Выход из построения производится клавишей <Esc> или правым кликом мыши.

Удалить выделенный текст можно клавишей <Delete>.


Команда Отрезок (меню Построения)

Отрезок

Команда предназначена для построения отрезка произвольного направления и произвольной длины.

Вызовите команду Отрезок из меню Оформление (Примитивы) (кнопка Отрезок [image] панели инструментов).

Левой клавишей мыши задайте положение начала отрезка.

Задайте положение конца отрезка.

В окне Свойства отредактируйте параметры вставленного объекта:

цвет линии - вызывается стандартный диалог выбора цвета.

толщина линии - введите с клавиатуры или отредактируйте с помощью спинбокса толщину линии.

стиль линии - выберите необходимое значение из выпадающего списка.

Редактирование положения объектов производится стандартными интерактивными методами, позволяющими выполнить масштабирование, перемещение и поворот, а также изменить положение вершин границы объекта.

Выход из построения производится клавишей <Esc> или правым кликом мыши.

Удалить выделенный объект можно клавишей <Delete>.


Команда Полилиния (меню Построения)

Полилиния

Команда строит ломаную линию в окне План или Чертеж.

Вызовите команду Полилиния из меню Оформление (Примитивы) (кнопка Полилиния [image] панели инструментов).

Левой клавишей мыши задайте положение начала ломаной.

Последовательно задавайте положение следующих точек ломаной. Для завершения построения выберите повторно последнюю созданную вершину.

Правым кликом мыши можно отменить построение последней вершины полилинии.

В окне Свойства отредактируйте параметры вставленного объекта:

цвет линии - вызывается стандартный диалог выбора цвета.

толщина линии - введите с клавиатуры или отредактируйте с помощью спинбокса толщину линии.

стиль линии - выберите необходимое значение из выпадающего списка.

Редактирование положения объектов производится стандартными интерактивными методами, позволяющими выполнить масштабирование, перемещение и поворот, а также изменить положение вершин границы объекта.

Выход из построения производится клавишей <Esc>.

Удалить выделенный объект можно клавишей <Delete>.


Команда Эллипс (меню Построения)

Эллипс

Команда строит эллипс в окне План или Чертеж.

Вызовите команду Эллипс из меню Оформление (Примитивы) (кнопка Эллипс [image] панели инструментов).

Левой клавишей мыши задайте положение центра эллипса.

Перемещайте курсор в сторону от центра эллипса, пока эллипс не примет необходимый вид. Повторный клик мыши завершит построение эллипса.

В окне Свойства отредактируйте параметры вставленного объекта:

X центра, Y центра - координаты центра эллипса.

угол поворота - введите с клавиатуры или отредактируйте с помощью спинбокса угол поворота эллипса.

большая полуось, a - введите с клавиатуры или отредактируйте с помощью спинбокса длину большой полуоси эллипса.

малая полуось, b - введите с клавиатуры или отредактируйте с помощью спинбокса длину малой полуоси эллипса.

Единицы измерения вводимых длин задаются в диалоге Свойства проекта.

Отрезки, проведённые из центра эллипса к вершинам на большой и малой осях называются, соответственно, большой полуосью и малой полуосью эллипса, и обозначаются a и b.

сжатие, a/b - соотношение между длинами большой и малой полуосей эллипса.

цвет линии - вызывается стандартный диалог выбора цвета.

толщина линии - введите с клавиатуры или отредактируйте с помощью спинбокса толщину линии.

стиль линии - выберите необходимое значение из выпадающего списка.

стиль заливки - выберите необходимое значение из выпадающего списка.

Редактирование положения объектов производится стандартными интерактивными методами, позволяющими выполнить масштабирование, перемещение и поворот.

Выход из построения производится клавишей <Esc> или правым кликом мыши.

Удалить выделенный объект можно клавишей <Delete>.


Команда Окружность (меню Построения)

Окружность

Команда строит дугу окружности в окне План или Чертеж.

Вызовите команду Окружность из меню Оформление (Примитивы) (кнопка Окружность [image] панели инструментов).

Левой клавишей мыши определите начальную точку дуги окружности.

Затем последовательно укажите три точки дуги окружности.

В окне Свойства уточните значение параметра Режим. В результате построения может быть создана как линия (при значении Дуга) , так и полигон (при значениях Окружность, Сектор и Хорда).

Если Режим = Дуга, Сектор или Хорда, обязательно должны быть заданы значения параметров Угол начала и Угол конца.

При необходимости в окне Свойства отредактируйте параметры вставленного объекта:

Х центра, Y центра - координаты центра окружности, на базе которой создается графический примитив.

радиус - радиус окружности.

цвет линии - вызывается стандартный диалог выбора цвета.

толщина линии - введите с клавиатуры или отредактируйте с помощью спинбокса толщину линии.

стиль линии - выберите необходимое значение из выпадающего списка.

стиль заливки - выберите необходимое значение из выпадающего списка.

Редактирование положения объектов производится стандартными интерактивными методами, позволяющими выполнить масштабирование, перемещение и поворот.

Выход из построения производится клавишей <Esc> или правым кликом мыши.

Удалить выделенный объект можно клавишей <Delete>.


Команда Прямоугольник (меню Построения)

Прямоугольник

Команда предназначена для построения прямоугольника произвольных размеров в окне План или Чертеж.

Вызовите команду Прямоугольник из меню Оформление (Примитивы) (кнопка Прямоугольник [image] панели инструментов).

Левой клавишей мыши задайте положение левой верхней вершины прямоугольника.

Задайте положение правой верхней вершины прямоугольника.

Укажите нижнюю правую вершину прямоугольника.

При необходимости в окне Свойства отредактируйте параметры вставленного объекта:

цвет линии - вызывается стандартный диалог выбора цвета.

толщина линии - введите с клавиатуры или отредактируйте с помощью спинбокса толщину линии.

стиль линии - выберите необходимое значение из выпадающего списка.

стиль заливки - выберите необходимое значение из выпадающего списка.

Редактирование положения объектов производится стандартными интерактивными методами, позволяющими выполнить масштабирование, перемещение и поворот, а также изменить положение вершин границы объекта.

Выход из построения производится клавишей <Esc> или правым кликом мыши.

Удалить выделенный объект можно клавишей <Delete>.


Команда Многоугольник (меню Построения)

Многоугольник

Команда строит многоугольник в окне План или Чертеж.

Вызовите команду Многоугольник из меню Оформление (Примитивы) (кнопка Многоугольник [image] панели инструментов).

Левой клавишей мыши определите начальный узел многоугольника.

Затем последовательно укажите положение остальных вершин многоугольника.

Правым кликом мыши можно отменить построение последней вершины многоугольника.

Захват начального/последнего узла многоугольника ("замыкание") заканчивает его построение.

При необходимости в окне Свойства отредактируйте параметры вставленного объекта:

цвет линии - вызывается стандартный диалог выбора цвета.

толщина линии - введите с клавиатуры или отредактируйте с помощью спинбокса толщину линии.

стиль линии - выберите необходимое значение из выпадающего списка.

стиль заливки - выберите необходимое значение из выпадающего списка.

Редактирование положения объектов производится стандартными интерактивными методами, позволяющими выполнить масштабирование, перемещение и поворот, а также изменить положение вершин границы объекта.

Выход из построения производится клавишей <Esc>.

Удалить выделенный объект можно клавишей <Delete>.


Команда Растеризация (меню Построения)

Растеризация

Команда производит растеризацию векторных примитивов и подписей. Операция растеризации производится только на растры.

Если растровые фрагменты не выбраны, векторные примитивы растеризуются на все фрагменты. Если выбраны какие-то растровые фрагменты, векторные примитивы растеризуются только на эти выбранные фрагменты.

Вызовите команду Растеризация из меню Оформление (кнопка Растеризовать примитивы на растровые фрагменты [image] панели инструментов).


Команда Подпись координат пункта (Оформление)

Подпись координат пункта

Команда создает подпись координат пункта в окне плана.

Вызовите команду Подпись координат пункта из меню Оформление (кнопка Подпись координат пункта [image] панели инструментов).

Выберите в графическом окне пункт, подпись координат которого необходимо создать

При необходимости измените параметры созданной подписи – в окне Свойства введите значения единиц измерения, точности представления, текста до и после значений координат, а также параметры линий выноски.

Редактирование подписей производится стандартными методами интерактивного редактирования графических элементов.

Параметры шрифта одинаковы для всех подписей данного типа, созданных в проекте, и настраиваются в диалоге Параметры программы.


Команда Подпись высоты пункта (Оформление)

Подпись высоты пункта

Команда создает подпись высоты пункта в окне плана.

Вызовите команду Подпись высоты пункта из меню Оформление (кнопка Подпись высоты пункта [image] панели инструментов).

Выберите в графическом окне пункт, подпись высоты которого необходимо создать

При необходимости измените параметры созданной подписи в окне Свойства.

Редактирование подписей производится стандартными методами интерактивного редактирования графических элементов.

Параметры шрифта одинаковы для всех подписей данного типа, созданных в проекте, и настраиваются в диалоге Параметры программы.


Команда Подпись дирекционного угла (Оформление)

Подпись дирекционного угла

Команда создает подпись дирекционного угла в окне плана.

Вызовите команду Подпись дирекционного угла из меню Оформление (кнопка Подпись дирекционного угла [image] панели инструментов).

Последовательно выберите в графическом окне пару пунктов, подпись дирекционного угла между которыми необходимо создать. Порядок выбора пунктов определяет значение угла.

При необходимости измените параметры созданной подписи – в окне Свойства введите значения единиц измерения, точности представления, текста до и после значений координат, а также параметры линий выноски.

Редактирование подписей производится стандартными методами интерактивного редактирования графических элементов.

Параметры шрифта одинаковы для всех подписей данного типа, созданных в проекте, и настраиваются в диалоге Параметры программы.


Команда Подпись расстояния (Оформление)

Подпись расстояния

Команда создает подпись расстояния между двумя пунктами в окне плана.

Вызовите команду Подпись расстояния из меню Оформление (кнопка Подпись расстояния [image] панели инструментов).

Последовательно выберите в графическом окне пару пунктов, между которыми необходимо создать подпись расстояния.

При необходимости измените параметры созданной подписи – в окне Свойства введите значения единиц измерения, точности представления, текста до и после значений координат, а также параметры линий выноски.

Редактирование подписей производится стандартными методами интерактивного редактирования графических элементов.

Параметры шрифта одинаковы для всех подписей данного типа, созданных в проекте, и настраиваются в диалоге Параметры программы.


Команда Подпись угла (Оформление)

Подпись угла

Команда создает подпись угла, созданного тремя точками в окне плана.

Вызовите команду Подпись угла из меню Оформление (кнопка Подпись угла [image] панели инструментов).

Последовательно выберите в графическом окне три пункта, между которыми необходимо создать подпись угла.

При необходимости измените параметры созданной подписи – в окне Свойства введите значения единиц измерения, точности представления, текста до и после значений координат, ориентации, а также параметры линий выноски.

Редактирование подписей производится стандартными методами интерактивного редактирования графических элементов.

Параметры шрифта одинаковы для всех подписей данного типа, созданных в проекте, и настраиваются в диалоге Параметры программы.


Команда Узел координатной сетки (Оформление)

Узел координатной сетки

Команда предназначена для вывода подписи координат в узлах координатной сетки.

Вызовите команду Узел координатной сетки из меню Оформление (кнопка Узел координатной сетки [image] панели инструментов).

Выделите рамкой в графическом окне один или несколько крестов.

При необходимости измените параметры созданных подписей – в окне Свойства введите значения единиц измерения, точности представления, а также текста до и после значения.

Редактирование подписей производится стандартными методами интерактивного редактирования графических элементов.

Параметры шрифта одинаковы для всех подписей данного типа, созданных в проекте, и настраиваются в диалоге Параметры программы.


Меню Чертеж

Команды меню Чертежи

Создать контур чертежа

Создать лист чертежа

Редактор шаблонов

Выпустить чертеж


Команда Создать контур чертежа (меню Чертеж)

Создать контур чертежа

Команда предназначена для создания контура фрагмента чертежа произвольной формы. Команда доступна только в режиме подготовки растровой подложки.

Для создания контура фрагмента чертежа доступны все фрагменты растра, независимо от того, какой из фрагментов является активным.

Участки фрагментов растра вне контуров видимости, а также фрагменты растра с отключенной видимостью на чертежах заливаются белым цветом.

Контуры фрагментов чертежа могут иметь сколь угодно сложную форму. Допускается пересечение контуров.

Чтобы создать контур фрагмента чертежа:

Выберите команду Создать контур чертежа меню Чертежи (кнопка Создать контур чертежа [image] панели инструментов).

Указывая левой клавишей мыши вершины многоугольного контура, создайте контур.

Правым кликом мыши можно отменить последнее действие.

Завершите операцию построения замыканием контура на первоначальную точку.

Отменить создание контура можно с помощью команды Правка/Отменить или кнопки Отменить на панели инструментов.

Выход из построения производится клавишей <Esc>.

Удалить выделенный контур можно клавишей <Delete>.


Команда Создать лист чертежа (меню Чертежи)

Создать лист чертежа

Команда создает фрагмент чертежа в соответствии с данными, заданными в шаблоне чертежа.

Выберите команду Создать лист чертежа меню Чертежи (кнопка Создать лист чертежа [image] панели Чертежи)..

Вызывается диалог Открыть шаблон чертежа.

После задания необходимых настроек нажмите кнопку Открыть. Шаблон чертежа загрузится в окно План.

Необходимо интерактивно указать положение шаблона чертежа (при необходимости его можно развернуть). По этим данным определяется область, которую нужно передать в чертеж.

Отменить создание области чертежа можно с помощью команды Правка/Отменить или кнопки Отменить на панели инструментов.


Команда Создать лист чертежа (меню Чертежи)

Редактор шаблонов

Команда открывает Редактор шаблонов для редактирования шаблонов выходных документов.

Команда вызывается из меню Чертежи в окне План и из меню Файл в окне Чертеж или кнопкой Редактор шаблонов [image] панели инструментов.


Команда Выпустить чертеж (меню Чертежи)

Выпустить чертеж

Команда предназначена для перехода в документ чертежа и передачи в него выбранного фрагмента или листа чертежа.

Вызовите команду Выпустить чертеж из меню Чертежи (кнопка Выпустить чертеж [image] панели Чертежи).

Если область чертежа не создана (или не выбрана), система выдаст предупреждающее сообщение.


Меню Окно

Команды меню Окно

Расположить вертикально

Расположить горизонтально

Открытые проекты


Команда Другие окна (меню Окно)

Расположить вертикально

Команда располагает все открытые окна с проектами и чертежами вертикально.


Команда Расположить горизонтально (меню Окно)

Расположить горизонтально

Команда располагает все открытые окна с проектами и чертежами горизонтально один под другим.


Команда Открытые проекты (меню Окно)

Открытые проекты

Команда выводит список открытых проектов и чертежей.

Для перехода к требуемому проекту или чертежу выберите его имя из списка.


Меню Файл

Команды меню Файл

Создать

Открыть

Закрыть

Сохранить

Сохранить как

Сохранить все

Экспорт

Параметры страницы

Раскладка на страницы

Предварительный просмотр

Печать

Редактор шаблонов

Выход


Меню Файл/Создать

меню Создать

– Чертеж

Команда доступна в окне Чертеж и в окне План.

Команда создает новый чертеж. Каждый чертеж создается в отдельном окне.

Чтобы создать новый чертеж:

Выберите команду Создать/Чертеж в меню Файл (кнопка Создать новый чертеж [image] на панели инструментов или горячие клавиши <Ctrl + N>).

Открывается окно нового чертежа. По умолчанию новому чертежу присваивается имя Новый чертеж 1, последующим вновь созданным чертежам будут присваиваться имена Новый чертеж 2, Новый чертеж 3 и т.д.


Команда Экспорт (меню Файл)

Экспорт

Команда предназначена для экспорта данных чертежа для последующей вставки в электронные отчеты или продолжения редактирования документа чертежа.

Экспорт производится в форматы PDF, DXF, SVG.

Экспорт в формат PDF производится с учетом текущей раскладки чертежа на страницы, в остальных форматах раскладка не учитывается.

Вызовите в меню Файл команду Экспорт (кнопка Экспорт [image] на панели инструментов).

В открывшемся окне Экспорт укажите папку для экспортируемого файла, тип и имя файла.


Команда Параметры страницы (меню Файл)

Параметры страницы

Команда предназначена для настройки параметров страницы чертежа. Команда доступна только в режиме компоновки чертежа.

Порядок работы:

Выберите команду Параметры страницы (кнопка Параметры страницы [image] на панели инструментов). Команда также доступна из контекстного меню, вызываемого правой клавишей мыши.

Выполните настройки в открывшемся диалоге Параметры страницы:

Определите размер бумаги (при необходимости может быть задан произвольный).

Задайте подачу и ориентацию страницы.

Задайте отступы внутренней рамки.

Для выхода из диалога с сохранением изменений нажмите кнопку ОК . Для отказа от установленных настроек нажмите кнопку Отмена.


Команда Раскладка на страницы (меню Файл)

Раскладка на страницы

Команда меняет видимость сетки раскладки чертежа по печатаемым страницам. Размер страницы соответствует выбранному формату в Параметрах страницы и зависит от размера непечатаемых полей.

Порядок работы:

Выберите в меню Файл команду Раскладка на страницы (кнопка Раскладка на страницы [image] на панели инструментов). Границы сетки отобразятся пунктирными линиями, а границы страниц отображаются голубыми линиями.

При необходимости отредактируйте параметры в окне Свойства.

Результат вывода страниц на печать можно увидеть, выбрав команду Предварительный просмотр.


Команда Предварительный просмотр (меню Файл)

Предварительный просмотр

Команда дает представление о виде страницы чертежа при выводе на печать. Команда доступна только в режиме компоновки чертежа.

Для предварительного просмотра чертежа:

Выберите команду Предварительный просмотр меню Файл (кнопка Предварительный просмотр [image] на панели инструментов).

Открывается окно предварительного просмотра чертежа.

Для просмотра многостраничного документа используйте кнопки Следующая, Предыдущая или клавиши <PageUp> и <PageDown>. Для просмотра всех страниц одновременно нажмите на кнопку Показать обзор всех страниц.

Для масштабирования отображения нажмите кнопку Увеличить или Уменьшить. Изменение масштаба изображения не влияет на размер чертежа при печати.

Из окна предварительного просмотра доступна команда Печать меню Файл.

Для выхода из режима предварительного просмотра нажмите кнопку Закрыть [image] .


Команда Печать (меню Файл)

Печать

Команда предназначена для вывода на печать текущего чертежа. Команда доступна только в режиме компоновки чертежа.

Чтобы распечатать текущий чертеж:

Выберите команду Печать в меню Файл (кнопка Печать [image] на панели инструментов).

Открывается диалог Печать.

Выберите принтер.

В группе Диапазон страниц определите, какие страницы чертежа должны быть распечатаны (по умолчанию на печать будут выведены все страницы).

В поле Число копий укажите количество печатаемых копий чертежа.

Нажмите кнопку ОК для вывода чертежа на печать.

Кнопка Отмена закрывает окно диалога без вывода чертежа на печать.


Меню Правка

Команды меню Правка

Отменить

Вернуть

Вырезать

Копировать

Вставить

Вставить объект

Удалить

Обновить фрагменты


Меню Вставить объект (меню Правка)

Меню Вставить объект

Проект

Рисунок

Документ *.html

Шаблон штампа

Шаблон чертежа


Команда Обновить фрагменты (меню Сервис)

Обновить фрагменты

Команда предназначена для обновления содержимого фрагмента чертежа с учетом текущего состояния исходного проекта (т.е. проекта, по которому создан фрагмент чертежа). Для этого необходимо, чтобы была открыта текущая версия проекта tmd.

Это необходимо, если при создании документа чертежа параметры отображения некоторых элементов не соответствовали требуемым. В этом случае нужно открыть исходный проект, выполнить необходимые настройки, после чего обновить фрагмент чертежа.

Выберите команду Обновить фрагменты меню Правка (кнопка Обновить фрагменты [image] на панели инструментов).

Ваши комментарии к справочной системе

© Компания "Кредо-Диалог" Компания "Кредо-Диалог"


Меню Вид

Команды меню Вид

Меню Вид содержит команды управления отображением окон и вкладок в группах вкладок. Выбор команды включает видимость соответствующего окна - значок для соответствующего окна находится в "нажатом" состоянии. Повторный выбор команды отключает видимость окна.

Чертеж | включает/отключает видимость окна Чертеж
Свойства | включает/отключает видимость окна Свойства
История | включает/отключает видимость окна История


Меню Примитивы

Команды меню примитивы

Текст

Отрезок

Полилиния

Эллипс

Прямоугольник

Многоугольник

Окружность


Меню Объект

Команды меню Объект

Меню Объект содержит следующие команды:

Сгруппировать

Разгруппировать

Поднять

Опустить

Поднять на передний план

Опустить на задний план

Блокировать

Разблокировать


Команда Сгруппировать (меню Объект)

Сгруппировать

Команда группирует два и более выделенных объекта. Данная операция позволяет перемещать, вращать, копировать и т.д. группу объектов как единое целое.

Выделите объекты, которые необходимо сгруппировать.

Выберите в меню Объект команду Сгруппировать (кнопка Сгруппировать [image] на панели инструментов).


Команда Сгруппировать (меню Объект)

Разгруппировать

Команда разгруппировывает созданную ранее группу объектов.

Выделите сгруппированный объект.

Выберите в меню Объект команду Разгруппировать (кнопка Разгруппировать [image] на панели инструментов).

См.также:

Команда Сгруппировать


Команда Поднять (меню Объект)

Поднять

Команда меняет вертикальный порядок отображения объектов в окне чертежа. Выделенный объект отрисовывается на один уровень выше.

Команда актуальна, если в чертеже присутствуют перекрывающиеся объекты.

Выделите объект, который необходимо отобразить на уровень выше.

Выберите в меню Объект команду Поднять (кнопка Поднять [image] на панели инструментов)..


Команда Опустить (меню Объект)

Опустить

Команда меняет вертикальный порядок отображения объектов в окне чертежа. Выделенный объект отрисовывается на один уровень ниже.

Команда актуальна, если в чертеже присутствуют перекрывающиеся объекты.

Выделите объект, который необходимо отобразить на уровень ниже.

Выберите в меню Объект команду Опустить (кнопка Опустить [image] на панели инструментов).


Команда Поднять на передний план (меню Объект)

Поднять на передний план

Команда меняет вертикальный порядок отображения объектов в окне чертежа. Выделенный объект отрисовывается на переднем плане.

Команда актуальна, если в чертеже присутствуют перекрывающиеся объекты.

Выделите объект, который необходимо отобразить выше всех остальных объектов.

Выберите в меню Объект команду Поднять на передний план (кнопка Поднять на передний план [image] на панели инструментов)..


Команда Опустить на задний план (меню Объект)

Опустить на задний план

Команда меняет вертикальный порядок отображения объектов в окне чертежа. Выделенный объект отрисовывается на один уровень ниже.

Команда актуальна, если в чертеже присутствуют перекрывающиеся объекты.

Выделите объект, который необходимо отобразить ниже всех остальных объектов.

Выберите в меню Объект команду Опустить на задний план (кнопка Опустить на задний план [image] на панели инструментов)..


Команда Блокировать (меню Объект)

Блокировать

Команда блокирует выделенный объект или сгруппированные объекты. Блокирование объекта предназначено для защиты объекта от случайного интерактивного смещения или вращения. В окне Свойства можно отредактировать параметры заблокированного объекта: координаты центра, угол поворота и т.д.

Выделите объект, который необходимо заблокировать.

Выберите в меню Объект команду Блокировать (кнопка Блокировать [image] на панели инструментов)..


Команда Разблокировать (меню Объект)

Разблокировать

Команда разблокирует объект, заблокированный командой Объект/Блокировать.

Выделите объект, который необходимо разблокировать.

Выберите в меню Объект команду Разблокировать (кнопка Разблокировать [image] на панели инструментов)..


Строка состояния

Строка состояния представляет собой горизонтальную область, расположенную ниже окна проекта, дает информацию о текущем состоянии программы:

координаты указателя мыши (если нет фрагментов, то этот элемент не отображается);

текущую конфигурацию рабочего окна;

количество выделенных элементов;

СК проекта.


Локальные панели инструментов

Локальные панели инструментов различных окон содержат кнопки с операциями, характерными только для данного окна.

Панель инструментов окна План:

– Линейки – включает и отключает в графическом окне режим отображения разметки координат по вертикали и горизонтали в соответствии с заданными единицами измерения.

– Масштаб отображения – масштаб отображения выбирается из выпадающего списка или вводится вручную.

– Показать все – масштаб автоматически изменяется таким образом, чтобы отобразились все видимые элементы.

– Масштабировать рамкой – увеличивает выделенный рамкой фрагмент изображения.

– Уменьшить – уменьшает масштаб отображения.

– Увеличить – увеличивает масштаб отображения.

– Переместить – сдвиг изображения на интерактивно заданные смещения. Необходимо вызвать метод и при нажатой левой клавише мыши сместить изображение.

– Позиционировать по курсору – по левому щелчку совмещается центр окна с точкой под курсором.

– Задать координаты центра – вызывается диалог ввода координат. В окне отображается участок, центром которого являются введенные координаты.

– К предыдущему виду – отображается предыдущее изображение.

– К следующему виду – отображается следующее изображение.

– Фильтр видимости – вызывается диалог Фильтр видимости элементов, который позволяет изменить текущий фильтр отображения.

– Фильтр выбора – вызывается диалог Фильтр выбора элементов.

– Выбрать рамкой – выбор группы элементов в окне План рамкой.

– Выбрать контуром – выбор группы элементов в окне План произвольным контуром. (См. Выбор данных)

Панели инструментов окон с таблицами:

– Копировать – копирует выделенные данные в буфер обмена, вызывается клавишами: <Ctrl + C>.

– Вырезать – вырезает выделенные данные, вызывается клавишами: <Ctrl + X>.

– Вставить – вставляет данные из буфера обмена, вызывается клавишами: <Ctrl + V> - работа с выбранными строками через буфер обмена. В таблицу могут быть вставлены только строки такой же таблицы (возможно, из другого проекта). Если нет выделенных строк, то операция выполняется для текущей ячейки на уровне текста: копирует или вырезает текст в буфер, команда Вставить вставляет текст из буфера.

– Удалить – удаляет выбранные строки, очищает текущую ячейку или выбранную группу ячеек, вызывается клавишами: <Del>.

– Найти – открывает диалог Найти в таблице (См. Поиск в таблицах).

– Показать на плане – выделяет в окне План точки, выбранные в таблице Точки привязки. Изображение масштабируется таким образом, чтобы отображение выбранных точек было максимально увеличено.

– Ведомости – формирует отчет по данной таблице в формате html.

– Настройки – вызывает диалог Настройка представления таблиц.


Получение справочной информации (меню Справка)

Меню Справка вызывается кнопкой [image], расположенной в правой верхней части окна приложения, и включает следующие команды:

Вызов справки (F1). Команда вызывает окно справочной системы. См. подробно - использование справочной системы.
Возможен также "быстрый" вызов справки - выполняется нажатием кнопки <F1> во время работы (т.е. без открытия меню Справка).

О программе. Команда вызывает диалог, в котором представлена информация о номере версии программы, об авторских и лицензионных правах, другая справочная информация.


Техническая поддержка

Служба техподдержки компании осуществляет техническую и технологическую поддержку пользователей программных продуктов.

Гарантийная техподдержка входит в состав подписки Гарантийная и осуществляется в течение 3-х месяцев со дня приобретения программного продукта. Этот вид техподдержки включает в себя оказание помощи в установке, настройке и запуске программ, консультации по системно-техническим вопросам, миграции данных, импорту разделяемых ресурсов, настройке соединений.

Базовая техподдержка входит в состав подписки Базовая и осуществляется в течение срока действия приобретенной подписки. Этот вид техподдержки осуществляется для текущей и предыдущей версий программного продукта, включает в себя оказание помощи в установке, настройке и запуске программ, помощь в освоении функциональности программного продукта, консультации по системно-техническим вопросам, миграции данных, импорту разделяемых ресурсов, настройке соединений.

Расширенная техподдержка входит в состав подписки Базовая + и осуществляется в течение срока действия приобретенной подписки. Этот вид техподдержки осуществляется для текущей и предыдущей версий программного продукта, включает в себя оказание помощи в установке, настройке и запуске программ, помощь в освоении функциональности программного продукта, консультации по системно-техническим вопросам, миграции данных, импорту разделяемых ресурсов, настройке соединений. Оказание помощи в решении вопросов профессионального характера, технологических задач и технологий работ, помощь в поиске и исправлении ошибок на объектах (проектах) пользователя.

Пользователи программных продуктов, не имеющие подписки или программных продуктов, для которых подписка не предусмотрена, могут обратиться за помощью в разделе ФОРУМ https://www.credo-dialogue.ru/forum/recent.html нашего сайта.

Техническая поддержка осуществляется в следующих формах:

По телефону "горячей линии". Консультации осуществляются специалистами компании в рабочие дни с 9-00 до 17-30 (время московское) по телефонам компании – правообладателя.

Cпециалистами региональных офисов и партнерскими компаниями в рабочие дни с 9-00 до 17-30 (время местное), контакты https://www.credo-dialogue.ru/kontakty.html.

По электронной почте. Вопросы можно присылать по адресу электронной почты support@credo-dialogue.com. Обращение по электронной почте позволяет службе поддержки оказать более подробные консультации, подготовить развернутые ответы на вопросы, провести анализ объектов и выработать рекомендации по устранению ошибок.

Непосредственно на странице https://www.credo-dialogue.ru/podderzhka.html нашего сайта.

Прежде чем обращаться в службу технической поддержки:

Прочтите приложение к договору (документацию) и выясните, удовлетворяет ли конфигурация вашего компьютера минимальным системным требованиям для работы программного продукта.

Выполните проверку компьютера на вирусы и попробуйте воспроизвести ошибку после лечения вирусов (если они были найдены). Если ошибка повторится, уточните название используемой антивирусной программы и ее версию для передачи этой информации в службу поддержки.

Подготовьте следующую информацию о себе и своей организации и обязательно включите ее в письмо при обращении в службу технической поддержки по электронной почте:

номер ключа электронной защиты программного продукта, по которому возникли вопросы;

город и название Вашей организации;

Ваши фамилию, имя и отчество, должность и телефон, по которому с Вами можно связаться для оперативного уточнения и решения вопросов.

Выясните название и полный номер версии программного продукта, вопрос по которому Вы хотите задать. Эту информацию можно уточнить в меню программы Помощь/О программе или в сведениях о технической поддержке по данному продукту диалогового окна Установка и удаление программ Панели управления Windows.

Уточните, у кого именно Вы приобретали программные продукты. Если программные продукты были приобретены через Поставщика, пожалуйста, обращайтесь непосредственно к нему. В большинстве случаев поставщики имеют собственную службу поддержки, специалисты которой обучаются в компании "Кредо-Диалог" и имеют соответствующие сертификаты. При необходимости, поставщик сам обратится к нам за консультацией.

Подготовьте детальный сценарий работы, приводящий к проблеме, которая является причиной обращения.

Сделайте снимки экранов, на которых проявляется проблема, имеются сообщения об ошибках. Если снимок экрана сделать невозможно, дословно запишите тексты сообщений об ошибках и коды ошибок.

При обращении по вопросам, касающимся установки, запуска, защиты программных продуктов подготовьте следующую информацию:

по конфигурации компьютера: модель процессора, материнской платы, видеоадаптера, какая операционная система установлена, какой пакет исправлений (Service Pack);

перечень ключей защиты, установленных на данном компьютере, и названия программных продуктов, для работы которых эти ключи предназначены. В этот перечень должны быть включены как ключи для продуктов компании "Кредо-Диалог", так и ключи для продуктов других производителей программного обеспечения.

При обращении по вопросам, касающимся функционирования сетевой защиты, подготовьте следующую информацию:

по топологии сети: сегментирована сеть, есть ли в ней маршрутизаторы; в случае положительного ответа на этот вопрос подготовьте информацию о взаимном расположении компьютеров, на которых запущены Менеджеры защиты Эшелон II или Сетевые агенты Echelon, и на которых запускаются защищенные приложения;

является ли сеть одноранговой или доменной, есть ли в сети сервера Windows и Novell;

какие сетевые протоколы установлены; при наличии протокола TCP/IP уточните способ назначения IP-адресов и наличие службы WINS.

При обращении по программным продуктам, работающим с базами данных, уточните тип, редакцию и номер версии используемой СУБД (Microsoft SQL Server, Oracle, MySQL и т.д.).

При обращении по электронной почте или по факсу включите в письмо подготовленный сценарий работы, приводящий к проблеме, снимки экранов, тексты сообщений, коды ошибок и поясните, чем полученный результат отличается от желаемого.

При обращении по телефону "горячей линии" желательно находиться за компьютером, на котором возникли проблемы.

Обращения в службу технической поддержки регистрируются, поэтому в случае необходимости при повторных обращениях Вы можете сослаться на дату предыдущего обращения, в том числе телефонного разговора, письма, факса или сообщения электронной почты.

Благодаря многолетнему опыту и большому объему накопленной информации специалисты службы технической поддержки помогут решить возникающие проблемы в кратчайшие сроки.

Ваши комментарии к справочной системе

Компания "Кредо-Диалог"


интерактивные методы редактирования графических элементов

Графический элемент окна Схема, фрагмент чертежа, объект, вставленный в чертеж, графический примитив можно интерактивно переместить, повернуть и изменить его размеры. Выберите элемент (фрагмент, объект) в графическом окне. При этом у выбранного объекта отобразятся управляющие элементы.

При перемещении курсор имеет вид [image]. Захватите объект левой клавишей мыши и переместите его в нужное место.

Для изменения размеров (для элементов в проекте чертежа) подведите курсор к любому углу объекта. Курсор примет вид [image]. Захватите угол левой клавишей мыши и потяните угол в сторону увеличения либо в сторону уменьшения до нужных размеров.

Для поворота объекта подведите курсор к значку [image], расположенному на середине верхней границы объекта. Курсор примет вид круговой стрелки [image]. Захватите значок левой клавишей мыши и поверните объект на нужный угол.


Команда Матрицы высот (меню Файл/Импорт)

Импорт в проект

Команда предназначена для импорта в проект заданной области картматериала.

Картматериал загружается на область, отображаемую на данный момент в окне План.

Загрузка снимка из интернета происходит отдельными фрагментами, которые в данный момент отображаются в графическом окне приложения (часть картматериала). Заданную область картматериала (только для Google Maps) можно сохранить (импортировать) в проект и затем преобразовать в чертежную модель.

Вызовите команду Импорт в проект меню Файл/Веб-карты (кнопка Импорт в проект [image] на панели инструментов).

Откроется диалог Сохранение области в проект, в котором задается уровень детализации загружаемых тайлов.

"Тайл" - от англ. tile - фрагмент, кусочек, плитка.

В диалоге также отображается информация о разрешении загружаемого растра, количестве загружаемых тайлов, размере загружаемого растра и размере несжатого растра, получаемого в процессе сохранения. Эта информация обновляется при изменении уровня детализации.

После нажатия кнопки ОК происходит загрузка тайлов, сшивка их в единый растр и загрузка этого растра в проект как растрового фрагмента.

Сохранение растра выполняется во временную папку программы, заданную в диалоге Параметры (Файл/Параметры программы).

См. также

Спутниковые снимки и веб-карты


Команда Выбрать источник (меню Файл/Веб-карты)

Выбрать источник

Команда предназначена для выбора источника картматериала, отображаемого в окне План.

Вызовите команду Выбрать источник меню Файл/Веб-карты (кнопка Выбрать источник [image] на панели инструментов).

Откроется диалог Выбор источника веб-карт, в котором следует сразу определиться с типом данных, которые предоставляются сервисами Google Maps и Экспресс.Космоснимки, а затем выбрать конкретный снимок.

При выборе данных сервиса Экспресс.Космоснимки становится доступной кнопка Выбор снимка [image], которая открывает диалог Выбор снимка со списком снимков согласно введенным ключам.

В диалоге Выбор снимка выполняется ввод полученного при регистрации API-ключа прямого доступа к сервису Экспресс.Космоснимки через кнопку Добавить ключ….

После ввода ключа становится доступным список космических снимков, которые можно загрузить в проект.

Введенный ключ сохраняется в реестре, т.е. на компьютере пользователя. Таким образом, снимок, добавленный в проект, будет подгружаться в графическое окно при открытии проекта без каких-либо дополнительных действий. Для работы со снимками на другом компьютере необходимо ввести ключ до или после открытия проекта.

Из списка следует выбрать нужный снимок и нажать кнопку ОК.

После выбора снимок отображается в окне предварительного просмотра в диалоге Выбор источника веб-карт.

В диалоге Выбор снимка можно также удалить ранее введенный ключ, получить дополнительную информацию об ИТЦ "СКАНЭКС", выполнить регистрацию на сайте http://my.kosmosnimki.ru/.

Для данных сервиса Google Maps предусмотрен поиск и позиционирование снимка по заданным координатам (в системе координат WGS 84). После ввода необходимых координат для позиционирования снимка надо нажать кнопку Найти [image].

После выбора источника картматериала или снимка в окне Выбор источника веб-карт нажмите кнопку ОК. Картматериал будет загружаться из выбранного источника и отображаться в окне План.

Отключить загрузку и отображение картматериалов можно при помощи фильтра видимости.

См. также

Спутниковые снимки и веб-карты


Команда Геодезическая библиотека (меню Файл)

Геодезическая библиотека

Команда открывает диалог Библиотека геодезических данных, позволяющий ввести необходимые параметры для используемых в проекте систем координат, эллипсоидов и т.д.

Команда вызывается из меню Файл или кнопкой Геодезическая библиотека [image] на панели инструментов.

Диалог содержит следующие разделы:

Эллипсоиды

Датумы

Системы координат

Геоиды

Эллипсоиды

В разделе Эллипсоиды производится редактирование библиотеки параметров эллипсоидов, используемых при описании систем координат в поперечно-цилиндрической проекции.

Редактирование или дополнение сводится к редактированию имени эллипсоида и значений большой и малой полуосей. Остальные параметры рассчитываются программой и отображаются в соответствующих полях.

Для внесения в библиотеку нового эллипсоида используется кнопка Создать. В список эллипсоидов добавляется новый эллипсоид. Введите имя нового эллипсоида и отредактируйте его параметры.

Кнопкой Удалить выбранный эллипсоид удаляется.

В начало

Датумы

В разделе Датумы отображается список датумов – ориентированных в пространстве земных эллипсоидов. Для задания датума необходимо выбрать из выпадающего списка нужный эллипсоид и указать параметры перехода от СК WGS-84 к геоцентрической СК, связанной с данным эллипсоидом. Параметры перехода задаются значениями Dx, Dy, Dz (смещение начал спутниковой и референцной систем координат), Wx, Wy, Wz (разворот координатных осей) и m (масштабный коэффициент).

В начало

Системы координат

В разделе Системы координат можно создать новые и отредактировать существующие системы координат (СК). В ВЕКТОРИЗАТОР используется СК различных проекций (Transverse Mercator, Mercator, Pseudo-Mercator, Lambert, LongLat, Local TM).

Для перечисленных СК обязательно нужно выбрать эллипсоид (по умолчанию это эллипсоид Крассовского). Масштаб по осевому меридиану (ОМ) необходимо будет изменить, если проекция врезана или наоборот приподнята над эллипсоидом.

Для СК, осевые меридианы зон которых кратны 3 или 6 градусам, нужно выбрать ширину зоны, указать ее номер или ввести долготу ОМ, заполнить значение ординаты ОМ – смещение на восток (Eо).

Для СК, у которых долготы осевых меридианов являются нестандартными, например СК-63, указывается долгота ОМ, значение смещения на восток (Eо), ширина зоны указывается Нестандартная и, при необходимости, указывается номер зоны. Для таких СК чаще всего приходится указывать еще и смещение по оси X – смещение на север (Nо).

В начало

Геоиды

В разделе Геоиды можно добавить существующую модель для дальнейшего использования ее в проектах ВЕКТОРИЗАТОРа. При необходимости использования модели геоида она может быть скопирована с установочного диска. При наличии установленных программных продуктов КРЕДО ДАТ или ТРАНСКОР можно добавить модель геоида из папок этих программ.

В информационных полях диалога отображаются значения области покрытия выбранной в списке модели геоида.

Геодезическая библиотека создается один раз при первой инсталляции приложения. Данные библиотеки могут быть импортированы и экспортированы (кнопки Импорт и Экспорт в нижней части диалога). В качестве обменного формата используется XML. При экспорте и импорте можно указать разделы библиотеки, относительно которых производится обмен.

В начало

См. также:

Библиотека геодезических данных


Команда Растры (меню Файл/Импорт)

Растры

Команда предназначена для импорта растровых изображений. Импорт растра возможен в новый или существующий проект.

Чтобы импортировать растровое изображение:

Вызовите команду Импорт/Растры в меню Файл (кнопка Растры [image] на панели инструментов). Команда также доступна из контекстного меню, вызываемого правой клавишей мыши, когда курсор находится вне растра. Откроется диалог Импорт.

Выберите один файл или группу файлов. Группа формируется последовательным указанием файлов с одновременным нажатием клавиш <Ctrl> или <Shift>.

Для импорта нажмите кнопку Открыть или клавишу <Enter>. Для первого импортируемого файла программа проверяет наличие встроенной информации о привязке (для CRF, ECW, RSW, TIFF) или отдельного файла привязки (для BMP, JPG, PNG, TIFF и др.).

В файлах GeoTIFF могут быть записаны сведения о системе координат.

При импорте файлов такого типа в новый проект, в котором не установлена система координат, программа считывает сведения о ней и устанавливает систему координат импортируемого файла. Если в проекте выбрана система координат (за исключением Локальной), то импортируемый растр, в котором записаны данные о системе координат, трансформируется в систему координат проекта. Если установлена Локальная система координат, то файл импортируется в соответствии с записанными в нем координатами привязки, система координат при этом не меняется.

Система координат, прочитанная из привязки, может отсутствовать в геодезической библиотеке. Ее можно туда добавить, вызвав контекстное меню кликом правой кнопки мыши, в разделе Система координат диалога Свойства проекта.

Нажатие кнопки Отмена прерывает процесс импорта.

После импорта последнего выбранного файла появляется диалоговое окно с сообщением о завершении импорта. Кнопка Отчет открывает область диалога с информацией о результате импорта выбранных файлов.

При импорте файла без привязки северо-западному углу растра в окне План присваиваются текущие координаты центра окна План.

См. также

Импорт


Команда Дополнительные точки по шаблону (меню Файл/Импорт)

Дополнительные точки по шаблону

Команда предназначена для импорта дополнительных точек из текстовых файлов по шаблону. Работа выполняется в утилите Импорт точек по шаблону.

Выберите команду Импорт/Дополнительные точки по шаблону в меню Файл (кнопка Дополнительные точки по шаблону [image] на панели инструментов). Команда также доступна из контекстного меню, вызываемого правой клавишей мыши, когда курсор находится вне растра. Откроется утилита Импорт точек по шаблону.

Выполните импорт.

Загрузите импортируемый файл (Файл/ Открыть). В левой части утилиты построчно будут отображаться данные выбранного файла. При этом отображается только часть файла. В правой части будет отображаться текущий разбор импортируемых данных в соответствии с настройками шаблона.

При необходимости настройте шаблон импорта (Шаблон /Свойства) - описание см. раздел ниже.

Если результат разбора вас устраивает, воспользуйтесь командой Файл/Импорт для передачи данных в программу.

Независимо от того, сколько строк отображалось на этапе настройки импорта, обрабатывается и импортируется всё содержимое выбранного файла.

Настройка и использование шаблона

Настройка параметров шаблона осуществляется в утилите Импорт точек по шаблону в окне Свойства, которое вызывается командой Шаблон/Свойства.

В группе Разделители необходимо задать использующиеся в файле разделители между значениями полей. Если разделителями являются символы, то они вводятся в текстовую строку, если же поля отделены пробелами или табуляцией, устанавливаются флажки параметров Пробел или Табуляция.

См. также

Импорт


Команда Точки привязки по шаблону (меню Файл/Импорт)

Точки привязки по шаблону

Выполняется только при наличии лицензии ТРАНСФОРМ.

Команда предназначена для импорта точек привязки из текстовых файлов по шаблону. Работа выполняется в утилите Импорт точек по шаблону.

Чтобы импортировать точки привязки:

Выберите команду Импорт/Точки привязки по шаблону в меню Файл (кнопка Точки привязки по шаблону [image] на панели инструментов). Команда также доступна из контекстного меню, вызываемого правой клавишей мыши, когда курсор находится вне растра. Откроется утилита Импорт точек по шаблону.

Выполните импорт.

Загрузите импортируемый файл (Файл/ Открыть). В левой части утилиты построчно будут отображаться данные выбранного файла. При этом отображается только часть файла. В правой части будет отображаться текущий разбор импортируемых данных в соответствии с настройками шаблона.

При необходимости настройте шаблон импорта (Шаблон /Свойства) - описание см. раздел ниже.

Если результат разбора вас устраивает, воспользуйтесь командой Файл/Импорт для передачи данных в программу.

Независимо от того, сколько строк отображалось на этапе настройки импорта, обрабатывается и импортируется всё содержимое выбранного файла.

Настройка и использование шаблона

Настройка параметров шаблона осуществляется в утилите Импорт точек по шаблону в окне Свойства, которое вызывается командой Шаблон/Свойства.

В группе Разделители необходимо задать использующиеся в файле разделители между значениями полей. Если разделителями являются символы, то они вводятся в текстовую строку, если же поля отделены пробелами или табуляцией, устанавливаются флажки параметров Пробел или Табуляция.

См. также

Импорт


Интерактивное редактирование графических элементов

Графический элемент окна плана, фрагмент чертежа, объект, вставленный в чертеж, графический примитив можно интерактивно переместить, повернуть и изменить его размеры.

Выберите элемент (фрагмент, объект) в графическом окне. При этом у выбранного объекта отобразятся управляющие элементы.

При перемещении курсор имеет вид [image]. Захватите объект левой клавишей мыши и переместите его в нужное место.

Для изменения размеров (для элементов в проекте чертежа) подведите курсор к любому углу объекта. Курсор примет вид [image]. Захватите угол левой клавишей мыши и потяните угол в сторону увеличения либо в сторону уменьшения до нужных размеров.

Для поворота объекта подведите курсор к значку [image], расположенному на середине верхней границы объекта. Курсор примет вид круговой стрелки [image]. Захватите значок левой клавишей мыши и поверните объект на нужный угол.

См. также

Работа с тематическими объектами


Общая информация (Классификатор)

Классификатор – это иерархическая структура данных, содержащая информацию о типах топографических объектов. В зависимости от видов выполняемых работ пользователь может настроить и использовать несколько различных классификаторов, которые содержат только необходимые для данного вида работ условные знаки и системы кодирования.

Для проекта ВЕКТОРИЗАТОРа, содержащего топографические объекты, необходимо задать классификатор, иначе работа с объектами этого проекта будет недоступна. Каждому проекту может одновременно соответствовать только один классификатор. Один и тот же классификатор может использоваться в нескольких проектах.

Классификаторы хранятся в виде файлов с расширением CLS4.

В поставку системы входит классификатор Classifikator_2010.cls4, хранящийся в папке установки программы.

Создание, открытие и сохранение файла классификатора выполняется аналогично созданию, открытию и сохранению файла проекта. Открыть классификатор, который используется в проекте, можно при помощи команды Файл/Классификатор. Организация рабочего окна классификатора и управление его элементами аналогично описанному для интерфейса.

Иерархическая структура классификатора реализована в виде дерева слоев. Каждый слой может включать произвольное количество других слоев. Каждый слой может содержать список закрепленных за ним тематических объектов.

Списки тематических объектов (ТО) представлены в таблице окна Тематические объекты. Каждый список ТО принадлежит тематическому слою определенной тематики.

В общем случае ТО описывается при помощи базового кода (также дополнительно кода в любой системе кодирования), имени, графического представления на плане (условный знак - УЗ) и семантического описания.

См. также

Работа с классификатором

Создание, открытие и сохранение классификатора


Технология создания/редактирования ТО классификатора

Классификатор будет недоступен для редактирования, если он используется в каком-либо открытом проекте. Для работы в классификаторе необходимо закрыть все проекты, в которых он используется, либо открыть другой классификатор в проекте (команда Файл/Свойства проекта раздел Классификатор).

Последовательность создания и редактирования всех тематических объектов классификатора одинаковая:

1. В окне Тематические объекты в выбранном слое создается новый ТО: вводится его имя, базовый код и т.д.

Создать слой можно не только в окне Слои (кнопка на инструментальной панели Вставить строку), но и в окне Тематические объекты (кнопка Вставить слой). При этом в окне Слои создается слой только в том случае, если в корневом слое присутствуют другие слои (на уровне ниже корневого слоя).

2. В окне Параметры УЗ из выпадающего списка устанавливается тип локализации условного знака: Точечный, Линейный или Площадной.

3. Далее задаются необходимые элементы и параметры условного знака. Перечень параметров зависит от типа УЗ и от элементов, из которых состоит УЗ.

4. Задаются семантические характеристики (атрибуты) всем созданным (существующим) ТО, если это необходимо.

См. также

Работа с классификатором

Работа в окне Слои


Создание ТО (Классификатор)

1. Для создания ТО в окне Слои необходимо выбрать слой, в котором будет создаваться объект. В окне Тематические объекты следует добавить новую строку с помощью команды Вставить строку.

2. Далее следует ввести базовый код и имя создаваемого объекта.

3. Устанавливается признак отношения объекта к цифровой модели рельефа. Для точечного объекта этот признак определяет участие точки в моделировании рельефа, для линейных объектов – формирование структурной линии рельефа, для площадных – формирование контура рельефа. Этот признак является умолчанием и используется в процессе импорта, если в кодовой строке отсутствует поле, задающее отношение объекта к рельефу.

4. Если необходимо использовать пользовательские СК, их можно создать при помощи команды Файл/Системы кодирования. Затем в столбце с именем пользовательской СК следует ввести коды объектов, которые будут использоваться в поле взамен базовых.

Диалог Системы кодирования содержит список существующих систем кодирования и кнопки, позволяющие создать новую систему, удалить или переименовать существующую, а также создать копию системы кодирования на основе существующей (для каждого ТО созданная копия содержит такой же код, какой ТО имеет в исходной системе кодирования).

См. также

Работа с классификатором

Работа в окне Тематические объекты (Классификатор)


Параметры условного знака (Классификатор)

Составной частью условного знака (УЗ) могут являться символы. В частности, на основе символа создается точечный УЗ, символы могут отображаться вдоль траектории линейных УЗ и использоваться для заполнения площадных УЗ.

В качестве символов используются файлы в формате SVG. Данный формат содержит законченное векторное изображение с фиксированным размером, цветами линий и заливки.

Создание и редактирование символов осуществляется внешними редакторами (например, CorelDraw).

При наличии установленного программного продукта ВЕКТОРИЗАТОР можно использовать символы из папки этой программы.

Редактирование параметров существующего или вновь созданного ТО производится в окне Параметры УЗ, где выбирается тип объекта и выполняется его графическое описание (задается условный знак ТО).

Все параметры УЗ можно сохранить в формате MSX, который предназначен для обмена УЗ между классификаторами (команда Сохранить как на локальной панели инструментов окна Параметры УЗ).

Параметры точечного ТО

В окне Параметры УЗ необходимо задать символ создаваемого объекта и установить его размер (Высоту и Ширину). Для того чтобы выбрать символ, необходимо в строке Символ svg двойным щелчком мыши открыть диалог Открыть символ в формате svg.

Выбранный символ появится в окне Предпросмотр УЗ, при этом середина символа будет служить точкой привязки. Точка привязки – это пересечение осей (0;0).

Так как у каждого УЗ своя точка привязки, то его необходимо интерактивно переместить в окне Предпросмотр УЗ относительно точки привязки по оси Х и Y. После перемещения в окне Параметры УЗ следует уточнить значения точки привязки условного знака (параметры Х и Y).

Параметры линейного ТО

Линейный УЗ представляет собой композицию элементов, расположенных вдоль траектории линейного объекта. Элементы могут быть трех типов: сегменты линий, текст (однострочный) и символы SVG. Тип элемента выбирается из выпадающего списка в строке, добавленной при помощи команды Вставить строку на локальной панели инструментов окна Параметры УЗ.

Пример настроек объекта Заборы деревянные с капитальными опорами для масштаба 1:2000-1:5000 (слой Ограждения/Границы и Ограждения) - см. здесь.

УЗ должен состоять из основной линии, которая показывает ось забора, «черточек», которые изображаются перпендикулярными линиями к основной линии и указывают на то, что забор деревянный, и капитальных опор. Следовательно, для УЗ и выбраны соответствующие три элемента: линия, линия (независимая прямая) и символ.

Символ и «независимая линия» должны изображаться через 4 мм вдоль траектории, поэтому в строке Период установлено – 4 мм.

Линии должны быть одного цвета и толщины, поэтому данные параметры и установлены одинаковые.

Для оси (основной) линии задана Длина – 3 мм, так как в общую длину повторения учтены длина линии и размер символа, равный 1 мм. В результате и получается 4 мм.

Для линии, которая перпендикулярна траектории УЗ, установлены следующие параметры: Расположение – Независимая линия, Угол – 90, Длина – 0,5 мм, Смещение по Х – 1,5 мм (так как должна изображаться по середине «основной линии»).

Если параметр Расположение = Независимая прямая, то параметр Угол ненулевой. Если Расположение = Изгибать с линией, то Угол недоступен для редактирования.

Линии и символ должны изображаться на протяжении всей траектории УЗ, поэтому в строке Периодичность установлено значение – Период.

Для элемента Символа параметры настраиваются аналогично, как и для ТТО. При этом можно еще изменить и угол символа.

Для элемента Текст устанавливается шрифт отображения текста в стандартном окне Выбор шрифта, его высоту и значение, все остальные параметры – как и для элемента Линии.

Параметры площадного ТО

Площадной тематический объект (ПТО) представляет собой замкнутую область, ограниченную составной кривой. Графическое описание площадного объекта включает различные элементы заполнения площадного ТО: символ, фон (заливка), штриховка.

Пример параметров площадного ТО Редколесье с зарослями кустарников (слой Примеры сочетания изображений растит. грунтов и с-х угодий) - см. здесь .

Данный УЗ не имеет заливки, поэтому в строке Фон выбрано соответствующее значение.

ПТО состоит из символов: заросли кустарников и редколесье. Следовательно, данные символы открыты в строке Символ svg (двойным щелчком левой клавиши мыши).

Так как данный УЗ изображается не в шахматном порядке, а рассеянно, следовательно, значение Да в соответствующих строках не установлено.

Для рассеянности символов использованы параметры: Рассеяние положения от узла сетки, Шаг горизонтальной и вертикальной сетки.

Также для рассеяния символов можно использовать параметры Смещение по X и Смещение по Y.

Для элемента Штриховка настраиваются параметры отображения линий штриховки внутренней области ПТО.

При необходимости можно создать ПТО только с заливкой, не добавляя больше никаких элементов.

См. также

Работа с классификатором


Семантические свойства (Классификатор)

Для разных типов объектов состав и формат атрибутов может быть разный. Информация о возможных атрибутах для каждого типа и их форматах хранится в классификаторе и представлена в виде таблицы.

Список семантических свойств может быть задан не только для тематического объекта (ТО), но и для слоя. В этом случае все семантические свойства из этого списка будут относиться к каждому дочернему слою и каждому ТО из данного слоя.

Следует отличать описание атрибутов тематического объекта, которое задается и хранится в классификаторе, от значений самих атрибутов, закрепленных за конкретным тематическим объектом и введенных вручную в таблице Тематические объекты проекта или импортированных из файла.

См. также

Работа с классификатором


Команда Экспорт проекта (меню Файл/Экспорт растра)

Схема соответствия экспорта (Классификатор)

В классификаторе можно выполнить настройку схем соответствия для экспорта данного ТО из системы ВЕКТОРИЗАТОР в форматы AutoCAD, MapInfo.

Под настройкой схемы соответствия в первую очередь понимается настройка графического отображения тематических объектов, которые в зависимости от системы могут быть представлены блоками (в AutoCAD) или шрифтами (MapInfo), стилями линий и контурами.

Настройка схемы соответствия выполняется в окне Схемы соответствия экспорта (меню Файл либо меню Вид). Окно разделено на две части, в одной из которых производится работа со схемами соответствия (создание, удаление и т.п.). Вторая часть – окно параметров, состав которого зависит как от типа системы кодирования, так и от типа объекта.

Для того, чтобы настроить Схему соответствия, необходимо предварительно выбрать тематический объект, а затем устанавливать необходимые настройки.

Можно создать неограниченное количество схем соответствия, которые будут храниться непосредственно за классификатором. При экспорте данных проекта в одну из возможных систем необходимо выбрать схему соответствия, созданную для этой системы, после чего экспортируемые ТО будут преобразованы согласно требуемому виду и сохранены в файле.

На панели инструментов расположены следующие команды:

– Создать схему. После выбора команды создается новая схема. При необходимости ее можно переименовать, нажав клавишу <F2>.

– Создать копию схемы. Метод активен только при выбранной существующей схеме соответствия. При нажатии на кнопку создается новая схема, параметры которой полностью соответствуют исходной.

– Удалить схему. После нажатия на кнопку выдается запрос на подтверждение удаления выбранной схемы.

– выбор формата. Из выпадающего списка выбирается формат, для экспорта в который настраивается схема соответствия.

Раздел параметров содержит список, зависящий от типа тематического объекта и от системы кодирования. Значения параметров выбираются из выпадающего списка.

Для каждой системы можно создать неограниченное количество схем соответствия, которые будут храниться непосредственно за Классификатором. При экспорте данных проекта в одну из возможных систем необходимо выбрать схему, созданную для этой системы, после чего экспортируемые ТО будут преобразованы к требуемому виду и сохранены в файле.

См. также

Экспорт

Работа с классификатором


Работа в окне Тематические объекты (Классификатор)

В окне Тематические объекты представлен список дочерних слоев выбранного в окне Слои слоя, а также список тематических объектов, содержащихся в выбранном слое.

На панели инструментов окна расположены команды редактирования и управления содержимым слоя:

– Вставить строку – вставляет строку с новым тематическим объектом в таблицу над выделенным элементом.

– Удалить строку – удаляет выделенный элемент.

– Копировать – копирует выделенный элемент в буфер обмена.

– Вставить – вставляет элемент из буфера обмена.

– Найти – вызывает диалог Найти в таблице Тематические объекты.

– Ведомости – формирует отчет по всем или выбранным тематическим объектам окна.

– Настройки – вызывает диалог Настройка представления таблиц.

– Вставить слой – вставляет строку с новым слоем в таблицу над выделенным элементом.

– Показать все вложенные. При нажатой кнопке в таблице выводятся все элементы родительских слоев, включая ТО и дочерние слои.

– Вверх – отображение информации на уровень выше относительно выбранного слоя.

– Поле выбора слоя классификатора. Из выпадающего списка выберите родительскую папку. Наличие этого поля обеспечивает "самодостаточность" окна ТО, возможность работать с ним при закрытом окне слоев.

Двойной щелчок на строке слоя изменяет родительский слой на выбранный.

Для создания ТО выберите в окне Слои слой, в котором будет создаваться объект. В окне Тематические объекты добавьте новую строку с помощью команды Вставить строку и введите Имя создаваемого объекта.

Если не ввести имя, строка автоматически удалится при выборе другого ТО или слоя.

Описание слоя или тематического объекта включает следующие параметры:

Имя. Имя слоя или наименование тематического объекта.

Базовый код – код тематического объекта, используемый при полевом кодировании.

Тип. Для слоя имеет значение Слой, для тематического объекта задает геометрический тип объекта и может принимать одно из трех значений:

Точечный. Геометрическое описание задается в виде пункта с заданными плановыми координатами. Объект отображается в графическом окне и на чертеже точечным условным знаком.

Линейный. Геометрическое описание задается в виде составной кривой, сегментами которой служат прямолинейные отрезки и дуги окружностей. Объект отображается в графическом окне и на чертеже линейным условным знаком.

Площадной. Объект представляет собой замкнутую область, границей которой служит составная кривая. Объект отображается в графическом окне и на чертеже площадным условным знаком.

Тип знака устанавливается в панели Стиль условного знака (см. Окно Параметры условного знака).

Рельеф. Признак отношения объекта к цифровой модели рельефа. Для точечного объекта этот признак определяет участие точки в моделировании рельефа, для линейных объектов – формирование структурной линии рельефа, для площадных – формирование контура рельефа. Этот признак является умолчанием и используется в процессе импорта, если в кодовой строке отсутствует поле, задающее отношение объекта к рельефу.

Путь. Отображается полный путь к родительскому слою.

Коды тематических объектов классификатора не доступны для редактирования, если они используются в каком-либо открытом проекте. Для редактирования или удаления кодов закройте проекты, в которых они используются. Следует, однако, помнить, что связь тематических объектов проекта с их описанием в классификаторе осуществляется через код, и при повторном открытии этих проектов будет потеряно семантическое описание объектов, код которых не найден в классификаторе.


Создание, открытие и сохранение классификатора

Для создания нового классификатора выполните команду Создать/Классификатор меню Файл.

По умолчанию новому классификатору присваивается имя Классификатор1, которое при необходимости можно изменить. Последующие новые проекты будут называться Классификатор2, Классификатор3 и т.д. Эти имена предлагаются в качестве имени файла при первой попытке сохранения классификатора с помощью команды Сохранить меню Файл.

Классификаторы хранятся в виде файлов с расширением CLS4. Для открытия существующего классификатора:

Выберите в меню Файл команду Открыть или нажмите клавиши <Ctrl + О>.

В панели Открыть проект в списке Тип файлов из выпадающего списка выберите формат файла классификатора.

Выберите нужный файл, нажмите кнопку Открыть.

Для сохранения активного классификатора выберите в меню Файл команду Сохранить или нажмите клавиши <Ctrl+S>. Для сохранения классификатора на диске под другим именем:

Выберите в меню Файл команду Сохранить как….

В панели Сохранить проект укажите тип и имя файла.

Нажмите кнопку Сохранить.

При первом сохранении классификатора, созданного за время текущего сеанса, по команде Сохранить меню Файл откроется панель Сохранить проект. Далее сохранение файла производится по описанному выше сценарию.

Для сохранения всех открытых классификаторов выполните команду Сохранить все меню Файл.


Работа в окне слои

Слои классификатора имеют иерархическую структуру и представлены в окне Слои в виде древовидного списка. Работа со списком слоев включает:

Создание слоя

В классификаторе один слой (корневой) присутствует всегда. Чтобы создать новый слой:

Выберите в окне Слои слой того уровня, на котором необходимо создать новый слой.

Выполните команду Вставить строку в контекстном меню или нажмите кнопку [image] Вставить строку на панели инструментов окна Слои. Слой можно вставить также с помощью клавиши <Ins>.

Новый слой создастся над выбранным слоем.

При необходимости переименуйте слой, или измените его свойства.

Удаление слоя

Чтобы удалить слой, выполните команду Удалить строку контекстного меню или нажмите кнопку [image] Удалить строку на панели инструментов окна Слои. Слой можно удалить также с помощью клавиши <Del>.

Переименование слоя

Для переименования дважды кликните на слое. Имя слоя станет доступным для редактирования.

Перемещение слоя

Перемещение слоев может производиться как с сохранением родительского слоя, так и со сменой родительского слоя. В обоих случаях слой перемещается вместе со своими подслоями.

Перемещение производится интерактивно, перетаскиванием слоя в нужное место.

Копирование слоя

Выделите слой, который нужно скопировать. Выполните команду Копировать контекстного меню или нажмите кнопку [image] Копировать на панели инструментов окна Слои. Слой можно скопировать также с помощью клавиши <Ctrl+C>.

Команда Вырезать слой

Слой можно вырезать и вставить в любое нужное место в иерархии слоев. Для этого выделите слой, выполните команду Вырезать контекстного меню или выполните эту команду с помощью горячих клавиш <Ctrl+X>.

Вставка слоя

Скопированный или вырезанный слой помещается в буфер обмена. Затем его можно вставить в нужное место с помощью команды Вставить, вызвав ее из контекстного меню, нажав кнопку [image] Вставить на панели инструментов окна Слои, или с помощью горячих клавиш <Ctrl+V>. Слой из буфера обмена вставится над выделенным слоем.


Окно параметры условного знака

Составной частью УЗ могут являться символы. На основе символа создается точечный УЗ, символы могут отображаться вдоль траектории линейных УЗ и использоваться для заполнения площадных УЗ.

В качестве символов используются файлы в формате SVG. Данный формат содержит законченное векторное изображение с фиксированным размером, цветами линий и заливки.

Создание и редактирование символов осуществляется внешними редакторами (например, CorelDraw).

Описание тематического объекта в классификаторе предусматривает задание типа условного знака (УЗ) и настройку его параметров в окне Параметры УЗ.

Окно содержит панель инструментов, на которой расположены элементы управления для загрузки, редактирования и сохранения УЗ:

– Вставить строку – вставляет новый элемент для описания линейного или площадного ТО.

– Удалить строку – удаляет элемент.

– Сохранить как – сохраняет условный знак в виде файла с расширением MSX.

– Открыть – загружает условный знак, сохраненный в формате MSX.

Порядок редактирования параметров УЗ

Для редактирования параметров существующего или вновь созданного ТО выберите объект в окне Тематические объекты.

В окне Параметры УЗ отобразятся параметры выбранного тематического объекта.

При необходимости на панели Тип УЗ выберите тип условного знака из выпадающего списка: Точечный, Линейный или Площадной.

Тип условного знака недоступен для редактирования, если классификатор используется в каком-либо открытом проекте. Для редактирования типа УЗ закройте проекты, в которых используется классификатор.

В окне Параметры УЗ задайте необходимые параметры условного знака. Перечень параметров зависит от типа УЗ:

Точечный УЗ

Точечный (ПВО) – в поле Тип таблицы Тематические объекты классификатора для точечных ТО с установленным флагом имя типа отображается как Точечный (ПВО). Это дает возможность выполнить сортировку по данному полю и быстро найти ТО, которые используются для отображения УЗ пунктов.

Символ

Х – координаты левого верхнего угла относительно точки привязки по оси Х.

Точка привязки УЗ – это точка в его изображении, которая совмещается с заданной точкой в графическом окне при позиционировании символа.

Y – координаты левого нижнего угла относительно точки привязки по оси Y.

Высота – высота условного знака.

Символ svg – поле для выбора и загрузки символа svg. Стандартный диалог открытия символа вызывается при двойном клике в поле отображения символа.

Линейный УЗ

Линейный УЗ представляет собой композицию элементов, расположенных вдоль траектории линейного объекта. Элементы могут быть трех типов: сегменты линий, текст (однострочный) и символы SVG.

Линейный (ПВО) – в поле Тип таблицы Тематические объекты классификатора для линейных ТО с установленным флагом имя типа отображается как Линейный (ПВО). Это дает возможность выполнить сортировку по данному полю и быстро найти ТО, которые используются для отображения УЗ пунктов.

Период – период повторения символа.

В зависимости от того, какое значение принимает следующий элемент, меняется перечень описывающих его параметров. Из выпадающего списка выберите значение: Символ, Линия, Текст.

Символ

Смещение по Х – смещение символа относительно траектории по оси Х (вдоль траектории) в рамках заданного периода повторения.

Смещение по Y – смещение символа относительно траектории по оси Y (поперек траектории).

Угол – угол поворота символа относительно траектории.

Периодичность – выбор значения из выпадающего списка: Период – символ располагается с заданным периодом, В начале – символ расположен в начале объекта, В конце – символ расположен в конце объекта.

Высота – высота условного знака.

Символ svg – поле для выбора и загрузки символа svg. Стандартный диалог открытия символа вызывается при двойном клике в поле отображения символа.

Линия

Смещение по Х – смещение сегментов линии относительно траектории по оси Х (вдоль траектории) в рамках заданного периода повторения.

Смещение по Y – смещение сегментов линии относительно траектории по оси Y (поперек траектории).

Угол – угол поворота сегментов линии относительно траектории.

Периодичность – выбор значения из выпадающего списка: Период – сегменты линии располагаются с заданным периодом, В начале – сегмент линии расположен в начале объекта, В конце – сегмент линии расположен в конце объекта.

Толщина – толщина сегментов линии.

Длина – сегмента линии.

Цвет – цвет линии.

Расположение – если параметры Угол или Смещение по Y ненулевые, то значение параметра равно Независимая прямая. Если Расположение = Изгибать с линией, то Угол и Смещение по Y недоступны для редактирования.

Текст

Смещение по Х – смещение текста относительно траектории по оси Х (вдоль траектории) в рамках заданного периода повторения.

Смещение по Y – смещение текста относительно траектории по оси Y (поперек траектории).

Угол – угол поворота текста относительно траектории.

Периодичность – выбор значения из выпадающего списка: Период – текст располагаются с заданным периодом, В начале – текст расположен в начале объекта, В конце – текст расположен в конце объекта.

Шрифт – выбор шрифта из стандартного диалога.

Высота – высота шрифта.

Цвет – цвет шрифта.

Текст – текстовая строка.

Площадной УЗ

Площадной тематический объект представляет собой замкнутую область, ограниченную составной кривой. Графическое описание площадного объекта включает различные элементы заполнения площадного ТО: символ, заливка, штриховка. В зависимости от того, какое значение принимает следующий элемент: Символ, Заливка или Штриховка, меняется перечень описывающих его параметров.

Символ

Высота – высота условного знака.

Смещение по Х – смещение символа относительно узла сетки по оси Х.

Смещение по Y – смещение символа относительно узла сетки по оси Y.

Угол – угол поворота символа относительно траектории.

Рассеяние размера – отклонение (в % ) от заданного размера символа.

Рассеяние положения – отклонение (в % ) положения символа от узла сетки.

Рассеяние угла – отклонение (в % ) от заданного угла поворота.

Шаг сетки горизонтальный – расстояние между горизонтальными линиями сетки в мм.

Шаг сетки вертикальный – расстояние между вертикальными линиями сетки в мм.

Шахматный порядок – при установленном флажке символы площадного УЗ располагаются в шахматном порядке.

Символ svg – поле для выбора и загрузки символа svg. Стандартный диалог открытия символа вызывается при двойном клике в поле отображения символа.

Заливка

Цвет – поле для выбора цвета заливки. Диалог выбора цвета вызывается двойным кликом в области значения параметра.

Штриховка

Толщина – толщина линии штриховки.

Угол – угол наклона штриховых линий относительно горизонтали.

Шаг сетки горизонтальный – расстояние между горизонтальными линиями штриховки в мм.

Цвет – цвет линии штриховки.

См. также

Работа в окне Тематические объекты


Команда Замкнуть ЛТО (Рельеф и ситуация)

Замкнуть ЛТО

Команда позволяет замкнуть существующий ЛТО в окне план. Замыкание предполагает соединение первой и последней точки ЛТО линейным сегментом.

Порядок работы:

Выберите команду Замкнуть ЛТО в меню Рельеф и ситуация (кнопка [image] Замкнуть ЛТО на панели инструментов).

Если ЛТО не выбран, клик по ЛТО в окне план его замыкает. Если ЛТО выбран, вызов команды его замыкает. В обоих случаях команда остается активна и можно замыкать другие ЛТО.

См. также

Работа с тематическими объектами


Команда не реализована

Команда

Команда не реализована


Команда "201"

Команда

Раздел Справочной системы в разработке


Команда Экспорт фрагментов (меню Файл/Экспорт растра)

Экспорт Фрагментов

Команда осуществляет экспорт выбранного фрагмента (фрагментов) в файл указанного формата, обеспечивая тем самым "сшивку" (объединение) выбранных фрагментов в единое растровое поле.

При экспорте фрагмента учитывается область видимости фрагмента.

Участки фрагментов, не попадающие в область видимости, заливаются белым цветом.

Порядок работы:

Выберите фрагменты, которые необходимо экспортировать.

Вызовите команду Экспорт фрагментов меню Файл/Экспорт растра (кнопка Экспортировать выбранные фрагменты в растр [image] на панели инструментов). Эту команду можно вызвать из контекстного меню, вызываемого правой клавишей мыши, когда курсор находится на фрагменте.

В открывшемся диалоге Сохранить растр в поле Тип файлов укажите требуемый формат. В поле Имя файла введите имя сохраняемого растра.

Нажмите кнопку Сохранить или клавишу <Enter>.

В открывшемся диалоге Экспорт выберите Тип привязки экспортируемого растра (См. команду Экспорт проекта).

При необходимости можно изменить размер по горизонтали и вертикали, Глубину цвета (монохромный (1 бит), оттенки серого (8 бит), индексированный (8 бит), цветной (32 бит)).

По умолчанию размер экспортируемого растра всегда устанавливается по разрешению фрагмента с максимальным разрешением. При изменении значения в одном поле, значение в другом поле автоматически пересчитывается, т.е. пропорции растра остаются без изменения.

После ввода всех настроек нажмите кнопку ОК.

См. также

Экспорт


Команда Экспорт контура (меню Файл/Экспорт растра)

Экспорт контура

Команда осуществляет экспорт части проекта, ограниченной контуром чертежа, в файл указанного формата, обеспечивая тем самым "сшивку" (объединение) фрагментов в единое растровое поле.

Команда доступна только в том случае, если построен контур чертежа.
При использовании этой команды экспортируются все видимые части фрагментов проекта, попадающих внутрь контура.

Порядок работы:

Создайте контур с помощью команды Создать контур чертежа (меню Чертежи) .

Вызовите команду Экспорт контура меню Файл/Экспорт растра (кнопка Экспортировать в растр по контуру [image] на панели инструментов). Эту команду можно вызвать из контекстного меню, вызываемого правой клавишей мыши, когда выбран контур чертежа.

В открывшемся диалоге в списке Тип файлов укажите формат. В поле Имя файла задайте имя экспортируемого растра.

Нажмите кнопку Сохранить или клавишу <Enter>.

В открывшемся диалоге Экспорт выберите Тип привязки экспортируемого растра (См. команду Экспорт проекта).

При необходимости можно изменить размер по горизонтали и вертикали, Глубину цвета (монохромный (1 бит), оттенки серого (8 бит), индексированный (8 бит), цветной (32 бит)).

По умолчанию размер экспортируемого растра всегда устанавливается по разрешению фрагмента с максимальным разрешением. При изменении значения в одном поле, значение в другом поле автоматически пересчитывается, т.е. пропорции растра остаются без изменения.

После ввода всех настроек нажмите кнопку ОК.

См. также

Экспорт


Команда Экспорт проекта (меню Файл/Экспорт растра)

Экспорт Проекта

Команда сохраняет проект, который может состоять из нескольких растровых фрагментов, в файл указанного формата, обеспечивая тем самым "сшивку" (объединение) фрагментов в единое растровое поле.

При использовании этой команды экспортируются все видимые фрагменты проекта.

При экспорте фрагментов учитываются их контуры видимости.

Порядок работы:

Вызовите команду Экспорт проекта меню Файл/Экспорт растра (кнопка Экспортировать проект в растр [image] на панели инструментов).

В открывшемся диалоге Сохранить растр в поле Тип файла укажите один из форматов. В поле Имя файла задайте имя экспортируемого проекта.

Нажмите кнопку Сохранить или клавишу <Enter>.

В открывшемся окне Экспорт выберите Тип привязки экспортируемого растра.

Выпадающий список Тип привязки зависит от выбранного формата файла в диалоге Сохранить растр.

При необходимости можно изменить размер по горизонтали и вертикали, Глубину цвета (монохромный (1 бит), оттенки серого (8 бит), индексированный (8 бит), цветной (32 бит)).

По умолчанию размер экспортируемого растра всегда устанавливается по разрешению фрагмента с максимальным разрешением. При изменении значения в одном поле, значение в другом поле автоматически пересчитывается, т.е. пропорции растра остаются без изменения.

После ввода всех настроек нажмите кнопку ОК.

Команда Экспорт проекта доступна также из контекстного меню, вызываемого правой клавишей мыши, когда курсор мыши находится за пределами растрового фрагмента.

См. также

Экспорт


Команда Матрицы высот (меню Файл/Импорт)

Матрицы высот

Команда предназначена для импорта матриц высот.

Матрицы высот импортируются в проект уже привязанными к системе координат. После импорта они автоматически блокируются.

Порядок импорта:

Вызовите команду Импорт/Матрицы высот меню Файл (кнопка [image] Импортировать матрицы высот (GeoTIFF, MTW, SRTM ASCII) на панели инструментов).

В открывшемся стандартном окне открытия файла выберите тип импортируемой матрицы и файлы матриц.

Данные SRTM и ASTER GDEM распространяются в формате GeoTIFF, поэтому они объединены в одном пункте Файлы GeoTIFF (*.tiff *.tif *.tff).

В проект можно импортировать одновременно файлы матриц разных типов (тип файлов должен быть = Все поддерживаемые форматы).

После импорта последнего выбранного файла появляется диалоговое окно с сообщением о завершении импорта. По нажатию на кнопку Отчёт раскрывается отчёт о результатах импорта.

Нажмите кнопку ОК. Матрицы загрузятся в проект (отображаются в окне План и в таблице Фрагменты).

См. также

Импорт


Команда Импорт матрицы по шаблону (меню Файл/Импорт)

Импорт матрицы по шаблону

Команда предназначена для импорта матриц высот по шаблону, записанных в текстовые файлы. Поддерживается импорт матриц высот, записанных в три столбца (координаты и высота) или построчно (в файле содержится только информация о привязке матрицы и высоты; одна строка файла – одна строка матрицы).

Порядок импорта

Вызовите команду Импорт матрицы по шаблону меню Файл/Импорт (кнопка Импорт матрицы по шаблону [image] на панели инструментов). Откроется окно утилиты Импорт матрицы высот по шаблону.

В окне утилиты загрузите импортируемый файл (команда Файл/Открыть). В левой части утилиты построчно отображаются данные выбранного файла. При этом отображается только часть файла.

Настройте шаблон импорта (Шаблон/Свойства) - подробно о настройке см. раздел ниже.

Выберите одну или несколько строк в левой части окна и конвертируйте их в правую часть окна (Правка/Конвертировать (добавление)).

Если результат конвертации вас устраивает, воспользуйтесь командой Файл/Импорт для передачи данных в программу ВЕКТОРИЗАТОР.

Если в наборе импортируемых данных содержатся данные о привязке матрицы, после выполнения команды Импорт данные обрабатываются и передаются в проект.
Если данные о привязке не определены (импортируется матрица По строкам), то после выполнения команды Импорт откроется диалог Область матрицы высот для привязки.

Задайте размер и область матрицы нажмите кнопку ОК.

Откроется окно с сообщением о завершении импорта. По нажатию на кнопку Отчёт раскрывается отчёт о результатах импорта. Нажмите кнопку ОК. Матрица загрузится в проект.

Независимо от того, сколько строк было конвертировано из левой части окна в правую, обрабатывается и импортируется всё содержимое выбранного файла.

Настройка и использование шаблона

Настройка параметров шаблона осуществляется в диалоге Свойства шаблона, который вызывается командой Шаблон/Свойства в окне утилиты Импорт матрицы высот по шаблону.

В группе Представление данных раздела Общие следует, в зависимости от того как представлен файл, выбрать формат представления данных (По столбцам или По строкам).

Если формат представления установлен По столбцам, при конвертации в правой панели будет создано столько столбцов, сколько элементов содержится в строке.

Если формат представления установлен По строкам, при конвертации в правой панели будет создан только один столбец Высота.

В группе Разделители необходимо задать использующиеся в файле разделители между значениями полей. Если разделителями являются символы, то они вводятся в текстовую строку, если же поля отделены пробелами или табуляцией, устанавливаются флажки параметров Пробел или Табуляция.

В разделе Единицы измерения выполняются настройки представления координат и единиц измерений, использующиеся в файле.

Созданный шаблон можно сохранить для последующего использования при помощи команды Шаблон/Сохранить.

Для автоматической загрузки шаблона при запуске утилиты импорта необходимо открыть нужный шаблон и выбрать команду Установить по умолчанию в меню Шаблон.

См. также

Импорт


Команда Сканировать (меню Файл/Сканирование)

Сканировать

Команда запускает программу сканера, позволяющую сделать необходимые настройки и сканировать картографический материал.

Чтобы сканировать исходный материал:

Выберите команду Сканирование/Сканировать в меню Файл (кнопка Сканировать [image] на панели инструментов).

На экране появится окно программы сканирования, вид которого зависит от установленного в системе сканера.

Выполните необходимые настройки и запустите процесс сканирования. Воспользуйтесь, при необходимости, инструкцией к сканеру.

Результатом работы команды является получение электронной подложки.

См. также

Выбрать источник


Команда Выбрать источник (меню Файл/Сканирование)

Выбрать источник

Команда позволяет выбрать сканирующее устройство.

Чтобы выбрать сканирующее устройство:

Выберите команду Сканирование/Выбрать источник в меню Файл (кнопка Выбрать источник [image] на панели инструментов)..

В открывшемся списке выберите сканирующее устройство, если их несколько.

Нажмите кнопку ОК.

Для того, чтобы сканировать изображение, необходимо выбирать сканер, программная поддержка работы которого установлена на компьютере.

Если программная поддержка работы выбранного сканера не установлена, появляется информационное сообщение об ошибке сканирования.

См. также

Сканировать


Функционал программы ТРАНСФОРМ

При наличии лицензии ТРАНСФОРМ пользователь может использовать функционал этой программы непосредственно в программе ВЕКТОРИЗАТОР.

Программа ТРАНСФОРМ предназначена для обработки растровых картографических изображений.

В результате работы программы создается электронная растровая подложка, которая может использоваться в системах комплекса КРЕДО и других проектирующих и геоинформационных системах, а также для выпуска чертежей, топопланов и схем, оформленных в соответствии с действующими нормативными документами.

В программе реализованы следующие функции:

сканирование;

импорт растровых данных;

просмотр в пользовательской системе координат картографических материалов интернет-сервисов WMS (веб-карты);

возможность сохранения выбранного фрагмента веб-карты с заданным уровнем детализации в проект в пользовательской системе координат;

возможность регулировки прозрачности отдельных фрагментов растровых изображений;

работа с высотными растрами (DEM – Digital Elevation Model);

интерактивное перемещение импортированных фрагментов относительно друг друга;

трансформация – устранение линейных и нелинейных искажений растрового материала, обусловленных деформацией исходного материала, погрешностью сканирования;

склейка растровых фрагментов с изменением масштаба и разворотом относительно исходного, выбранного фрагмента;

топографическая привязка растровых фрагментов к прямоугольной системе координат;

устранение "несводок" контуров на смежных фрагментах;

поворот растровых фрагментов на произвольный угол и углы кратные 90°;

обрезка прямоугольным контуром;

наложение на растровые фрагменты многоугольных контуров видимости произвольной формы;

сшивка растровых фрагментов в единое растровое поле с учетом контуров видимости;

редактирование растровых изображений с помощью набора инструментов;

печать чертежей, оформленных в соответствии с нормативными документами; разбивка на листы, если размер чертежа превышает формат печатающего устройства;

экспорт подготовленной растровой подложки в системы ArcView, MapInfo, PHOTOMOD и др.

Для устранения нелинейных искажений картматериала используется метод кусочно-линейной трансформации, который позволяет получать качественные изображения, в определенной степени исправляя такие дефекты, как складки бумаги, участки с неравномерным масштабом и другие. Одновременно обеспечивается привязка обрабатываемых растровых фрагментов к выбранной пользователем системе координат, которая может быть основана на одной из картографических проекций – Mercator, Transverse Mercator, PseudoMercator и т.д. Также пользователь может не назначить систему координат и работать в локальных координатах.

Трансформация растра осуществляется по задаваемым пользователем опорным точкам, координаты которых известны, – абсолютным опорным точкам. Такими точками могут быть кресты координатной сетки, пункты обоснования, координированные углы зданий и т. п. Если используемая система координат основана на картографической проекции, то при смене системы координат автоматически выполняется пересчет опорных точек и трансформация растра. При этом в программе отслеживаются искажения в центральной части растра и, если они не превышают величину равную половине пикселя, то выполняется аффинное преобразование, в остальных случаях – кусочно-линейное преобразование.

Имеется специальный механизм устранения "несводок" контуров соседних фрагментов растра. Для устранения "несводок" контуров на каждом из смежных фрагментов в области их перекрытия задаются дополнительные опорные точки без указания координат – относительные опорные точки. Обычно такие точки задаются в характерных местах изображения: на колодцах, осветительных мачтах, пересечениях линий, отдельно стоящих деревьях. В процессе трансформации соответствующие относительные опорные точки соседних фрагментов совмещаются.

Реализован механизм склейки фрагментов по относительным опорным точкам, позволяющий, используя различные алгоритмы трансформации, выполнить разворот и изменение масштаба фрагментов, входящих в проект.

В процессе задания опорных точек для каждого растрового фрагмента рассчитываются значения уклонений по осям абсцисс (dN), ординат (dE), абсолютной величине смещения (dS), позволяющие оценить корректность задания координат опорных точек или степень искажения исходного материала.

Для отображения на экране или чертеже только необходимых участков изображения служит механизм работы с контурами видимости. Контур видимости представляет собой многоугольник произвольной формы, накладываемый на растровый фрагмент, позволяющий скрыть часть проекта, лежащую за пределами контура. Контуры видимости соседних растровых фрагментов легко сопрягаются между собой, обеспечивая "сшивку" фрагментов по произвольной траектории.

ТРАНСФОРМ позволяет экспортировать проект, состоящий из произвольного количества растровых фрагментов, в единый файл, обеспечивая тем самым объединение всех фрагментов в единое растровое поле.

Для выпуска проектной документации в соответствии с действующими нормативными документами в программу встроен компоновщик чертежей. Он позволяет разместить на стандартных листах отдельные растровые фрагменты произвольной формы, оформить листы чертежей в соответствии с ГОСТом, дополнить чертеж надписями, разбить чертеж формата, превышающего формат печатающего устройства, на склеиваемые листы. Печать производится в масштабе съемки. Подготовленный в ТРАНСФОРМ чертеж можно сохранить в файл, что позволяет создавать электронные архивы чертежей.


Команда Вставить объект/Шаблон чертежа (меню Правка)

Шаблон чертежа

Команда вставляет шаблон чертежа в чертеж.

Выберите команду (кнопка Вставить шаблон чертежа [image] на панели инструментов).

В открывшемся стандартном диалоге Открыть шаблон чертежа выберите необходимый файл. Нажмите кнопку Открыть.

Вставленный объект при необходимости можно отредактировать либо интерактивно, либо в окне параметров.

Для интерактивного редактирования:

При выборе объекта в графическом окне доступны стандартные интерактивные методы, позволяющие выполнить масштабирование, перемещение и поворот.

После выбора объекта в окне свойств отображаются его параметры, которые также можно отредактировать.

При двойном клике в поле Имя шаблона откроется диалог Открыть шаблон чертежа, в котором можно выбрать другой шаблон. Выбранный шаблон заменит вставленный ранее. Введите либо отредактируйте остальные параметры.

Удалить выделенный объект можно кнопкой [image] Удалить на панели инструментов, либо клавишей <Delete>.

Ваши комментарии к справочной системе

© Компания "Кредо-Диалог" Компания "Кредо-Диалог"


Команда Вставить объект/Документ *.html (меню Правка)

Документ *.html

Команда вставляет документ HTML в чертеж.

Выберите команду (кнопка Вставить документ html [image] на панели инструментов).

В открывшемся стандартном диалоге Открыть html документ выберите необходимый файл. Нажмите кнопку Открыть.

Вставленный объект при необходимости можно отредактировать. Для этого:

Выберите html документ в графическом окне. При выборе объекта в графическом окне доступны стандартные интерактивные методы, позволяющие выполнить масштабирование, перемещение и поворот.

После выбора объекта в окне свойств отображаются его параметры, которые также можно отредактировать.

Удалить выделенный объект можно кнопкой [image] Удалить на панели инструментов, либо клавишей <Delete>.

Ваши комментарии к справочной системе

© Компания "Кредо-Диалог" Компания "Кредо-Диалог"


Команда Вставить объект/Рисунок (меню Правка)

Рисунок

Команда вставляет рисунок в чертеж.

Выберите команду (кнопка Вставить рисунок [image] на панели инструментов).

В открывшемся стандартном диалоге Открыть файл рисунка выберите необходимый файл. Для выбора доступны файлы с расширениями: JPG, BMP, PNG, GIF, ICO, MNG, SVG, TIFF. Нажмите кнопку Открыть.

Вставленный объект при необходимости можно отредактировать либо интерактивно, либо в окне параметров.

Для интерактивного редактирования:

При выборе объекта в графическом окне доступны стандартные интерактивные методы, позволяющие выполнить масштабирование, перемещение и поворот.

После выбора объекта в окне свойств отображаются его параметры, которые можно отредактировать.

Удалить выделенный объект можно кнопкой [image] Удалить на панели инструментов, либо клавишей <Delete>.

Ваши комментарии к справочной системе

© Компания "Кредо-Диалог" Компания "Кредо-Диалог"


Команда Вставить объект/Проект *.gds (меню Правка)

Проект

Команда вставляет в чертеж фрагмент проекта TMD. Граница фрагмента соответствует экстремальной области всей графической информации, видимой в проекте на момент вставки.

Выберите команду (кнопка Вставить проект [image] на панели инструментов).

В открывшемся стандартном диалоге Открыть проект с содержимым фрагмента выберите необходимый файл. Нажмите кнопку Открыть.

Вставленный объект при необходимости можно отредактировать либо интерактивно, либо в окне параметров.

Для интерактивного редактирования:

При выборе объекта в графическом окне доступны стандартные интерактивные методы, позволяющие выполнить масштабирование, перемещение и поворот.

После выбора объекта его параметры отображаются в окне свойств, их можно отредактировать.

Удалить выделенный объект можно кнопкой [image] Удалить на панели инструментов, либо клавишей <Delete>.

Ваши комментарии к справочной системе

© Компания "Кредо-Диалог" Компания "Кредо-Диалог"


Команда Вставить объект/Шаблон штампа (меню Правка)

Шаблон штампа

Команда вставляет шаблон штампа в чертеж.

Выберите команду (кнопка Вставить шаблон штампа [image] на панели инструментов).

В открывшемся стандартном диалоге Открыть шаблон штампа выберите необходимый файл, предварительно подготовленный в Редакторе шаблонов. Нажмите кнопку Открыть.

При выборе объекта в графическом окне доступны стандартные интерактивные методы, позволяющие выполнить масштабирование, перемещение и поворот.

Также после выбора объекта в окне свойств отображаются его параметры, которые можно отредактировать.

При двойном клике в поле Имя шаблона откроется диалог Открыть шаблон штампа, в котором можно выбрать другой шаблон. Выбранный шаблон заменит вставленный ранее. Введите либо отредактируйте остальные параметры.

Удалить выделенный объект можно кнопкой [image] Удалить на панели инструментов, либо клавишей <Delete>.

Ваши комментарии к справочной системе

© Компания "Кредо-Диалог" Компания "Кредо-Диалог"


Диалог Найти в таблице

Диалог Найти в таблице осуществляет поиск строки, значение полей которой удовлетворяют заданному условию.

Диалог вызывается по кнопке [image] на панели инструментов таблицы, по команде Найти контекстного меню, вызываемого правой клавишей мыши или сочетанием клавиш <Ctrl + F>.

Курсор должен быть позиционирован в области таблицы.

Диалог может содержать два логических выражения. В верхней строке задается первое условие поиска, устанавливается переключатель в нужное положение (И, ИЛИ), затем в нижней строке задаются значения второго логического выражения.

Нижняя строка может быть пустой. Тогда поиск производится только по условию, заданному в первой строке.

В группе Условие:

Выберите наименование столбца из выпадающего списка заголовков всех столбцов данной таблицы (включая невидимые). Поле с наименованием столбца во втором выражении (в нижней строке) может быть пустым.

Из выпадающего списка выберите логическую операцию для данного типа поля. В нижней строке это поле доступно для редактирования, если первое поле непусто.

Введите значение для поиска в правое поле.

Установите переключатель И, ИЛИ в нужное положение.

При установленном флажке В обратном направлении поиск выполняется от текущей строки вверх до первой. В противном случае – от текущей вниз до последней.

Флажок С учетом регистра доступен только для строковых полей. Если флажок установлен, то при сравнении строк учитывается регистр.

При нажатии на кнопку Найти далее начинается поиск следующей строки, удовлетворяющей условию. Если строка найдена, то ее первая ячейка становится текущей.

При нажатии на кнопку Выбрать все в таблице выбираются (выделяются) все строки, удовлетворяющие условию.

Диалог закрывается клавишей <Esc> или кнопкой системного меню.


команда Экспорт в GDS4 (Файл/Экспорт модели)

Экспорт в GDS4

Команда сохраняет данные в файл формата GDS (КРЕДО ДАТ 4.11). Не требует настроек.

Порядок работы:

Вызовите команду Экспорт в GDS4 меню Файл/Экспорт модели (кнопка Экспорт в GDS4 [image] на панели инструментов).

В окне Экспорт в gds4 выберите папку, введите имя экспортируемого файла и нажмите кнопку Сохранить для экспорта или Отмена для отказа.


команда Экспорт в DXF (меню Файл/Экспорт модели)

Экспорт в DXF

Команда сохраняет данные в файл формата DXF.

Экспортируются все пункты и тематические объекты проекта, независимо от установленных фильтров видимости и выбора.

Схема соответствия тематических объектов должна быть создана в классификаторе заранее. См. Схема соответствия экспорта.

Порядок работы:

Выберите команду Экспорт в DXF меню Файл/Экспорт модели (кнопка Экспорт в DXF [image] на панели инструментов).

Откроется диалог Настройки экспорта в DXF:

Окно настроек разделено на две части: в левой части находится список элементов, для которых необходимо настроить параметры для экспорта, а в правой части непосредственно сами параметры.

Для выбора схемы соответствия тематических объектов необходимо выделить строку Тематические объекты и из выпадающего списка в колонке Значение выбрать нужную схему экспорта.

При необходимости для тематических объектов настраивается передача атрибутов.

Настройки остальных параметров интуитивно понятны. Настройки таких элементов модели, как точки, шрифты и т.п. выполняются непосредственно в проекте ВЕКТОРИЗАТОРа.

Элементы, которые не содержатся в списке, экспортируются "как есть", т.е. если элемент виден в проекте, то он экспортируется, причем его вид не будет отличаться от того, что мы видим в проекте ВЕКТОРИЗАТОРа.

Нажмите кнопку Экспорт.

В окне Экспорт в DXF выберите папку и введите имя экспортируемого файла, нажмите кнопку Сохранить для экспорта или Отмена для отказа.


команда Экспорт в MIF/MID (меню Файл/Экспорт модели)

Экспорт в MIF/MID

Команда сохраняет данные в файлы формата MIF/MID.

Экспортируются все пункты и тематические объекты проекта, независимо от установленных фильтров видимости и выбора.

Схема соответствия тематических объектов должна быть создана в классификаторе заранее. См. Схема соответствия экспорта.

Порядок работы:

Выберите команду Экспорт в MIF/MID меню Файл/Экспорт модели (кнопка Экспорт в MIF/MID [image] на панели инструментов).

Откроется диалог Настройки экспорта в MIF/MID:

Окно настроек разделено на две части: в левой части находится список элементов, для которых необходимо настроить параметры для экспорта, а в правой части непосредственно сами параметры.

Для выбора схемы соответствия тематических объектов необходимо выделить строку Тематические объекты и из выпадающего списка в колонке Значение выбрать нужную схему экспорта.

При необходимости для тематических объектов настраивается передача атрибутов.

Настройки остальных параметров интуитивно понятны. Настройки таких элементов модели, как точки, шрифты и т.п. выполняются непосредственно в проекте.

Элементы, которые не содержатся в списке, экспортируются как есть, т.е. если элемент виден в проекте, то он экспортируется, причем его вид не будет отличаться от того, что мы видим в проекте.

Нажмите кнопку Экспорт. Отказ от экспорта – кнопка Отмена.

В окне Экспорт в MIF выберите папку и введите имя экспортируемого файла, нажмите кнопку Сохранить для экспорта или Отмена для отказа.


Использование справочной системы

Справочная система, встроенная в приложение, вызывается командой из меню Справка [image].

Навигация в окне справки

Способ навигации в окне справки во многом похож на способ навигации на веб-сайте.

Для поиска нужной информации в данной справочной системе существует несколько способов:

Поиск и выбор нужного раздела в окне Содержание.

Поиск и выбор нужной темы или понятия в индексном указателе, расположенном на вкладке Указатель.

Вкладка Указатель содержит список ключевых слов для всех разделов справочной системы, отсортированный в алфавитном порядке. Здесь можно быстро найти нужный раздел по наименованию операции, диалогового окна или команды.

Поиск слова или словосочетания на вкладке Поиск. Осуществляется поиск разделов, содержащих заданное слово или выражение. Для поиска словосочетания целиком словосочетание следует заключить в кавычки. Результат поиска − отсортированный список разделов, содержащих введенный текст.

Выбор нужной темы на вкладке Избранное. Данная вкладка позволяет создать список наиболее часто используемых тем с целью экономии времени при последующем поиске.

Чтобы создать список на вкладке Избранное:

выберите интересующую вас страницу справочной системы;

перейдите на вкладку Избранное; в поле Текущий раздел отобразится название выбранной темы, ее можно переименовать сразу, либо после добавления (см. ниже);

нажмите кнопку Добавить;

для переименования раздела подведите курсор в окне Разделы к названию страницы и по правой клавише мыши переименуйте ее.

Чтобы просмотреть тему из списка на вкладке Избранное: выделите название в списке и нажмите кнопку Показать или дважды кликните мышью по названию раздела.

По кнопке Удалить выбранная тема удалится.


Диалог Открыть шаблон чертежа

Диалог открывает шаблон чертежа.

В левой части окна расположено поле для выбора нужной папки.

В центре отображается список файлов шаблонов (если такие имеются) или папок, содержащихся в выбранной папке. Навигация по дереву папок и управление отображением списка производится с помощью кнопок, расположенных на панели инструментов данного окна: Назад, Вперед, Родительский каталог, Создать папку, Список, Подробный вид.

Справа отображается схема шаблона, поля для выбора формата бумаги, ориентации листа а также размеры листа в мм.

В поле Имя файла отображается имя выбранного шаблона.

По кнопке Открыть выбранный шаблон загружается в проект. Кнопка Отмена закрывает диалог.

Ваши комментарии к справочной системе

© Компания "Кредо-Диалог" Компания "Кредо-Диалог"


Алгоритм интерполяции

Алгоритм интерполяции цвета используется для расчета цветов точек результирующих фрагментов при таких операциях, как поворот растровых фрагментов и трансформация и в значительной степени влияет на скорость этих операций, а также на качество изображения, получаемого в результате применения таких операций.

Алгоритм интерполяции не влияет на точность трансформации.

Алгоритм ближайших соседей – применяется для растровых изображений любой глубины цвета и обеспечивает удовлетворительные результаты при операциях над цветными и монохромными (256 оттенков серого) изображениями, сами операции выполняются намного быстрее, чем при алгоритме равномерного усреднения.

Алгоритм равномерного усреднения – самый качественный из предлагаемых алгоритмов. Значительно замедляет процесс трансформации, поворота и некоторых других операций. Рекомендуется использовать этот алгоритм для получения качественных цветных и монохромных (256 оттенков серого) фрагментов. Не имеет смысла применять его для черно-белых 1-битных фрагментов.

Быстрая трансформация 1-битных фрагментов – этот алгоритм, как правило, обеспечивает хорошие результаты при работе с 1-битными фрагментами, позволяя значительно сэкономить время. Независимо от того, включена ли эта опция, для операций с цветными фрагментами используется один из двух вышеперечисленных алгоритмов. Если эта опция выключена, для операций с 1-битными фрагментами используется тот же алгоритм интерполяции, что и для операций с цветными фрагментами. Если качество изображения, полученного в результате поворота или трансформации, неудовлетворительно, следует отключить эту опцию и использовать алгоритм равномерного усреднения.

Алгоритм преобразования координат оказывает влияние на точность трансформации и склейки. Выбор алгоритма зависит от количества и расположения опорных точек.

Аффинное преобразование – этот метод рекомендуется использовать, если для трансформации заданы опорные точки, расположенные регулярно по всему изображению в узлах координатной сетки; само растровое изображение может иметь некоторую неортогональность по осям координат.

Преобразование по Хельмерту – этот метод рекомендуется использовать, если для трансформации заданы опорные точки, расположенные нерегулярно по краям изображения или расположенные вдоль одной линии; в растровом изображении не предполагается заметных локальных деформаций (например, растр получен с планшетов на жесткой основе).

Для трансформации проекта, содержащего большой объем растровых изображений с глубиной цвета 1 бит/пиксель, рекомендуется задать больше опорных точек и использовать алгоритм быстрой трансформации 1-битных фрагментов. Выбор одного из качественных алгоритмов значительно повлияет на время трансформации.

Задать алгоритм интерполяции можно с помощью команды Свойства проекта меню Файл (вкладка Свойства диалога Свойства проекта).


Диалог Настройка представления таблиц

Диалог предназначен для управления видом и содержимым таблицы.

Диалог настройки таблиц представляет собой окно, в котором объединены все параметры таблицы, доступные для редактирования.

Диалог вызывается:

из контекстного меню таблицы;

кнопкой [image] Настройки на панели инструментов окна таблицы.

В диалоге можно изменить заголовок таблицы, а также задать имена ее столбцов и настроить их видимость.

В текстовом поле Заголовок таблицы можно задать имя таблицы, которое будет отображаться в окне программы.

В окне Столбцы приводится список столбцов выбранной таблицы. Список содержит поле с флажком видимости столбца, поля Столбец и Заголовок. Поле Заголовок можно редактировать. При установленном флажке столбец является видимым в окне таблицы, иначе – невидимым. Изменить порядок следования столбцов можно перетаскиванием их заголовков непосредственно в таблице.

Кнопка ОК сохраняет заданные настройки.

Кнопка Отмена закрывает диалог без сохранения настроек.

Кнопка Применить применяет заданные настройки.